summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/magic-enum/magic-enum_0.9.6.bb
diff options
context:
space:
mode:
authorRicardo Simoes <ricardo.simoes@pt.bosch.com>2024-08-28 09:21:38 +0200
committerKhem Raj <raj.khem@gmail.com>2024-08-28 01:25:41 -0700
commit83d9607ba5d96419db9d1d2f81d0c1c0afb72fb5 (patch)
tree7f3ec2e7e408dc984b495a5a660e495ed8a7fdc8 /meta-oe/recipes-extended/magic-enum/magic-enum_0.9.6.bb
parent48e257b4c7c8990c9afba90d5b3fcc957a1d8e73 (diff)
downloadmeta-openembedded-83d9607ba5d96419db9d1d2f81d0c1c0afb72fb5.tar.gz
magic-enum: Upgrade v0.9.5 -> v0.9.6
In version 0.9.6 issue #362 was fixed. Thus, the tweak in the compile flags is no longer needed. The checksum of the LICENSE file changed because the copyright range was updated. Changelog: https://github.com/Neargye/magic_enum/releases/tag/v0.9.6 Signed-off-by: Ricardo Simoes <ricardo.simoes@pt.bosch.com> Signed-off-by: Mark Jonas <mark.jonas@de.bosch.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/magic-enum/magic-enum_0.9.6.bb')
-rw-r--r--meta-oe/recipes-extended/magic-enum/magic-enum_0.9.6.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/magic-enum/magic-enum_0.9.6.bb b/meta-oe/recipes-extended/magic-enum/magic-enum_0.9.6.bb
new file mode 100644
index 000000000..01a134a5b
--- /dev/null
+++ b/meta-oe/recipes-extended/magic-enum/magic-enum_0.9.6.bb
@@ -0,0 +1,44 @@
1# SPDX-FileCopyrightText: 2024 Bosch Sicherheitssysteme GmbH
2#
3# SPDX-License-Identifier: MIT
4
5SUMMARY = "Static reflection for enums"
6DESCRIPTION = "Header-only C++17 library provides static reflection for enums, works \
7with any enum type without any macro or boilerplate code."
8BUGTRACKER = "https://github.com/Neargye/magic_enum/issues"
9HOMEPAGE = "https://github.com/Neargye/magic_enum"
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=7e7717cf723eb72f57e80fdb651cb318"
13
14SRC_URI = " \
15 git://github.com/Neargye/magic_enum.git;protocol=https;branch=master \
16 file://run-ptest \
17"
18
19SRCREV = "dd6a39d0ba1852cf06907e0f0573a2a10d23c2ad"
20S = "${WORKDIR}/git"
21
22inherit cmake ptest
23
24EXTRA_OECMAKE = "\
25 -DMAGIC_ENUM_OPT_BUILD_EXAMPLES=OFF \
26"
27
28do_install_ptest () {
29 install -d ${D}${PTEST_PATH}/tests
30 install -m 0755 ${B}/test/test_* ${D}${PTEST_PATH}/tests
31}
32
33# Add catkin and colcon (ROS build system) support
34FILES:${PN}-dev += "\
35 ${datadir}/magic_enum/package.xml \
36"
37
38# Header-only library
39# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
40RDEPENDS:${PN}-dev = ""
41RDEPENDS:${PN}-ptest = ""
42RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
43
44BBCLASSEXTEND = "native nativesdk"