summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libwmf
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-extended/libwmf
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-extended/libwmf')
-rw-r--r--meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch67
-rw-r--r--meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-intoverflow.patch31
-rw-r--r--meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-useafterfree.patch14
-rw-r--r--meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb30
4 files changed, 142 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch b/meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch
new file mode 100644
index 000000000..0f133e2e7
--- /dev/null
+++ b/meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch
@@ -0,0 +1,67 @@
1From 61655f82224cadb261e81f8bae111eaaa7bdf531 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 6 Aug 2014 14:53:03 +0200
4Subject: [PATCH] configure: use pkg-config for freetype
5
6Upstream-status: Pending
7Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
8---
9 configure.ac | 37 ++++++++-----------------------------
10 1 file changed, 8 insertions(+), 29 deletions(-)
11
12diff --git a/configure.ac b/configure.ac
13index 3cfe974..0055a8c 100644
14--- a/configure.ac
15+++ b/configure.ac
16@@ -399,40 +399,19 @@ AC_ARG_WITH(freetype,[ --with-freetype=DIR use freetype2 in DIR],[
17 fi
18 ])
19
20-if [ test -n "$FREETYPE_DIR" ]; then
21- AC_PATH_PROG(FREETYPE_CONFIG,freetype-config, ,[$FREETYPE_DIR/bin:$PATH])
22-else
23- AC_PATH_PROG(FREETYPE_CONFIG,freetype-config)
24-fi
25-
26-if [ test -n "$FREETYPE_CONFIG" ]; then
27- if [ test -n "$FREETYPE_DIR" ]; then
28- freetype_cflags="`$FREETYPE_CONFIG --cflags` -I$FREETYPE_DIR/include"
29- freetype_libs=`$FREETYPE_CONFIG --libs`
30- else
31- freetype_cflags=`$FREETYPE_CONFIG --cflags`
32- freetype_libs=`$FREETYPE_CONFIG --libs`
33- fi
34-else
35- if [ test -n "$FREETYPE_DIR" ]; then
36- freetype_cflags="-I$FREETYPE_DIR/include/freetype2 -I$FREETYPE_DIR/include"
37- freetype_libs="-L$FREETYPE_DIR/lib -lfreetype"
38- else
39- freetype_cflags=""
40- freetype_libs="-lfreetype"
41- fi
42-fi
43-
44-CPPFLAGS="$freetype_cflags $CPPFLAGS"
45-LDFLAGS="$LDFLAGS $freetype_libs"
46+PKG_CHECK_MODULES(FREETYPE2, freetype2,
47+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
48+ LDFLAGS="$LDFLAGS $FREETYPE2_LIBS",
49+ AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)])
50+)
51
52 AC_CHECK_LIB(freetype,FT_Init_FreeType,[
53- WMF_FT_LDFLAGS="$freetype_libs"
54+ WMF_FT_LDFLAGS="$FREETYPE2_LIBS"
55 ],[ AC_MSG_ERROR([* * * freetype(2) is required * * *])
56 ])
57 AC_CHECK_HEADER(ft2build.h,[
58- WMF_FT_CFLAGS="$freetype_cflags"
59- WMF_FT_CONFIG_CFLAGS="$freetype_cflags"
60+ WMF_FT_CFLAGS="$FREETYPE2_CFLAGS"
61+ WMF_FT_CONFIG_CFLAGS="$FREETYPE2_CFLAGS"
62 ],[ AC_MSG_ERROR([* * * freetype(2) is required * * *])
63 ])
64
65--
661.9.0
67
diff --git a/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-intoverflow.patch b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-intoverflow.patch
new file mode 100644
index 000000000..50d915c01
--- /dev/null
+++ b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-intoverflow.patch
@@ -0,0 +1,31 @@
1http://cvs.fedoraproject.org/viewvc/devel/libwmf/libwmf-0.2.8.4-intoverflow.patch?view=log
2
3CVE-2006-3376 libwmf integer overflow
4
5--- libwmf-0.2.8.4.orig/src/player.c 2002-12-10 19:30:26.000000000 +0000
6+++ libwmf-0.2.8.4/src/player.c 2006-07-12 15:12:52.000000000 +0100
7@@ -42,6 +42,7 @@
8 #include "player/defaults.h" /* Provides: default settings */
9 #include "player/record.h" /* Provides: parameter mechanism */
10 #include "player/meta.h" /* Provides: record interpreters */
11+#include <stdint.h>
12
13 /**
14 * @internal
15@@ -132,8 +134,14 @@
16 }
17 }
18
19-/* P->Parameters = (unsigned char*) wmf_malloc (API,(MAX_REC_SIZE(API)-3) * 2 * sizeof (unsigned char));
20- */ P->Parameters = (unsigned char*) wmf_malloc (API,(MAX_REC_SIZE(API) ) * 2 * sizeof (unsigned char));
21+ if (MAX_REC_SIZE(API) > UINT32_MAX / 2)
22+ {
23+ API->err = wmf_E_InsMem;
24+ WMF_DEBUG (API,"bailing...");
25+ return (API->err);
26+ }
27+
28+ P->Parameters = (unsigned char*) wmf_malloc (API,(MAX_REC_SIZE(API) ) * 2 * sizeof (unsigned char));
29
30 if (ERR (API))
31 { WMF_DEBUG (API,"bailing...");
diff --git a/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-useafterfree.patch b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-useafterfree.patch
new file mode 100644
index 000000000..4d2d28564
--- /dev/null
+++ b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-useafterfree.patch
@@ -0,0 +1,14 @@
1
2http://cvs.fedoraproject.org/viewvc/devel/libwmf/libwmf-0.2.8.4-useafterfree.patch?view=log
3Resolves: CVE-2009-1364
4
5--- libwmf-0.2.8.4/src/extra/gd/gd_clip.c.CVE-2009-1364-im-clip-list 2009-04-24 04:06:44.000000000 -0400
6+++ libwmf-0.2.8.4/src/extra/gd/gd_clip.c 2009-04-24 04:08:30.000000000 -0400
7@@ -70,6 +70,7 @@ void gdClipSetAdd(gdImagePtr im,gdClipRe
8 { more = gdRealloc (im->clip->list,(im->clip->max + 8) * sizeof (gdClipRectangle));
9 if (more == 0) return;
10 im->clip->max += 8;
11+ im->clip->list = more;
12 }
13 im->clip->list[im->clip->count] = (*rect);
14 im->clip->count++;
diff --git a/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb b/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb
new file mode 100644
index 000000000..11e2ba180
--- /dev/null
+++ b/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Library for converting WMF files"
2HOMEPAGE = "http://wvware.sourceforge.net/libwmf.html"
3SECTION = "libs"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8PR = "r3"
9
10DEPENDS_virtclass-native = "freetype-native libpng-native jpeg-native"
11DEPENDS = "freetype libpng jpeg expat gtk+"
12
13BBCLASSEXTEND = "native"
14
15inherit autotools pkgconfig
16
17SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/${BPN}/${PV}/${BPN}-${PV}.tar.gz;name=tarball \
18 file://libwmf-0.2.8.4-intoverflow.patch \
19 file://libwmf-0.2.8.4-useafterfree.patch \
20 file://0001-configure-use-pkg-config-for-freetype.patch \
21 "
22
23SRC_URI[tarball.md5sum] = "d1177739bf1ceb07f57421f0cee191e0"
24SRC_URI[tarball.sha256sum] = "5b345c69220545d003ad52bfd035d5d6f4f075e65204114a9e875e84895a7cf8"
25
26FILES_${PN}-dbg += "${libdir}/gtk-2.0/2.10.0/loaders/.debug"
27FILES_${PN}-dev += "${libdir}/gtk-2.0/2.10.0/loaders/*.la"
28FILES_${PN}-staticdev += "${libdir}/gtk-2.0/2.10.0/loaders/*.a"
29FILES_${PN} += "${libdir}/gtk-2.0/2.10.0/loaders/*.so"
30