summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libidn
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2023-03-09 08:50:19 -0800
committerKhem Raj <raj.khem@gmail.com>2023-03-09 21:58:44 -0800
commit910c70a160cca64935035e925c76645f2203ca2f (patch)
treeb2536c334299373481a265517c276111d61431a4 /meta-oe/recipes-extended/libidn
parent165fae99d83eb5910c67d303ed56561d20470fad (diff)
downloadmeta-openembedded-910c70a160cca64935035e925c76645f2203ca2f.tar.gz
libidn: update to 1.41
Adjust dont-depend-on-help2man patch to apply. Remove unneeded format warnings patch. Cosmetic changes to license files require new checksums. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libidn')
-rw-r--r--meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch180
-rw-r--r--meta-oe/recipes-extended/libidn/libidn/dont-depend-on-help2man.patch24
-rw-r--r--meta-oe/recipes-extended/libidn/libidn_1.41.bb (renamed from meta-oe/recipes-extended/libidn/libidn_1.36.bb)16
3 files changed, 21 insertions, 199 deletions
diff --git a/meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch b/meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch
deleted file mode 100644
index d5fb8e7c82..0000000000
--- a/meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch
+++ /dev/null
@@ -1,180 +0,0 @@
1Subject: [PATCH] idn: fix printf() format security warnings
2MIME-Version: 1.0
3Content-Type: text/plain; charset=UTF-8
4Content-Transfer-Encoding: 8bit
5
6| ../../libidn-1.32/src/idn.c: In function 'main':
7| ../../libidn-1.32/src/idn.c:172:7: error: format not a string literal and no format arguments [-Werror=format-security]
8| error (0, 0, _("only one of -s, -e, -d, -a, -u or -n can be specified"));
9| ^~~~~
10| ../../libidn-1.32/src/idn.c:187:5: error: format not a string literal and no format arguments [-Werror=format-security]
11| fprintf (stderr, _("Type each input string on a line by itself, "
12| ^~~~~~~
13| ../../libidn-1.32/src/idn.c:202:4: error: format not a string literal and no format arguments [-Werror=format-security]
14| error (EXIT_FAILURE, errno, _("input error"));
15| ^~~~~
16| ../../libidn-1.32/src/idn.c:220:8: error: format not a string literal and no format arguments [-Werror=format-security]
17| _("could not convert from UTF-8 to UCS-4"));
18| ^
19| ../../libidn-1.32/src/idn.c:245:8: error: format not a string literal and no format arguments [-Werror=format-security]
20| _("could not convert from UTF-8 to UCS-4"));
21| ^
22| ../../libidn-1.32/src/idn.c:281:6: error: format not a string literal and no format arguments [-Werror=format-security]
23| _("could not convert from UTF-8 to UCS-4"));
24| ^
25| ../../libidn-1.32/src/idn.c:340:6: error: format not a string literal and no format arguments [-Werror=format-security]
26| _("could not convert from UCS-4 to UTF-8"));
27| ^
28| ../../libidn-1.32/src/idn.c:364:6: error: format not a string literal and no format arguments [-Werror=format-security]
29| _("could not convert from UCS-4 to UTF-8"));
30| ^
31| ../../libidn-1.32/src/idn.c:442:8: error: format not a string literal and no format arguments [-Werror=format-security]
32| _("could not convert from UCS-4 to UTF-8"));
33| ^
34| ../../libidn-1.32/src/idn.c:498:6: error: format not a string literal and no format arguments [-Werror=format-security]
35| _("could not convert from UTF-8 to UCS-4"));
36| ^
37| ../../libidn-1.32/src/idn.c:527:5: error: format not a string literal and no format arguments [-Werror=format-security]
38| _("could not convert from UTF-8 to UCS-4"));
39| ^
40| ../../libidn-1.32/src/idn.c:540:6: error: format not a string literal and no format arguments [-Werror=format-security]
41| error (EXIT_FAILURE, 0, _("could not do NFKC normalization"));
42| ^~~~~
43| ../../libidn-1.32/src/idn.c:551:5: error: format not a string literal and no format arguments [-Werror=format-security]
44| _("could not convert from UTF-8 to UCS-4"));
45| ^
46
47Signed-off-by: André Draszik <adraszik@tycoint.com>
48Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
49
50Upstream-Status: Pending
51
52---
53 src/idn.c | 27 ++++++++++++++-------------
54 1 file changed, 14 insertions(+), 13 deletions(-)
55
56diff --git a/src/idn.c b/src/idn.c
57index f2fee11..c6e5caa 100644
58--- a/src/idn.c
59+++ b/src/idn.c
60@@ -169,7 +169,7 @@ main (int argc, char *argv[])
61 (args_info.idna_to_unicode_given ? 1 : 0) +
62 (args_info.nfkc_given ? 1 : 0) != 1)
63 {
64- error (0, 0,
65+ error (0, 0, "%s",
66 _("only one of -s, -e, -d, -a, -u or -n can be specified"));
67 usage (EXIT_FAILURE);
68 }
69@@ -183,7 +183,7 @@ main (int argc, char *argv[])
70
71 if (!args_info.quiet_given
72 && args_info.inputs_num == 0 && isatty (fileno (stdin)))
73- fprintf (stderr, _("Type each input string on a line by itself, "
74+ fprintf (stderr, "%s", _("Type each input string on a line by itself, "
75 "terminated by a newline character.\n"));
76
77 do
78@@ -195,7 +195,7 @@ main (int argc, char *argv[])
79 if (feof (stdin))
80 break;
81
82- error (EXIT_FAILURE, errno, _("input error"));
83+ error (EXIT_FAILURE, errno, "%s", _("input error"));
84 }
85
86 if (strlen (line) > 0)
87@@ -213,7 +213,7 @@ main (int argc, char *argv[])
88 if (!q)
89 {
90 free (p);
91- error (EXIT_FAILURE, 0,
92+ error (EXIT_FAILURE, 0, "%s",
93 _("could not convert from UTF-8 to UCS-4"));
94 }
95
96@@ -238,7 +238,7 @@ main (int argc, char *argv[])
97 if (!q)
98 {
99 free (r);
100- error (EXIT_FAILURE, 0,
101+ error (EXIT_FAILURE, 0, "%s",
102 _("could not convert from UTF-8 to UCS-4"));
103 }
104
105@@ -275,7 +275,7 @@ main (int argc, char *argv[])
106 q = stringprep_utf8_to_ucs4 (p, -1, &len);
107 free (p);
108 if (!q)
109- error (EXIT_FAILURE, 0,
110+ error (EXIT_FAILURE, 0, "%s",
111 _("could not convert from UTF-8 to UCS-4"));
112
113 if (args_info.debug_given)
114@@ -334,7 +334,7 @@ main (int argc, char *argv[])
115 r = stringprep_ucs4_to_utf8 (q, -1, NULL, NULL);
116 free (q);
117 if (!r)
118- error (EXIT_FAILURE, 0,
119+ error (EXIT_FAILURE, 0, "%s",
120 _("could not convert from UCS-4 to UTF-8"));
121
122 p = stringprep_utf8_to_locale (r);
123@@ -358,7 +358,7 @@ main (int argc, char *argv[])
124 q = stringprep_utf8_to_ucs4 (p, -1, NULL);
125 free (p);
126 if (!q)
127- error (EXIT_FAILURE, 0,
128+ error (EXIT_FAILURE, 0, "%s",
129 _("could not convert from UCS-4 to UTF-8"));
130
131 if (args_info.debug_given)
132@@ -436,7 +436,7 @@ main (int argc, char *argv[])
133 if (!q)
134 {
135 free (p);
136- error (EXIT_FAILURE, 0,
137+ error (EXIT_FAILURE, 0, "%s",
138 _("could not convert from UCS-4 to UTF-8"));
139 }
140
141@@ -492,7 +492,7 @@ main (int argc, char *argv[])
142 r = stringprep_ucs4_to_utf8 (q, -1, NULL, NULL);
143 free (q);
144 if (!r)
145- error (EXIT_FAILURE, 0,
146+ error (EXIT_FAILURE, 0, "%s",
147 _("could not convert from UTF-8 to UCS-4"));
148
149 p = stringprep_utf8_to_locale (r);
150@@ -521,7 +521,7 @@ main (int argc, char *argv[])
151 if (!q)
152 {
153 free (p);
154- error (EXIT_FAILURE, 0,
155+ error (EXIT_FAILURE, 0, "%s",
156 _("could not convert from UTF-8 to UCS-4"));
157 }
158
159@@ -535,7 +535,8 @@ main (int argc, char *argv[])
160 r = stringprep_utf8_nfkc_normalize (p, -1);
161 free (p);
162 if (!r)
163- error (EXIT_FAILURE, 0, _("could not do NFKC normalization"));
164+ error (EXIT_FAILURE, 0, "%s",
165+ _("could not do NFKC normalization"));
166
167 if (args_info.debug_given)
168 {
169@@ -545,7 +546,7 @@ main (int argc, char *argv[])
170 if (!q)
171 {
172 free (r);
173- error (EXIT_FAILURE, 0,
174+ error (EXIT_FAILURE, 0, "%s",
175 _("could not convert from UTF-8 to UCS-4"));
176 }
177
178--
1792.25.1
180
diff --git a/meta-oe/recipes-extended/libidn/libidn/dont-depend-on-help2man.patch b/meta-oe/recipes-extended/libidn/libidn/dont-depend-on-help2man.patch
index 0863530f29..46938bccf6 100644
--- a/meta-oe/recipes-extended/libidn/libidn/dont-depend-on-help2man.patch
+++ b/meta-oe/recipes-extended/libidn/libidn/dont-depend-on-help2man.patch
@@ -1,23 +1,23 @@
1Upstream-Status: Inappropriate [disable feature] 1Upstream-Status: Inappropriate [disable feature]
2 2
3Signed-off-by: Marko Lindqvist <cazfi74@gmail.com> 3Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
4diff -Nurdd libidn-1.26/doc/Makefile.am libidn-1.26/doc/Makefile.am 4--- libidn-1.41.orig/doc/Makefile.am
5--- libidn-1.26/doc/Makefile.am 2012-09-18 11:25:45.000000000 +0300 5+++ libidn-1.41/doc/Makefile.am
6+++ libidn-1.26/doc/Makefile.am 2013-02-08 07:41:24.591431462 +0200 6@@ -73,16 +73,9 @@ BUILT_SOURCES = example.txt example2.txt
7@@ -49,15 +49,9 @@ 7
8
9 # Man pages. 8 # Man pages.
10 9
11-dist_man_MANS = idn.1 $(gdoc_MANS) 10-dist_man_MANS = idn.1 $(gdoc_MANS)
12+dist_man_MANS = $(gdoc_MANS) 11+dist_man_MANS = $(gdoc_MANS)
13 MAINTAINERCLEANFILES = $(dist_man_MANS) 12 MAINTAINERCLEANFILES = $(dist_man_MANS)
14 13
15-idn.1: $(top_srcdir)/src/idn.c $(top_srcdir)/src/idn.ggo \ 14-idn.1: $(top_srcdir)/src/idn.c $(top_srcdir)/src/idn.ggo $(top_srcdir)/.version
16- $(top_srcdir)/configure.ac 15- $(MAKE) -C ../lib
17- $(HELP2MAN) \ 16- $(MAKE) -C ../src
17- $(AM_V_GEN)$(HELP2MAN) \
18- --name="Internationalized Domain Names command line tool" \ 18- --name="Internationalized Domain Names command line tool" \
19- --output=$@ $(top_builddir)/src/idn$(EXEEXT) 19- --output=$@ $(top_builddir)/src/idn$(EXEEXT)
20- 20-
21 # GDOC 21 # GDOC
22 22
23 GDOC_BIN = $(srcdir)/gdoc 23 gdoc_TEXINFOS =
diff --git a/meta-oe/recipes-extended/libidn/libidn_1.36.bb b/meta-oe/recipes-extended/libidn/libidn_1.41.bb
index 0dea4aff5c..b4303a1623 100644
--- a/meta-oe/recipes-extended/libidn/libidn_1.36.bb
+++ b/meta-oe/recipes-extended/libidn/libidn_1.41.bb
@@ -3,24 +3,26 @@ DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specification
3HOMEPAGE = "http://www.gnu.org/software/libidn/" 3HOMEPAGE = "http://www.gnu.org/software/libidn/"
4SECTION = "libs" 4SECTION = "libs"
5LICENSE = "(LGPL-2.1-or-later | LGPL-3.0-only) & GPL-3.0-or-later" 5LICENSE = "(LGPL-2.1-or-later | LGPL-3.0-only) & GPL-3.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=df4be47940a91ee69556f5f71eed4aec \ 6LIC_FILES_CHKSUM = "file://COPYING;md5=f95a3dc99fecfa9a0c4e726d4b5d822f \
7 file://COPYING.LESSERv2;md5=4fbd65380cdd255951079008b364516c \ 7 file://COPYING.LESSERv2;md5=4fbd65380cdd255951079008b364516c \
8 file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ 8 file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
9 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 9 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \ 10 file://COPYINGv3;md5=11cc2d3ee574f9d6b7ee797bdce4d423 \
11 file://lib/idna.h;endline=21;md5=c381d797e2d7fbdace7c147b1285d076 \ 11 file://lib/idna.h;endline=21;md5=176de4fe1d98e59d743d3b12a850e4cb \
12 file://src/idn.c;endline=20;md5=7d88aa87b0494d690bdf7748fe08d536" 12 file://src/idn.c;endline=20;md5=dd17b9093355bf669e2ea108d2defbd0 \
13 "
14
13DEPENDS = "virtual/libiconv autoconf-archive" 15DEPENDS = "virtual/libiconv autoconf-archive"
14 16
15inherit pkgconfig autotools gettext texinfo gtk-doc 17inherit pkgconfig autotools gettext texinfo gtk-doc
16 18
17SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz \ 19SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz \
18 file://dont-depend-on-help2man.patch \ 20 file://dont-depend-on-help2man.patch \
19 file://0001-idn-format-security-warnings.patch \
20 " 21 "
21 22
22SRC_URI[md5sum] = "813c7b268d1051ca02c3610986126f38" 23#SRC_URI[md5sum] = "813c7b268d1051ca02c3610986126f38"
23SRC_URI[sha256sum] = "14b67108344d81ba844631640df77c9071d9fb0659b080326ff5424e86b14038" 24#SRC_URI[sha256sum] = "14b67108344d81ba844631640df77c9071d9fb0659b080326ff5424e86b14038"
25SRC_URI[sha256sum] = "884d706364b81abdd17bee9686d8ff2ae7431c5a14651047c68adf8b31fd8945"
24 26
25# command tool is under GPLv3+, while libidn itself is under LGPLv2.1+ or LGPLv3 27# command tool is under GPLv3+, while libidn itself is under LGPLv2.1+ or LGPLv3
26# so package command into a separate package 28# so package command into a separate package