diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-01-27 22:51:32 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-28 09:40:58 -0800 |
commit | 829327315f1ca0dcc92e1e0ac7721b88f23b72d4 (patch) | |
tree | 7dc46ad8b7a31679187b7364d3f9fe5a2f0d2baa /meta-oe/recipes-extended/libcec | |
parent | 2855fb2de892e9842bfd953e3d7c885c2dc35374 (diff) | |
download | meta-openembedded-829327315f1ca0dcc92e1e0ac7721b88f23b72d4.tar.gz |
libcec: Fix type mismatch for return value of LibCecBootloader()
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libcec')
-rw-r--r-- | meta-oe/recipes-extended/libcec/libcec/0001-cecloader-Match-return-type-of-function-LibCecBootlo.patch | 41 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libcec/libcec_6.0.2.bb | 1 |
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec/0001-cecloader-Match-return-type-of-function-LibCecBootlo.patch b/meta-oe/recipes-extended/libcec/libcec/0001-cecloader-Match-return-type-of-function-LibCecBootlo.patch new file mode 100644 index 000000000..ab1ab5b8e --- /dev/null +++ b/meta-oe/recipes-extended/libcec/libcec/0001-cecloader-Match-return-type-of-function-LibCecBootlo.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From 2241edc8b70c2a54d109ac9c0e821889ac138d40 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 27 Jan 2022 22:49:52 -0800 | ||
4 | Subject: [PATCH] cecloader: Match return type of function LibCecBootloader | ||
5 | |||
6 | Fixes | ||
7 | include/cecloader.h:175:14: error: cannot initialize return object of type 'bool' with an rvalue of type 'nullptr_t' | ||
8 | return NULL; | ||
9 | ^~~~ | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | include/cecloader.h | 4 ++-- | ||
15 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/include/cecloader.h b/include/cecloader.h | ||
18 | index be76468f..550f598e 100644 | ||
19 | --- a/include/cecloader.h | ||
20 | +++ b/include/cecloader.h | ||
21 | @@ -172,7 +172,7 @@ bool LibCecBootloader(const char *strLib = NULL) | ||
22 | if (!g_libCEC) | ||
23 | { | ||
24 | std::cout << dlerror() << std::endl; | ||
25 | - return NULL; | ||
26 | + return false; | ||
27 | } | ||
28 | } | ||
29 | |||
30 | @@ -181,7 +181,7 @@ bool LibCecBootloader(const char *strLib = NULL) | ||
31 | if (!LibCecBootloader) | ||
32 | { | ||
33 | std::cout << "cannot find CECStartBootloader" << std::endl; | ||
34 | - return NULL; | ||
35 | + return false; | ||
36 | } | ||
37 | |||
38 | bool bReturn = LibCecBootloader(); | ||
39 | -- | ||
40 | 2.35.0 | ||
41 | |||
diff --git a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb index eabe1d476..2036c53ef 100644 --- a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb +++ b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb | |||
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release;protocol=https | |||
14 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ | 14 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ |
15 | file://0001-Enhance-reproducibility.patch \ | 15 | file://0001-Enhance-reproducibility.patch \ |
16 | file://0001-Remove-buggy-test-confusing-host-and-target.patch \ | 16 | file://0001-Remove-buggy-test-confusing-host-and-target.patch \ |
17 | file://0001-cecloader-Match-return-type-of-function-LibCecBootlo.patch \ | ||
17 | " | 18 | " |
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |