summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
diff options
context:
space:
mode:
authorYann Dirson <yann@blade-group.com>2020-09-09 10:45:40 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-10 01:24:33 -0700
commit58ba034db7379ff1714054ece5074a4c6ef61505 (patch)
treeae7fa5efec9ab9c858ae07d00d54926465768e6b /meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
parente59b461d19d59b45467ec9933f9c1bb4b962ec4e (diff)
downloadmeta-openembedded-58ba034db7379ff1714054ece5074a4c6ef61505.tar.gz
libcec: split the python example into a separate package
It does not provide more functionality than the C-based examples, so is of little value on a target except for checking the python module is working. Signed-off-by: Yann Dirson <yann@blade-group.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libcec/libcec_6.0.2.bb')
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_6.0.2.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
index f55801c39..48be1fdac 100644
--- a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
@@ -24,10 +24,11 @@ inherit cmake pkgconfig
24PLATFORM_CMAKE_FLAGS ?= "-DHAVE_LINUX_API=1 -DHAVE_RPI_API=0" 24PLATFORM_CMAKE_FLAGS ?= "-DHAVE_LINUX_API=1 -DHAVE_RPI_API=0"
25EXTRA_OECMAKE += "${PLATFORM_CMAKE_FLAGS}" 25EXTRA_OECMAKE += "${PLATFORM_CMAKE_FLAGS}"
26 26
27# Put client examples into a separate package 27# Put client examples into separate packages
28PACKAGE_BEFORE_PN += "${PN}-examples" 28PACKAGE_BEFORE_PN += "${PN}-examples-python ${PN}-examples"
29FILES_${PN}-examples-python = "${bindir}/py*"
29FILES_${PN}-examples = "${bindir}" 30FILES_${PN}-examples = "${bindir}"
30RDEPENDS_${PN}-examples = "python3-${BPN} python3-core" 31RDEPENDS_${PN}-examples-python = "python3-${BPN} python3-core"
31 32
32# Create the wrapper for python3 33# Create the wrapper for python3
33PACKAGES += "python3-${BPN}" 34PACKAGES += "python3-${BPN}"