summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-06 15:12:57 +0800
committerKhem Raj <raj.khem@gmail.com>2024-02-09 09:52:07 -0800
commit9c809c0136806ad4820890aeb045ad471520f96c (patch)
tree4eab4a49be0e69079f7f1e26d6ceabb7280ed4e8 /meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
parent4a27f91f13d23836f1b1b031a63f963c8fa65245 (diff)
downloadmeta-openembedded-9c809c0136806ad4820890aeb045ad471520f96c.tar.gz
libcbor: upgrade 0.10.2 -> 0.11.0
Changelog: ========== - Updated documentation to refer to RFC 8949 - Improvements to 'cbor_describe' - Fix 'cbor_string_set_handle' not setting the codepoint count - 'cbor_load' will no longer fail on input strings that are well-formed but not valid UTF-8 - All decoders like 'cbor_load' and 'cbor_stream_decode' will accept all well-formed tag values Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb')
-rwxr-xr-xmeta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb b/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
new file mode 100755
index 000000000..28bd5b5ae
--- /dev/null
+++ b/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
@@ -0,0 +1,14 @@
1SUMMARY = "library for CBOR"
2DESCRIPTION = "C library for parsing and generating CBOR, the general-purpose schema-less binary data format."
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=6f3b3881df62ca763a02d359a6e94071"
6
7SRC_URI = "git://github.com/PJK/libcbor.git;protocol=https;branch=master"
8SRCREV = "170bee2b82cdb7b2ed25af301f62cb6efdd40ec1"
9
10S = "${WORKDIR}/git"
11
12inherit cmake
13
14EXTRA_OECMAKE += " -DCMAKE_BUILD_TYPE=Release"