summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/iotop
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-extended/iotop
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-extended/iotop')
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_0.4.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb b/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb
new file mode 100644
index 000000000..d6292453f
--- /dev/null
+++ b/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Simple top-like I/O monitor"
2DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
3 It watches I/O usage information output by the Linux kernel and displays \
4 a table of current I/O usage by processes on the system."
5HOMEPAGE = "http://guichaz.free.fr/iotop/"
6
7PR = "r1"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
11
12SRC_URI = "http://guichaz.free.fr/iotop/files/${BP}.tar.bz2"
13SRC_URI[md5sum] = "cdd38b276cbf238676f5d2bcf098ba9c"
14SRC_URI[sha256sum] = "46f3279fb1a7dfc129b5d00950c6e8389e4aedeb58880e848b88d686483df0b0"
15
16inherit distutils
17
18do_install_append() {
19 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
20 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
21}
22
23RDEPENDS_${PN} = "python-curses python-textutils \
24 python-codecs python-ctypes python-pprint \
25 python-shell"