summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/hplip
diff options
context:
space:
mode:
authorZoltán Böszörményi <zboszor@gmail.com>2023-03-30 12:16:56 +0200
committerKhem Raj <raj.khem@gmail.com>2023-03-30 06:25:15 -0700
commit53b7f2359064a5d62aa7dba7a2f7680a1f803046 (patch)
treed8ce6b0200d5629dda1b4fbf58cc124829b80429 /meta-oe/recipes-extended/hplip
parentc2ddfe8b3a64e7e2430b346778dd1c36781329ea (diff)
downloadmeta-openembedded-53b7f2359064a5d62aa7dba7a2f7680a1f803046.tar.gz
hplip: Fix installation and QA
With version 3.22.11 it's not enough avoid linking to the closed source ImageProcessor library, it must not be installed either. This library is pre-stripped so package QA fails. Add a new patch to fix installing HPLIP.conf into /usr/share/ipp-usb/quirks. The upstream Makefile.am fails to take DESTDIR into account and do_install fails because of this. Also, instead of detecting the presence of the target directory which is invalid for a source build, create it and install the quirk file. Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/hplip')
-rw-r--r--meta-oe/recipes-extended/hplip/hplip/0001-Fix-installing-ipp-usb-quirk.patch38
-rw-r--r--meta-oe/recipes-extended/hplip/hplip/0002-Add-ImageProcessor-only-when-DISBALE_IMAGEPROCESSOR_.patch20
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.22.10.bb2
3 files changed, 58 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/hplip/hplip/0001-Fix-installing-ipp-usb-quirk.patch b/meta-oe/recipes-extended/hplip/hplip/0001-Fix-installing-ipp-usb-quirk.patch
new file mode 100644
index 000000000..71ed69722
--- /dev/null
+++ b/meta-oe/recipes-extended/hplip/hplip/0001-Fix-installing-ipp-usb-quirk.patch
@@ -0,0 +1,38 @@
1From 5cfe30829174a18ec64e53c84292a0229ffa5602 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Zolt=C3=A1n=20B=C3=B6sz=C3=B6rm=C3=A9nyi?=
3 <zboszor@gmail.com>
4Date: Thu, 30 Mar 2023 11:31:27 +0200
5Subject: [PATCH] Fix installing ipp-usb quirk
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10Use $(DESTDIR) as installation prefix for
11/usr/share/usb-ipp/quirk/HPLIP.conf.
12
13Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
14---
15 Makefile.am | 7 +++----
16 1 file changed, 3 insertions(+), 4 deletions(-)
17
18diff --git a/Makefile.am b/Makefile.am
19index e10364d..f520225 100644
20--- a/Makefile.am
21+++ b/Makefile.am
22@@ -703,10 +703,9 @@ if !DISBALE_IMAGEPROCESSOR_BUILD
23 ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
24 fi
25 endif #DISABLE_IMAGEPROCESSOR
26- if [ -d "/usr/share/ipp-usb/quirks/" ]; then \
27- echo "ipp-usb directory exists"; \
28- cp prnt/ipp-usb/HPLIP.conf /usr/share/ipp-usb/quirks/ ; \
29- fi
30+ install -d -m0755 $(DESTDIR)/usr/share/ipp-usb/quirks ; \
31+ echo "ipp-usb directory exists"; \
32+ cp prnt/ipp-usb/HPLIP.conf $(DESTDIR)/usr/share/ipp-usb/quirks/
33 if !HPLIP_CLASS_DRIVER
34 # If scanner build, add hpaio entry to sane dll.conf.
35 if [ "$(scan_build)" = "yes" ]; then \
36--
372.39.2
38
diff --git a/meta-oe/recipes-extended/hplip/hplip/0002-Add-ImageProcessor-only-when-DISBALE_IMAGEPROCESSOR_.patch b/meta-oe/recipes-extended/hplip/hplip/0002-Add-ImageProcessor-only-when-DISBALE_IMAGEPROCESSOR_.patch
index 2cfe1255e..fa973a8d8 100644
--- a/meta-oe/recipes-extended/hplip/hplip/0002-Add-ImageProcessor-only-when-DISBALE_IMAGEPROCESSOR_.patch
+++ b/meta-oe/recipes-extended/hplip/hplip/0002-Add-ImageProcessor-only-when-DISBALE_IMAGEPROCESSOR_.patch
@@ -7,8 +7,8 @@ Subject: [PATCH 2/4] Add ImageProcessor only when DISBALE_IMAGEPROCESSOR_BUILD
7Upstream-Status: Pending 7Upstream-Status: Pending
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9--- 9---
10 Makefile.am | 6 +++++- 10 Makefile.am | 8 +++++++-
11 1 file changed, 5 insertions(+), 1 deletion(-) 11 1 file changed, 7 insertions(+), 1 deletion(-)
12 12
13diff --git a/Makefile.am b/Makefile.am 13diff --git a/Makefile.am b/Makefile.am
14index 5f75759..73421b1 100644 14index 5f75759..73421b1 100644
@@ -27,6 +27,22 @@ index 5f75759..73421b1 100644
27 #else 27 #else
28 #hpcupsdir = $(cupsfilterdir) 28 #hpcupsdir = $(cupsfilterdir)
29 #hpcups_PROGRAMS = hpcups 29 #hpcups_PROGRAMS = hpcups
30@@ -687,6 +692,7 @@
31
32 install-data-hook:
33 if HPLIP_BUILD
34+if !DISBALE_IMAGEPROCESSOR_BUILD
35 if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
36 cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
37 chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
38@@ -697,6 +703,7 @@
39 chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
40 ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
41 fi
42+endif #DISABLE_IMAGEPROCESSOR
43 if [ -d "/usr/share/ipp-usb/quirks/" ]; then \
44 echo "ipp-usb directory exists"; \
45 cp prnt/ipp-usb/HPLIP.conf /usr/share/ipp-usb/quirks/ ; \
30-- 46--
312.37.3 472.37.3
32 48
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.22.10.bb b/meta-oe/recipes-extended/hplip/hplip_3.22.10.bb
index 23cc5197f..ca683483b 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.22.10.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.22.10.bb
@@ -15,6 +15,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
15 file://0004-Define-missing-prototype-for-functions.patch \ 15 file://0004-Define-missing-prototype-for-functions.patch \
16 file://0005-hp_ipp.c-Add-printf-format-to-snprintf-calls.patch \ 16 file://0005-hp_ipp.c-Add-printf-format-to-snprintf-calls.patch \
17 file://0006-Workaround-patch-for-missing-Python3-transition-of-t.patch \ 17 file://0006-Workaround-patch-for-missing-Python3-transition-of-t.patch \
18 file://0001-Fix-installing-ipp-usb-quirk.patch \
18 file://0001-Drop-using-register-storage-classifier.patch" 19 file://0001-Drop-using-register-storage-classifier.patch"
19SRC_URI[sha256sum] = "533c3f2f6b53e4163ded4fd81d1f11ae6162a0f6451bd5e62a8382d0c1366624" 20SRC_URI[sha256sum] = "533c3f2f6b53e4163ded4fd81d1f11ae6162a0f6451bd5e62a8382d0c1366624"
20 21
@@ -80,6 +81,7 @@ FILES:${PN}-dbg += "\
80 ${PYTHON_SITEPACKAGES_DIR}/.debug \ 81 ${PYTHON_SITEPACKAGES_DIR}/.debug \
81 ${libexecdir}/cups/filter/.debug " 82 ${libexecdir}/cups/filter/.debug "
82 83
84FILES:${PN} += "${datadir}/ipp-usb/quirks/HPLIP.conf"
83FILES:${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la" 85FILES:${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
84FILES:${PN}-ppd = "${datadir}/ppd" 86FILES:${PN}-ppd = "${datadir}/ppd"
85FILES:${PN}-cups = "${datadir}/cups" 87FILES:${PN}-cups = "${datadir}/cups"