summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/gnuplot
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-03-30 17:44:17 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-21 13:31:47 +0200
commit8b29bc67af47e3f6ca272731e5ccf1ff1c59b14c (patch)
tree0a97a56f5396ef679dccdfbbe09426c62ef37a34 /meta-oe/recipes-extended/gnuplot
parent72b21ffad37e520da3e10fe91bf3246774da0e46 (diff)
downloadmeta-openembedded-8b29bc67af47e3f6ca272731e5ccf1ff1c59b14c.tar.gz
gnuplot: upgrade to 4.6.5
* automake patch from 4.4.4 is no longer needed * PACKAGECONFIG for lua (lua term is only useful for LaTeX) * linking problems with dlopen, etc. in lua loadlibs.c fixed ** this same problem was seen in jansa world builds for 4.4.4 ** I am not able to replicate that error on 4.4.4 NOTE: qt is supported by this version, but I was not able to figure out the configuration... Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/gnuplot')
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch44
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch16
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/subdirs.patch (renamed from meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/subdirs.patch)0
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot.inc1
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot_4.6.5.bb (renamed from meta-oe/recipes-extended/gnuplot/gnuplot_4.4.4.bb)8
5 files changed, 20 insertions, 49 deletions
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch b/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch
deleted file mode 100644
index 51f703ce2..000000000
--- a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1Upstream-Status: Backport
2
3It's fixed in 4.6 and 4.7(HEAD)
4
5http://sourceforge.net/tracker/?func=detail&aid=3523591&group_id=2055&atid=102055
6
7diff -uNr gnuplot-4.4.4.orig/Makefile.am gnuplot-4.4.4/Makefile.am
8--- gnuplot-4.4.4.orig/Makefile.am 2012-07-20 10:54:49.075828905 +0200
9+++ gnuplot-4.4.4/Makefile.am 2012-07-20 10:55:22.380831313 +0200
10@@ -1,5 +1,5 @@
11 ## Process this file with automake to produce Makefile.in -*-Makefile-*-
12-AUTOMAKE_OPTIONS = foreign 1.2h
13+AUTOMAKE_OPTIONS = foreign
14
15 SUBDIRS = config m4 term src $(LISPDIR) man share
16
17diff -uNr gnuplot-4.4.4.orig/configure.in gnuplot-4.4.4/configure.in
18--- gnuplot-4.4.4.orig/configure.in 2011-09-02 06:09:40.000000000 +0200
19+++ gnuplot-4.4.4/configure.in 2012-07-20 10:55:53.289833224 +0200
20@@ -16,10 +16,11 @@
21 dnl configure.in body
22
23 dnl Compiler characteristics
24-dnl Check for ANSI C prototypes, the const and inline keywords,
25-dnl and ANSI style stringification
26+dnl Check for the const and inline keywords and ANSI style stringification
27+dnl automake 1.12 dropped support for AM_C_PROTOTYPES and ansi2knr
28+dnl But our code still tests for #ifdef PROTOTYPES, so define it here
29+AC_DEFINE(PROTOTYPES,1,[Automake 1.12 dropped support for building without prototypes])
30 AC_PROG_CC
31-AM_C_PROTOTYPES
32 AC_PROG_CPP
33 AC_C_CONST
34 AC_C_INLINE
35diff -uNr gnuplot-4.4.4.orig/src/Makefile.am gnuplot-4.4.4/src/Makefile.am
36--- gnuplot-4.4.4.orig/src/Makefile.am 2010-10-06 06:53:16.000000000 +0200
37+++ gnuplot-4.4.4/src/Makefile.am 2012-07-20 10:56:02.376834548 +0200
38@@ -1,5 +1,5 @@
39 ## Process this file with automake to produce Makefile.in -*-Makefile-*-
40-AUTOMAKE_OPTIONS = ansi2knr foreign 1.2h
41+AUTOMAKE_OPTIONS = foreign
42
43 # in the spirit of automake ...
44 pkglibexecdir = $(libexecdir)/@PACKAGE@/@VERSION_MAJOR@
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch
new file mode 100644
index 000000000..23f2cd26a
--- /dev/null
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch
@@ -0,0 +1,16 @@
1Index: gnuplot-4.6.5/configure.in
2===================================================================
3--- gnuplot-4.6.5.orig/configure.in
4+++ gnuplot-4.6.5/configure.in
5@@ -690,6 +690,11 @@ if test "${with_lua}" = yes ; then
6 fi
7
8 if test "$with_lua" != no; then
9+ dnl check for dlopen/dl to fix loadlibs link failure
10+ AC_CHECK_FUNC([dlopen], [],
11+ AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
12+ AC_SUBST(DLOPEN_LIBS)
13+ LUA_LIBS="$LUA_LIBS $DLOPEN_LIBS"
14 TERMLIBS="$TERMLIBS $LUA_LIBS"
15 CPPFLAGS="$CPPFLAGS $LUA_CFLAGS"
16 else
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/subdirs.patch b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/subdirs.patch
index 8c7d1f0d3..8c7d1f0d3 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/subdirs.patch
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/subdirs.patch
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot.inc b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
index 96d6ee2cc..ab3ec3fbb 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot.inc
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
@@ -12,6 +12,7 @@ acpaths = ""
12 12
13PACKAGECONFIG ??= "cairo" 13PACKAGECONFIG ??= "cairo"
14PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango" 14PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango"
15PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
15 16
16EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \ 17EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
17 --without-lisp-files \ 18 --without-lisp-files \
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot_4.4.4.bb b/meta-oe/recipes-extended/gnuplot/gnuplot_4.6.5.bb
index 4ea312fea..8a5bca964 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot_4.4.4.bb
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot_4.6.5.bb
@@ -1,16 +1,14 @@
1require gnuplot.inc 1require gnuplot.inc
2 2
3PR = "r1"
4
5SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz;name=archive \ 3SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz;name=archive \
6 http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \ 4 http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \
7 file://subdirs.patch \ 5 file://subdirs.patch \
6 file://lua-loadlibs-configure-in-fix.patch \
8 file://gnuplot.desktop \ 7 file://gnuplot.desktop \
9 file://gnuplot.png \ 8 file://gnuplot.png \
10 file://automake-1.12.x.patch \
11" 9"
12 10
13SRC_URI[archive.md5sum] = "97a43328e81e57ebed7f135ca0c07e82" 11SRC_URI[archive.md5sum] = "9a476b21f74bd99c876f1509d731a0f9"
14SRC_URI[archive.sha256sum] = "d228599d08d5f87bcb79af8af8bb432c77d942802b1643f920c7baaeaf1ddbfd" 12SRC_URI[archive.sha256sum] = "e550f030c7d04570e89c3d4e3f6e82296816508419c86ab46c4dd73156519a2d"
15SRC_URI[qtplot.md5sum] = "0a481885a496092c77eb4017540b5cf6" 13SRC_URI[qtplot.md5sum] = "0a481885a496092c77eb4017540b5cf6"
16SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132" 14SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132"