summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/fluentbit
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-18 23:39:31 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-18 23:41:11 -0700
commitd1fb6cd8a55a4e7f8158f79da476398fcad033d0 (patch)
tree98bea04d6d1eecbbe5e5d9fb6546b1138b4e0bf5 /meta-oe/recipes-extended/fluentbit
parent6c998191cd1070342fbcfc86f93e5ac1201c56ff (diff)
downloadmeta-openembedded-d1fb6cd8a55a4e7f8158f79da476398fcad033d0.tar.gz
fluentbit: Upgrade to 1.9.7 and fix build on x86
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/fluentbit')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/0001-Revert-Remove-unused-variable-in-mpi_mul_hlp.patch42
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb (renamed from meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb)7
2 files changed, 47 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-Revert-Remove-unused-variable-in-mpi_mul_hlp.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-Revert-Remove-unused-variable-in-mpi_mul_hlp.patch
new file mode 100644
index 000000000..8a165dc0d
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-Revert-Remove-unused-variable-in-mpi_mul_hlp.patch
@@ -0,0 +1,42 @@
1From af6cefba8c2675f58b75f93785337ab23054568c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 18 Aug 2022 23:35:23 -0700
4Subject: [PATCH] Revert Remove unused variable in mpi_mul_hlp()
5
6This reverts
7https://github.com/Mbed-TLS/mbedtls/commit/e7f14a3090e6595eb3c8d821704ad9c90f6d3712
8
9Which helps in compiling the x86 asm code.
10
11Upstream-Status: Pending
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 lib/mbedtls-2.28.0/library/bignum.c | 4 +++-
16 1 file changed, 3 insertions(+), 1 deletion(-)
17
18diff --git a/lib/mbedtls-2.28.0/library/bignum.c b/lib/mbedtls-2.28.0/library/bignum.c
19index 9c256ae..62e7f76 100644
20--- a/lib/mbedtls-2.28.0/library/bignum.c
21+++ b/lib/mbedtls-2.28.0/library/bignum.c
22@@ -1392,7 +1392,7 @@ void mpi_mul_hlp( size_t i,
23 mbedtls_mpi_uint *d,
24 mbedtls_mpi_uint b )
25 {
26- mbedtls_mpi_uint c = 0;
27+ mbedtls_mpi_uint c = 0, t = 0;
28
29 #if defined(MULADDC_HUIT)
30 for( ; i >= 8; i -= 8 )
31@@ -1443,6 +1443,8 @@ void mpi_mul_hlp( size_t i,
32 }
33 #endif /* MULADDC_HUIT */
34
35+ t++;
36+
37 while( c != 0 )
38 {
39 *d += c; c = ( *d < c ); d++;
40--
412.37.2
42
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb
index a801694f4..a1f879488 100644
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb
@@ -22,13 +22,13 @@ SRC_URI = "https://releases.fluentbit.io/1.9/source-${PV}.tar.gz;subdir=fluent-b
22 file://0004-Use-correct-type-to-store-return-from-flb_kv_item_cr.patch \ 22 file://0004-Use-correct-type-to-store-return-from-flb_kv_item_cr.patch \
23 file://0005-stackdriver-Fix-return-type-mismatch.patch \ 23 file://0005-stackdriver-Fix-return-type-mismatch.patch \
24 file://0006-monkey-Fix-TLS-detection-testcase.patch \ 24 file://0006-monkey-Fix-TLS-detection-testcase.patch \
25 file://0001-Revert-Remove-unused-variable-in-mpi_mul_hlp.patch \
25 " 26 "
26SRC_URI:append:libc-musl = "\ 27SRC_URI:append:libc-musl = "\
27 file://0001-Use-posix-strerror_r-with-musl.patch \ 28 file://0001-Use-posix-strerror_r-with-musl.patch \
28 file://0002-chunkio-Link-with-fts-library-with-musl.patch \ 29 file://0002-chunkio-Link-with-fts-library-with-musl.patch \
29 " 30 "
30SRC_URI[sha256sum] = "5ef7dd97e10936269fe5f4e5d3ebf16559333066f7d6757ba12464a9d6186570" 31SRC_URI[sha256sum] = "8ca2ac081d7eee717483c06608adcb5e3d5373e182ad87dba21a23f8278c6540"
31
32S = "${WORKDIR}/fluent-bit-${PV}" 32S = "${WORKDIR}/fluent-bit-${PV}"
33 33
34DEPENDS = "zlib bison-native flex-native openssl" 34DEPENDS = "zlib bison-native flex-native openssl"
@@ -78,6 +78,9 @@ EXTRA_OECMAKE:append:libc-musl = ' -DFLB_JEMALLOC_OPTIONS="--with-jemalloc-prefi
78EXTRA_OECMAKE:append:riscv64 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic" 78EXTRA_OECMAKE:append:riscv64 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
79EXTRA_OECMAKE:append:riscv32 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic" 79EXTRA_OECMAKE:append:riscv32 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
80EXTRA_OECMAKE:append:mips = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic" 80EXTRA_OECMAKE:append:mips = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
81EXTRA_OECMAKE:append:x86 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
82
83CFLAGS:append:x86 = " -DMBEDTLS_HAVE_SSE2"
81 84
82inherit cmake systemd pkgconfig 85inherit cmake systemd pkgconfig
83 86