diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-02 21:28:05 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-05 22:49:35 -0700 |
commit | 6c251848590867debaaf87bfe12bed572d8f6a8d (patch) | |
tree | 39b3e3c156cd421f881e36035f2e51469024c8f8 /meta-oe/recipes-extended/enscript | |
parent | 649d69d5a2754bcd7d2803857306df4fce3f69c2 (diff) | |
download | meta-openembedded-6c251848590867debaaf87bfe12bed572d8f6a8d.tar.gz |
enscript: Include string.h form str* function prototypes
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/enscript')
-rw-r--r-- | meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-extended/enscript/enscript_1.6.6.bb | 1 |
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch b/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch new file mode 100644 index 0000000000..a080b3aef7 --- /dev/null +++ b/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From faec0206611f8ea4ca6f70987866077ac8c3c6c1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 2 Sep 2022 21:24:27 -0700 | ||
4 | Subject: [PATCH] getopt: Include string.h for strcmp/stcncmp functions | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | compat/getopt.c | 1 + | ||
11 | 1 file changed, 1 insertion(+) | ||
12 | |||
13 | diff --git a/compat/getopt.c b/compat/getopt.c | ||
14 | index 752f28a..9b984b4 100644 | ||
15 | --- a/compat/getopt.c | ||
16 | +++ b/compat/getopt.c | ||
17 | @@ -43,6 +43,7 @@ | ||
18 | #endif | ||
19 | |||
20 | #include <stdio.h> | ||
21 | +#include <string.h> /* strcmp */ | ||
22 | |||
23 | /* Comment out all this code if we are using the GNU C Library, and are not | ||
24 | actually compiling the library itself. This code is part of the GNU C | ||
25 | -- | ||
26 | 2.37.3 | ||
27 | |||
diff --git a/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb b/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb index 3f00621f71..9490ee09dc 100644 --- a/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb +++ b/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb | |||
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" | |||
13 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \ | 13 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \ |
14 | file://enscript-autoconf.patch \ | 14 | file://enscript-autoconf.patch \ |
15 | file://0001-Fix-builds-with-recent-gettext.patch \ | 15 | file://0001-Fix-builds-with-recent-gettext.patch \ |
16 | file://0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | inherit autotools gettext | 19 | inherit autotools gettext |