summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/collectd
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-09-01 17:00:33 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:22:49 +0200
commit1b4e4f455f7c1f98a1e506ac0dbf9721d2f477b4 (patch)
tree484466dcb7b376ed7c6c7cceda74ad3c4dd8fefa /meta-oe/recipes-extended/collectd
parent50d34ad81068aed2477851d78004e9d8997190f0 (diff)
downloadmeta-openembedded-1b4e4f455f7c1f98a1e506ac0dbf9721d2f477b4.tar.gz
collectd: fix a floating dependence on libvirt
Even though the PACKAGECONFIG of libvirt is used to fix the floating dependence, but enable-libvirt/disable-libvirt become useless after collectd upgrade, and libvirt is checked unconditionally, and lead to a floating dependence on libvirt. check if libvirt is available only when a user wants to use libvirt to fix this issue Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/collectd')
-rw-r--r--meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch39
-rw-r--r--meta-oe/recipes-extended/collectd/collectd_5.5.0.bb4
2 files changed, 42 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch b/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch
new file mode 100644
index 000000000..d0a58041f
--- /dev/null
+++ b/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch
@@ -0,0 +1,39 @@
1[PATCH] conditionally check libvirt
2
3Upstream-Statue: Pending
4
5check if libvirt is available only when a user wants to use libvirt
6
7Signed-off-by: Roy Li <rongqing.li@windriver.com>
8---
9 configure.ac | 14 ++++++++------
10 1 file changed, 8 insertions(+), 6 deletions(-)
11
12diff --git a/configure.ac b/configure.ac
13index 923498e..7206095 100644
14--- a/configure.ac
15+++ b/configure.ac
16@@ -4778,12 +4778,14 @@ then
17 with_libxml2="no (pkg-config doesn't know libxml-2.0)"
18 fi
19
20- $PKG_CONFIG --exists libvirt 2>/dev/null
21- if test "$?" = "0"
22- then
23- with_libvirt="yes"
24- else
25- with_libvirt="no (pkg-config doesn't know libvirt)"
26+ if test "x$enable_libvirt" = "xyes"; then
27+ $PKG_CONFIG --exists libvirt 2>/dev/null
28+ if test "$?" = "0"
29+ then
30+ with_libvirt="yes"
31+ else
32+ with_libvirt="no (pkg-config doesn't know libvirt)"
33+ fi
34 fi
35 fi
36 if test "x$with_libxml2" = "xyes"
37--
381.9.1
39
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb b/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb
index feda26be9..fd3b1ab3d 100644
--- a/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb
+++ b/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb
@@ -10,7 +10,9 @@ SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \
10 file://collectd-version.patch \ 10 file://collectd-version.patch \
11 file://0001-redefine-the-dependence.patch \ 11 file://0001-redefine-the-dependence.patch \
12 file://collectd.init \ 12 file://collectd.init \
13 file://collectd.service" 13 file://collectd.service \
14 file://0001-conditionally-check-libvirt.patch \
15"
14SRC_URI[md5sum] = "c39305ef5514b44238b0d31f77e29e6a" 16SRC_URI[md5sum] = "c39305ef5514b44238b0d31f77e29e6a"
15SRC_URI[sha256sum] = "847684cf5c10de1dc34145078af3fcf6e0d168ba98c14f1343b1062a4b569e88" 17SRC_URI[sha256sum] = "847684cf5c10de1dc34145078af3fcf6e0d168ba98c14f1343b1062a4b569e88"
16 18