diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-08-22 23:01:24 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-28 11:06:04 +0200 |
commit | 75d93934ff35656168639d5d957e22ad6fd8004c (patch) | |
tree | 6ea7519dc4bf6883ee928489bf2fb29a44a3df96 /meta-oe/recipes-extended/collectd/collectd_5.7.2.bb | |
parent | 00197a9bdb650097707ff98c99c7f16322db8fa8 (diff) | |
download | meta-openembedded-75d93934ff35656168639d5d957e22ad6fd8004c.tar.gz |
collectd: 5.7.1 -> 5.7.2
The 5.7.2 fixed CVE-2017-7401.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/collectd/collectd_5.7.2.bb')
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd_5.7.2.bb | 86 |
1 files changed, 86 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.7.2.bb b/meta-oe/recipes-extended/collectd/collectd_5.7.2.bb new file mode 100644 index 000000000..c156ea19c --- /dev/null +++ b/meta-oe/recipes-extended/collectd/collectd_5.7.2.bb | |||
@@ -0,0 +1,86 @@ | |||
1 | SUMMARY = "Collects and summarises system performance statistics" | ||
2 | DESCRIPTION = "collectd is a daemon which collects system performance statistics periodically and provides mechanisms to store the values in a variety of ways, for example in RRD files." | ||
3 | LICENSE = "GPLv2 & MIT" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=1bd21f19f7f0c61a7be8ecacb0e28854" | ||
5 | |||
6 | DEPENDS = "rrdtool curl libpcap libxml2 yajl libgcrypt libtool lvm2" | ||
7 | |||
8 | SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \ | ||
9 | file://collectd.init \ | ||
10 | file://collectd.service \ | ||
11 | file://no-gcrypt-badpath.patch \ | ||
12 | file://0001-conditionally-check-libvirt.patch \ | ||
13 | file://0001-fix-to-build-with-glibc-2.25.patch \ | ||
14 | file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ | ||
15 | " | ||
16 | SRC_URI[md5sum] = "5da2b69c286a064db35c6cc1e758b039" | ||
17 | SRC_URI[sha256sum] = "9d20a0221569a8d6b80bbc52b86e5e84965f5bafdbf5dfc3790e0fed0763e592" | ||
18 | |||
19 | inherit autotools pythonnative update-rc.d pkgconfig systemd | ||
20 | |||
21 | SYSTEMD_SERVICE_${PN} = "collectd.service" | ||
22 | |||
23 | # Floatingpoint layout, architecture dependent | ||
24 | # 'nothing', 'endianflip' or 'intswap' | ||
25 | FPLAYOUT ?= "--with-fp-layout=nothing" | ||
26 | |||
27 | PACKAGECONFIG ??= "" | ||
28 | PACKAGECONFIG[openjdk] = "--with-java=${STAGING_DIR_TARGET}${libdir}/jvm,--without-java,openjdk-7" | ||
29 | PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp --with-libnetsnmp=no,net-snmp" | ||
30 | PACKAGECONFIG[libmemcached] = "--with-libmemcached,--without-libmemcached,libmemcached" | ||
31 | PACKAGECONFIG[iptables] = "--enable-iptables,--disable-iptables,iptables" | ||
32 | PACKAGECONFIG[postgresql] = "--enable-postgresql --with-libpq=yes, \ | ||
33 | --disable-postgresql --with-libpq=no,postgresql" | ||
34 | PACKAGECONFIG[mysql] = "--enable-mysql --with-libmysql=yes, \ | ||
35 | --disable-mysql --with-libmysql=no,mysql5" | ||
36 | PACKAGECONFIG[dbi] = "--enable-dbi,--disable-dbi,libdbi" | ||
37 | PACKAGECONFIG[modbus] = "--enable-modbus,--disable-modbus,libmodbus" | ||
38 | PACKAGECONFIG[libowcapi] = "--with-libowcapi,--without-libowcapi,owfs" | ||
39 | PACKAGECONFIG[sensors] = "--enable-sensors --with-libsensors=yes, \ | ||
40 | --disable-sensors --with-libsensors=no,lmsensors" | ||
41 | PACKAGECONFIG[amqp] = "--enable-amqp --with-librabbitmq=yes, \ | ||
42 | --disable-amqp --with-librabbitmq=no,rabbitmq-c" | ||
43 | # protobuf-c, libvirt that are currently only available in meta-virtualization layer | ||
44 | PACKAGECONFIG[pinba] = "--enable-pinba,--disable-pinba,protobuf-c-native protobuf-c" | ||
45 | PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" | ||
46 | PACKAGECONFIG[libesmtp] = "--with-libesmtp,--without-libesmtp,libesmtp" | ||
47 | PACKAGECONFIG[libmnl] = "--with-libmnl,--without-libmnl,libmnl" | ||
48 | PACKAGECONFIG[libatasmart] = "--with-libatasmart,--without-libatasmart,libatasmart" | ||
49 | PACKAGECONFIG[ldap] = "--enable-openldap --with-libldap,--disable-openldap --without-libldap, openldap" | ||
50 | |||
51 | EXTRA_OECONF = " \ | ||
52 | ${FPLAYOUT} \ | ||
53 | --disable-perl --with-libperl=no --with-perl-bindings=no \ | ||
54 | --with-libgcrypt=${STAGING_BINDIR_CROSS}/libgcrypt-config \ | ||
55 | --disable-notify_desktop \ | ||
56 | " | ||
57 | |||
58 | do_install_append() { | ||
59 | install -d ${D}${sysconfdir}/init.d | ||
60 | install -m 0755 ${WORKDIR}/collectd.init ${D}${sysconfdir}/init.d/collectd | ||
61 | sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/collectd | ||
62 | sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/collectd | ||
63 | sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/collectd | ||
64 | sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/collectd | ||
65 | |||
66 | # Fix configuration file to allow collectd to start up | ||
67 | sed -i 's!^#FQDNLookup[ \t]*true!FQDNLookup false!g' ${D}${sysconfdir}/collectd.conf | ||
68 | |||
69 | rmdir "${D}${localstatedir}/run" | ||
70 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" | ||
71 | |||
72 | # Install systemd unit files | ||
73 | install -d ${D}${systemd_unitdir}/system | ||
74 | install -m 0644 ${WORKDIR}/collectd.service ${D}${systemd_unitdir}/system | ||
75 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ | ||
76 | ${D}${systemd_unitdir}/system/collectd.service | ||
77 | } | ||
78 | |||
79 | CONFFILES_${PN} = "${sysconfdir}/collectd.conf" | ||
80 | |||
81 | INITSCRIPT_NAME = "collectd" | ||
82 | INITSCRIPT_PARAMS = "defaults" | ||
83 | |||
84 | # threshold.so load.so are also provided by gegl | ||
85 | # disk.so is also provided by libgphoto2-camlibs | ||
86 | PRIVATE_LIBS = "threshold.so load.so disk.so" | ||