summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-22 16:28:16 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-26 10:00:32 +0200
commit2fc71a181eeea1ef393ad1ca7bde0a5f5de5c5ad (patch)
tree18eec77a319ca57d26ed75dfbe1afc7429edae8a /meta-oe/recipes-extended/collectd/collectd_5.2.2.bb
parent9e7327e446d16a8bd70f93d5d68cdf267e3d2106 (diff)
downloadmeta-openembedded-2fc71a181eeea1ef393ad1ca7bde0a5f5de5c5ad.tar.gz
collectd: add recipe for 5.2.2
Based on initial version by Koen Kooi <koen@beagleboard.org>. Initscript borrowed from Debian with some tweaks. Note that since collectd uses libltdl, building this successfully required OE-Core commit db84eaf851b22b262d9dc48eb55bd5224a00fdd2 or else you get an error about "config/compile" being missing. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/collectd/collectd_5.2.2.bb')
-rw-r--r--meta-oe/recipes-extended/collectd/collectd_5.2.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb b/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb
new file mode 100644
index 000000000..a508840ef
--- /dev/null
+++ b/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Collects and summarises system performance statistics"
2DESCRIPTION = "collectd is a daemon which collects system performance statistics periodically and provides mechanisms to store the values in a variety of ways, for example in RRD files."
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6DEPENDS = "rrdtool curl mysql5 libpcap libxml2 yajl libgcrypt libtool"
7
8SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \
9 file://no-gcrypt-badpath.patch \
10 file://collectd-version.patch \
11 file://collectd.init"
12
13SRC_URI[md5sum] = "29e61411e51845d5ae71ab676078867e"
14SRC_URI[sha256sum] = "7b8906d1c8866155b31820ef108be92abcee7fcd278d386bf0d449e704ba4696"
15
16inherit autotools pythonnative update-rc.d
17
18# Floatingpoint layout, architecture dependent
19# 'nothing', 'endianflip' or 'intswap'
20FPLAYOUT ?= "--with-fp-layout=nothing"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp --with-libnetsnmp=no,net-snmp"
24
25EXTRA_OECONF = " \
26 ${FPLAYOUT} \
27 --disable-perl --with-libperl=no --with-perl-bindings=no \
28 --with-libgcrypt=${STAGING_BINDIR_CROSS}/libgcrypt-config \
29"
30
31do_install_append() {
32 install -d ${D}${sysconfdir}/init.d
33 install -m 0755 ${WORKDIR}/collectd.init ${D}${sysconfdir}/init.d/collectd
34 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/collectd
35 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/collectd
36 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/collectd
37 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/collectd
38
39 # Fix configuration file to allow collectd to start up
40 sed -i 's!^#FQDNLookup[ \t]*true!FQDNLookup false!g' ${D}${sysconfdir}/collectd.conf
41}
42
43INITSCRIPT_NAME = "collectd"
44INITSCRIPT_PARAMS = "defaults"
45