diff options
author | Gianfranco Costamagna <costamagna.gianfranco@gmail.com> | 2023-01-19 09:11:31 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-19 11:17:02 -0800 |
commit | 30a0c7da3a6502a5c32464032ab4b815d6916011 (patch) | |
tree | b4529ec0121b4d757da66184f560f5ae04da3cd1 /meta-oe/recipes-extended/boinc/boinc-client_7.20.5.bb | |
parent | 81f36f8675d31024eb104293aafce6f8b71d64b8 (diff) | |
download | meta-openembedded-30a0c7da3a6502a5c32464032ab4b815d6916011.tar.gz |
boinc-client: Update boinc from 7.20.4 to 7.20.5
Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/boinc/boinc-client_7.20.5.bb')
-rw-r--r-- | meta-oe/recipes-extended/boinc/boinc-client_7.20.5.bb | 82 |
1 files changed, 82 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/boinc/boinc-client_7.20.5.bb b/meta-oe/recipes-extended/boinc/boinc-client_7.20.5.bb new file mode 100644 index 0000000000..4e35283dd2 --- /dev/null +++ b/meta-oe/recipes-extended/boinc/boinc-client_7.20.5.bb | |||
@@ -0,0 +1,82 @@ | |||
1 | # Copyright (C) 2016 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Open-source software for volunteer computing" | ||
5 | DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \ | ||
6 | source software platform which supports distributed computing, primarily in \ | ||
7 | the form of volunteer computing and desktop Grid computing. It is well \ | ||
8 | suited for problems which are often described as trivially parallel. BOINC \ | ||
9 | is the underlying software used by projects such as SETI@home, Einstein@Home, \ | ||
10 | ClimatePrediciton.net, the World Community Grid, and many other distributed \ | ||
11 | computing projects. \ | ||
12 | This package installs the BOINC client software, which will allow your \ | ||
13 | computer to participate in one or more BOINC projects, using your spare \ | ||
14 | computer time to search for cures for diseases, model protein folding, study \ | ||
15 | global warming, discover sources of gravitational waves, and many other types \ | ||
16 | of scientific and mathematical research." | ||
17 | |||
18 | HOMEPAGE = "http://boinc.berkeley.edu/" | ||
19 | LICENSE = "LGPL-2.0-or-later & GPL-3.0-only" | ||
20 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ | ||
21 | file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6" | ||
22 | SECTION = "applications" | ||
23 | DEPENDS = "curl \ | ||
24 | jpeg \ | ||
25 | openssl \ | ||
26 | sqlite3 \ | ||
27 | virtual/egl \ | ||
28 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \ | ||
29 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+3 wxwidgets libnotify xcb-util libxscrnsaver', '', d)} \ | ||
30 | nettle \ | ||
31 | " | ||
32 | SRCREV = "4774e1cbe0ad13cb9a6f7fffbb626a417316f61d" | ||
33 | BRANCH = "client_release/7/7.20" | ||
34 | SRC_URI = "git://github.com/BOINC/boinc;protocol=https;branch=${BRANCH} \ | ||
35 | file://boinc-AM_CONDITIONAL.patch \ | ||
36 | file://0001-scripts-Do-not-check-for-files-on-build-host.patch \ | ||
37 | file://0001-Do-not-undefine-_FILE_OFFSET_BITS.patch \ | ||
38 | " | ||
39 | |||
40 | inherit gettext autotools pkgconfig features_check systemd | ||
41 | |||
42 | REQUIRED_DISTRO_FEATURES += "opengl" | ||
43 | |||
44 | S = "${WORKDIR}/git" | ||
45 | |||
46 | EXTRA_OECONF += "\ | ||
47 | --enable-libraries \ | ||
48 | --enable-unicode \ | ||
49 | --enable-shared \ | ||
50 | --enable-dynamic-client-linkage \ | ||
51 | --enable-client \ | ||
52 | --disable-server \ | ||
53 | --disable-static \ | ||
54 | --disable-manager \ | ||
55 | --with-ssl=${STAGING_EXECPREFIXDIR} \ | ||
56 | --without-wxdir \ | ||
57 | --without-x \ | ||
58 | --with-boinc-platform=${TARGET_SYS} \ | ||
59 | ac_cv_c_undeclared_builtin_options='none' \ | ||
60 | " | ||
61 | export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config" | ||
62 | |||
63 | do_compile:prepend () { | ||
64 | # Disable rpaths | ||
65 | sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/libtool | ||
66 | sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/libtool | ||
67 | sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/libtool | ||
68 | } | ||
69 | |||
70 | do_install:prepend() { | ||
71 | # help script install a bit to do right thing for OE | ||
72 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
73 | mkdir -p ${D}${systemd_system_unitdir} | ||
74 | else | ||
75 | mkdir -p ${D}${sysconfdir}/init.d | ||
76 | fi | ||
77 | mkdir -p ${D}${sysconfdir}/default | ||
78 | } | ||
79 | |||
80 | SYSTEMD_SERVICE:${PN} = "boinc-client.service" | ||
81 | |||
82 | FILES:${PN} += "${libdir}/systemd" | ||