summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-03-07 11:43:52 -0800
committerKhem Raj <raj.khem@gmail.com>2025-03-08 15:06:11 -0800
commitf9b58e2eaec9e79be5443cda6fc09f0e97b38b3f (patch)
tree7a2a624c4f4a0f636d2a5100ebe5dfa0c98738c3 /meta-oe/recipes-devtools
parent56cb03c8cf69b7faeead2286286f4d6c3f8c4743 (diff)
downloadmeta-openembedded-f9b58e2eaec9e79be5443cda6fc09f0e97b38b3f.tar.gz
libtoml11: Upgrade to 4.4.0
Fix build with clang-20 while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/libtoml11/files/0001-Remove-whitespace-in-operator.patch46
-rw-r--r--meta-oe/recipes-devtools/libtoml11/libtoml11_4.4.0.bb (renamed from meta-oe/recipes-devtools/libtoml11/libtoml11_4.3.0.bb)5
2 files changed, 49 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/libtoml11/files/0001-Remove-whitespace-in-operator.patch b/meta-oe/recipes-devtools/libtoml11/files/0001-Remove-whitespace-in-operator.patch
new file mode 100644
index 0000000000..c8c9922d55
--- /dev/null
+++ b/meta-oe/recipes-devtools/libtoml11/files/0001-Remove-whitespace-in-operator.patch
@@ -0,0 +1,46 @@
1From dee78f822d8a5b985e565e5c1ef42a59557aa8fc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Mar 2025 11:35:46 -0800
4Subject: [PATCH] Remove whitespace in operator""
5
6Clang 20+ errors about this whitespace.
7
8Fixes
9include/toml11/impl/../fwd/literal_fwd.hpp:22:26: error: identifier '_toml' preceded by whitespace in a literal operator declaration is deprecated [-Werror,-Wdeprecated-literal-operator]
10| 22 | ::toml::value operator"" _toml(const char* str, std::size_t len);
11| | ~~~~~~~~~~~^~~~~
12| | operator""_toml
13
14Upstream-Status: Submitted [https://github.com/ToruNiina/toml11/pull/285]
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 include/toml11/fwd/literal_fwd.hpp | 2 +-
18 include/toml11/impl/literal_impl.hpp | 2 +-
19 2 files changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/include/toml11/fwd/literal_fwd.hpp b/include/toml11/fwd/literal_fwd.hpp
22index e46612c..82f62b7 100644
23--- a/include/toml11/fwd/literal_fwd.hpp
24+++ b/include/toml11/fwd/literal_fwd.hpp
25@@ -19,7 +19,7 @@ inline namespace literals
26 inline namespace toml_literals
27 {
28
29-::toml::value operator"" _toml(const char* str, std::size_t len);
30+::toml::value operator""_toml(const char* str, std::size_t len);
31
32 #if defined(TOML11_HAS_CHAR8_T)
33 // value of u8"" literal has been changed from char to char8_t and char8_t is
34diff --git a/include/toml11/impl/literal_impl.hpp b/include/toml11/impl/literal_impl.hpp
35index e8298c2..067d4ed 100644
36--- a/include/toml11/impl/literal_impl.hpp
37+++ b/include/toml11/impl/literal_impl.hpp
38@@ -115,7 +115,7 @@ inline namespace toml_literals
39 {
40
41 TOML11_INLINE ::toml::value
42-operator"" _toml(const char* str, std::size_t len)
43+operator""_toml(const char* str, std::size_t len)
44 {
45 if(len == 0)
46 {
diff --git a/meta-oe/recipes-devtools/libtoml11/libtoml11_4.3.0.bb b/meta-oe/recipes-devtools/libtoml11/libtoml11_4.4.0.bb
index 9f265ea19a..5b357e2492 100644
--- a/meta-oe/recipes-devtools/libtoml11/libtoml11_4.3.0.bb
+++ b/meta-oe/recipes-devtools/libtoml11/libtoml11_4.4.0.bb
@@ -11,13 +11,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=44d1fcf70c7aa6991533c38daf7befa3"
11 11
12PE = "1" 12PE = "1"
13 13
14SRCREV = "499be3c177bcf9b42848d5d9567153e4edfcbc8a" 14SRCREV = "be08ba2be2a964edcdb3d3e3ea8d100abc26f286"
15SRCREV_json = "9cca280a4d0ccf0c08f47a99aa71d1b0e52f8d03" 15SRCREV_json = "8c391e04fe4195d8be862c97f38cfe10e2a3472e"
16SRCREV_doctest = "ae7a13539fb71f270b87eb2e874fbac80bc8dda2" 16SRCREV_doctest = "ae7a13539fb71f270b87eb2e874fbac80bc8dda2"
17 17
18SRC_URI = "git://github.com/ToruNiina/toml11;branch=main;protocol=https \ 18SRC_URI = "git://github.com/ToruNiina/toml11;branch=main;protocol=https \
19 git://github.com/nlohmann/json;destsuffix=git/tests/extlib/json;name=json;branch=develop;protocol=https \ 19 git://github.com/nlohmann/json;destsuffix=git/tests/extlib/json;name=json;branch=develop;protocol=https \
20 git://github.com/doctest/doctest;destsuffix=git/tests/extlib/doctest;name=doctest;branch=master;protocol=https \ 20 git://github.com/doctest/doctest;destsuffix=git/tests/extlib/doctest;name=doctest;branch=master;protocol=https \
21 file://0001-Remove-whitespace-in-operator.patch \
21 file://run-ptest \ 22 file://run-ptest \
22" 23"
23SRCREV_FORMAT = "json_doctest" 24SRCREV_FORMAT = "json_doctest"