diff options
author | Andrej Valek <andrej.valek@siemens.com> | 2019-03-19 08:05:47 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-03-19 21:00:06 -0700 |
commit | f0c1ee77d98e679e1c9211c2a91fc315491232b4 (patch) | |
tree | 633eaaa7593eb68d7cb5cca922d29518dd1d3ab9 /meta-oe/recipes-devtools | |
parent | 6cb4e90fcde2d383ebcf656e489ac84d1db422f1 (diff) | |
download | meta-openembedded-f0c1ee77d98e679e1c9211c2a91fc315491232b4.tar.gz |
nodejs: fix target ldflags using
- do not drop target LDFLAGS
- even if the target LDFLAGS have been specified, tools like torque was
linked with system libraries
Signed-off-by: Andrej Valek <andrej.valek@siemens.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs/0006-Use-target-ldflags.patch | 24 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb | 1 |
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0006-Use-target-ldflags.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0006-Use-target-ldflags.patch new file mode 100644 index 0000000000..f6569cd57a --- /dev/null +++ b/meta-oe/recipes-devtools/nodejs/nodejs/0006-Use-target-ldflags.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | The target LDFLAGS have been ignored. Tools like torque | ||
2 | have been loaded from system libraries, even if a native | ||
3 | one was the target. | ||
4 | |$ ldd torque | ||
5 | | libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 | ||
6 | | libcrypto.so.1.1 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 | ||
7 | | libssl.so.1.1 => /usr/lib/x86_64-linux-gnu/libssl.so.1.1 | ||
8 | | libicui18n.so.63 => not found | ||
9 | | libicuuc.so.63 => not found | ||
10 | ... | ||
11 | |||
12 | Signed-off-by: Andrej Valek <andrej.valek@siemens.com> | ||
13 | |||
14 | diff -Naur node-v10.15.1/deps/v8/gypfiles/toolchain.gypi node-v10.15.1/deps/v8/gypfiles/toolchain.gypi | ||
15 | --- node-v10.15.1/deps/v8/gypfiles/toolchain.gypi 2019-03-18 15:01:39.000000000 +0100 | ||
16 | +++ node-v10.15.1/deps/v8/gypfiles/toolchain.gypi 2019-03-18 15:04:08.628361308 +0100 | ||
17 | @@ -1106,6 +1106,7 @@ | ||
18 | 'cflags': [ '-fno-strict-aliasing' ], | ||
19 | }], | ||
20 | ], # conditions | ||
21 | + 'ldflags+': [ '$(LDFLAGS)' ], | ||
22 | }], | ||
23 | ['OS=="solaris"', { | ||
24 | 'defines': [ '__C99FEATURES__=1' ], # isinf() etc. | ||
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb index 17c9bb0c4e..672cd84401 100644 --- a/meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb +++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.15.1.bb | |||
@@ -17,6 +17,7 @@ SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \ | |||
17 | file://0003-Crypto-reduce-memory-usage-of-SignFinal.patch \ | 17 | file://0003-Crypto-reduce-memory-usage-of-SignFinal.patch \ |
18 | file://0004-Make-compatibility-with-gcc-4.8.patch \ | 18 | file://0004-Make-compatibility-with-gcc-4.8.patch \ |
19 | file://0005-Link-atomic-library.patch \ | 19 | file://0005-Link-atomic-library.patch \ |
20 | file://0006-Use-target-ldflags.patch \ | ||
20 | " | 21 | " |
21 | SRC_URI_append_class-target = " \ | 22 | SRC_URI_append_class-target = " \ |
22 | file://0002-Using-native-torque.patch \ | 23 | file://0002-Using-native-torque.patch \ |