summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorVijay Khemka <vijaykhemka@fb.com>2020-08-10 12:32:14 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-11 23:37:47 -0700
commitdd0fafdc53834c9487dc292ea7a2d870c9654e55 (patch)
tree4b6d3391d9087db30f037c140b8ca48900bfe7f9 /meta-oe/recipes-devtools
parent8fd3da8ab8e7583f11f0d8d55e3e1704239aabcb (diff)
downloadmeta-openembedded-dd0fafdc53834c9487dc292ea7a2d870c9654e55.tar.gz
Adding recipe for exprtk
The C++ Mathematical Expression Toolkit Library (ExprTk) is a simple to use, easy to integrate and extremely efficient run-time mathematical expression parsing and evaluation engine. The parsing engine supports numerous forms of functional and logic processing semantics and is easily extensible. It is a header only library. Signed-off-by: Vijay Khemka <vijaykhemka@fb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/exprtk/exprtk_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/exprtk/exprtk_git.bb b/meta-oe/recipes-devtools/exprtk/exprtk_git.bb
new file mode 100644
index 000000000..6930f31e9
--- /dev/null
+++ b/meta-oe/recipes-devtools/exprtk/exprtk_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Expression parser"
2HOMEPAGE = "https://github.com/ArashPartow/exprtk"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6SRCREV = "281c2ccc65b8f91c012ea3725ebcef406378a225"
7
8SRC_URI = "git://github.com/ArashPartow/exprtk.git"
9
10S = "${WORKDIR}/git"
11
12# other packages commonly reference the file directly as "exprtk.hpp"
13# create symlink to allow this usage
14do_install() {
15 install -d ${D}/${includedir}
16 install -m 0644 ${S}/exprtk.hpp ${D}/${includedir}/exprtk.hpp
17}
18
19# exprtk is a header only C++ library, so the main package will be empty.
20RDEPENDS_${PN}-dev = ""
21
22BBCLASSEXTEND = "native nativesdk"