diff options
author | wangmy <wangmy@fujitsu.com> | 2021-05-26 14:57:07 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-28 06:55:33 -0700 |
commit | ccacda40bcccbf27c7eebe12849a135337b8be38 (patch) | |
tree | 3f302c77627e8c301ff157d51a4ec004967c4152 /meta-oe/recipes-devtools | |
parent | baa9453d57aa06554c823b5c7bd9c029e1858f89 (diff) | |
download | meta-openembedded-ccacda40bcccbf27c7eebe12849a135337b8be38.tar.gz |
uftrace: upgrade 0.9.4 -> 0.10
0001-aarch64-Fix-a-plthook-crash-on-aarch64-with-binutils.patch
removed since it is removed in 0.10
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace/0001-aarch64-Fix-a-plthook-crash-on-aarch64-with-binutils.patch | 47 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace_0.10.bb (renamed from meta-oe/recipes-devtools/uftrace/uftrace_0.9.4.bb) | 3 |
2 files changed, 1 insertions, 49 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0001-aarch64-Fix-a-plthook-crash-on-aarch64-with-binutils.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0001-aarch64-Fix-a-plthook-crash-on-aarch64-with-binutils.patch deleted file mode 100644 index bf997d6e4b..0000000000 --- a/meta-oe/recipes-devtools/uftrace/uftrace/0001-aarch64-Fix-a-plthook-crash-on-aarch64-with-binutils.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From 0851278471472c6be69a936cc3698aa50a646ffd Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
3 | Date: Wed, 12 May 2021 17:06:31 +0900 | ||
4 | Subject: [PATCH] aarch64: Fix a plthook crash on aarch64 with binutils2.35.1 | ||
5 | and later versions | ||
6 | |||
7 | plthook is always crashed in Ubuntu 20.10 aarch64, which uses binutils 2.35.1. | ||
8 | Since the `plt_entsize` is not automatically set in this version, we have to | ||
9 | explicitly set the value. | ||
10 | |||
11 | This patch fixes the following problem. | ||
12 | |||
13 | $ uname -m | ||
14 | aarch64 | ||
15 | |||
16 | $ cat /etc/os-release | grep PRETTY_NAME | ||
17 | PRETTY_NAME="Ubuntu 20.10" | ||
18 | |||
19 | $ gcc -pg tests/s-abc.c | ||
20 | |||
21 | $ uftrace record a.out | ||
22 | WARN: child terminated by signal: 7: Bus error | ||
23 | |||
24 | Fixed: #1254 | ||
25 | |||
26 | Upstream-status: submitted [Sent to https://github.com/namhyung/uftrace/pull/1248] | ||
27 | |||
28 | Signed-off-by: Lei Maohui <leimaohui@fujitsu.com> | ||
29 | --- | ||
30 | utils/symbol.c | 1 + | ||
31 | 1 file changed, 1 insertion(+) | ||
32 | |||
33 | diff --git a/utils/symbol.c b/utils/symbol.c | ||
34 | index 29a1d295..01e52dab 100644 | ||
35 | --- a/utils/symbol.c | ||
36 | +++ b/utils/symbol.c | ||
37 | @@ -560,6 +560,7 @@ int load_elf_dynsymtab(struct symtab *dsymtab, struct uftrace_elf_data *elf, | ||
38 | } | ||
39 | else if (elf->ehdr.e_machine == EM_AARCH64) { | ||
40 | plt_addr += 16; /* AARCH64 PLT0 size is 32 */ | ||
41 | + plt_entsize = 16; | ||
42 | } | ||
43 | else if (elf->ehdr.e_machine == EM_386) { | ||
44 | plt_entsize += 12; | ||
45 | -- | ||
46 | 2.25.1 | ||
47 | |||
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.9.4.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.10.bb index a04fccca75..828c21cf9f 100644 --- a/meta-oe/recipes-devtools/uftrace/uftrace_0.9.4.bb +++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.10.bb | |||
@@ -11,9 +11,8 @@ DEPENDS_append_libc-musl = " argp-standalone" | |||
11 | inherit autotools | 11 | inherit autotools |
12 | 12 | ||
13 | PV .= "+git${SRCPV}" | 13 | PV .= "+git${SRCPV}" |
14 | SRCREV = "d648bbffedef529220896283fb59e35531c13804" | 14 | SRCREV = "a5e5a51d32bdfe59af8b453ca08d78cbdf0b3c61" |
15 | SRC_URI = "git://github.com/namhyung/${BPN} \ | 15 | SRC_URI = "git://github.com/namhyung/${BPN} \ |
16 | file://0001-aarch64-Fix-a-plthook-crash-on-aarch64-with-binutils.patch \ | ||
17 | " | 16 | " |
18 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
19 | 18 | ||