diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-02-23 15:48:14 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-02-23 16:46:32 +0100 |
commit | aa26673c83a126732d9a404bbe748b7e5321009f (patch) | |
tree | 852ad6e2e629404a47d34e6e90d14eb1d4d9a385 /meta-oe/recipes-devtools | |
parent | afa3939e99f87365feb4f55d727268a723e68c55 (diff) | |
download | meta-openembedded-aa26673c83a126732d9a404bbe748b7e5321009f.tar.gz |
cloud9: use systemd_unitdir variable
* maybe we should move systemd_unitdir definition outside systemd.bbclass
because it's used in few more recipes which doesn't inherit systemd
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb index 4e95075f8..7041527a4 100644 --- a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb +++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018" | |||
5 | 5 | ||
6 | DEPENDS = "libxml2 nodejs-native" | 6 | DEPENDS = "libxml2 nodejs-native" |
7 | 7 | ||
8 | PR = "r13" | 8 | PR = "r14" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ | 10 | SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ |
11 | git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ | 11 | git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ |
@@ -98,8 +98,8 @@ do_install () { | |||
98 | install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.js | 98 | install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.js |
99 | install -m 0755 ${WORKDIR}/o3/o3.node ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.node | 99 | install -m 0755 ${WORKDIR}/o3/o3.node ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.node |
100 | 100 | ||
101 | install -m 0755 -d ${D}${base_libdir}/systemd/system | 101 | install -m 0755 -d ${D}${systemd_unitdir}/system |
102 | install -m 0644 ${WORKDIR}/cloud9.service ${D}${base_libdir}/systemd/system/ | 102 | install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system/ |
103 | 103 | ||
104 | install -m 0755 -d ${D}${sysconfdir}/avahi/services/ | 104 | install -m 0755 -d ${D}${sysconfdir}/avahi/services/ |
105 | install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/ | 105 | install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/ |
@@ -109,7 +109,7 @@ FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o | |||
109 | ${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \ | 109 | ${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \ |
110 | " | 110 | " |
111 | 111 | ||
112 | FILES_${PN} += "${base_libdir}/systemd/system" | 112 | FILES_${PN} += "${systemd_unitdir}/system" |
113 | RDEPENDS_${PN} = "nodejs gzip" | 113 | RDEPENDS_${PN} = "nodejs gzip" |
114 | 114 | ||
115 | inherit systemd | 115 | inherit systemd |