summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-01 14:13:40 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-07 12:21:23 +0200
commit910feab3e7cae1a74562c930be032566824968eb (patch)
treebd75583bd7ca4dc5d9dcf66d3de51d551c93d584 /meta-oe/recipes-devtools
parent614daa3a27d090fbf54e08c5f4eabc1f14d228c3 (diff)
downloadmeta-openembedded-910feab3e7cae1a74562c930be032566824968eb.tar.gz
python-sip: import from oe-classic and upgrade to latest
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-sip.inc42
-rw-r--r--meta-oe/recipes-devtools/python/python-sip_4.13.3.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-sip.inc b/meta-oe/recipes-devtools/python/python-sip.inc
new file mode 100644
index 000000000..19abbba4e
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-sip.inc
@@ -0,0 +1,42 @@
1DESCRIPTION = "Runtime helper for sip-generated python wrapper libraries"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
4AUTHOR = "Phil Thompson"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://siplib.sbf.in;endline=15;md5=e0e7b5d0c4656666df09826ea1d2071c"
7DEPENDS = "python"
8RDEPENDS_${PN} = "python-core"
9
10SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz"
11
12S = "${WORKDIR}/sip-${PV}/siplib"
13
14inherit qt4x11 distutils-base
15
16EXTRA_QMAKEVARS_POST += " TEMPLATE=lib \
17 CONFIG=console \
18 DESTDIR= \
19 VERSION=1.0.0 \
20 TARGET=sip \
21 DEFINES=SIP_QT_SUPPORT \
22 INCLUDEPATH+=. \
23 INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \
24 INCLUDEPATH+=${STAGING_INCDIR}"
25
26
27do_configure_prepend() {
28 cat siplib.sbf.in | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.pro
29 cat siplib.c.in | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.c
30 cat sip.h.in | sed -e s,@CFG_MODULE_NAME@,sip,g > sip.h
31}
32
33do_install() {
34 install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/
35 install -m 0755 libsip.so.1.0.0 ${D}${libdir}/${PYTHON_DIR}/site-packages/sip.so
36 # sipconfig.py sipdistutils.py
37 install -d ${D}${includedir}
38 install -m 0644 ../siplib/sip.h ${D}${includedir}/sip.h
39}
40
41FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/sip.so"
42
diff --git a/meta-oe/recipes-devtools/python/python-sip_4.13.3.bb b/meta-oe/recipes-devtools/python/python-sip_4.13.3.bb
new file mode 100644
index 000000000..b1bda92cd
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-sip_4.13.3.bb
@@ -0,0 +1 @@
require python-sip.inc