summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-08 08:15:10 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:28 -0800
commit903c8e58ed2240f7214261c9005a38f15d782c29 (patch)
tree0698567213d88fbfcf41d8de16822ae397adadb3 /meta-oe/recipes-devtools
parentd8511c2432ca4ba75bca6e7f71f3c4c3f6098aae (diff)
downloadmeta-openembedded-903c8e58ed2240f7214261c9005a38f15d782c29.tar.gz
abseil-cpp: upgrade 20230802.1 -> 20240116.1
0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch revmoed since it's included in 20240116.1. Changelog: =========== -Added absl::NoDestructor<T> to simplify defining static types that do not need to be destructed upon program exit. -Added configurable verbose logging (also known as VLOG). -Added absl::Overload(), which returns a functor that provides overloads based on the functors passed to it. -Bzlmod is now officially supported (previously it was supported by the community). Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch62
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb (renamed from meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb)37
2 files changed, 9 insertions, 90 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch
deleted file mode 100644
index db559bb16..000000000
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From cb7665f39e23e95e2466390c60ee5a410780a3ed Mon Sep 17 00:00:00 2001
2From: Derek Mauro <dmauro@google.com>
3Date: Wed, 8 Nov 2023 09:55:31 -0800
4Subject: [PATCH] Avoid using both Win32Waiter and PthreadWaiter on MinGW, and
5 use StdcppWaiter instead.
6
7There are various flavors of MinGW, some of which support pthread,
8and some of which support Win32. Instead of figuring out which
9platform is being used, just use the generic implementation.
10
11PiperOrigin-RevId: 580565507
12Change-Id: Ia85fd7496f1e6ebdeadb95202f0039e844826118
13Upstream-Status: Backport
14---
15 absl/synchronization/internal/pthread_waiter.h | 4 ++--
16 absl/synchronization/internal/win32_waiter.h | 6 ++++--
17 2 files changed, 6 insertions(+), 4 deletions(-)
18
19diff --git a/absl/synchronization/internal/pthread_waiter.h b/absl/synchronization/internal/pthread_waiter.h
20index 206aefa4..23db76ad 100644
21--- a/absl/synchronization/internal/pthread_waiter.h
22+++ b/absl/synchronization/internal/pthread_waiter.h
23@@ -16,7 +16,7 @@
24 #ifndef ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
25 #define ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
26
27-#ifndef _WIN32
28+#if !defined(_WIN32) && !defined(__MINGW32__)
29 #include <pthread.h>
30
31 #include "absl/base/config.h"
32@@ -55,6 +55,6 @@ class PthreadWaiter : public WaiterCrtp<PthreadWaiter> {
33 ABSL_NAMESPACE_END
34 } // namespace absl
35
36-#endif // ndef _WIN32
37+#endif // !defined(_WIN32) && !defined(__MINGW32__)
38
39 #endif // ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
40diff --git a/absl/synchronization/internal/win32_waiter.h b/absl/synchronization/internal/win32_waiter.h
41index 87eb617c..fdab264e 100644
42--- a/absl/synchronization/internal/win32_waiter.h
43+++ b/absl/synchronization/internal/win32_waiter.h
44@@ -20,7 +20,8 @@
45 #include <sdkddkver.h>
46 #endif
47
48-#if defined(_WIN32) && _WIN32_WINNT >= _WIN32_WINNT_VISTA
49+#if defined(_WIN32) && !defined(__MINGW32__) && \
50+ _WIN32_WINNT >= _WIN32_WINNT_VISTA
51
52 #include "absl/base/config.h"
53 #include "absl/synchronization/internal/kernel_timeout.h"
54@@ -65,6 +66,7 @@ class Win32Waiter : public WaiterCrtp<Win32Waiter> {
55 ABSL_NAMESPACE_END
56 } // namespace absl
57
58-#endif // defined(_WIN32) && _WIN32_WINNT >= _WIN32_WINNT_VISTA
59+#endif // defined(_WIN32) && !defined(__MINGW32__) &&
60+ // _WIN32_WINNT >= _WIN32_WINNT_VISTA
61
62 #endif // ABSL_SYNCHRONIZATION_INTERNAL_WIN32_WAITER_H_
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb
index 17db7b2e4..82b2d20e0 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb
@@ -1,24 +1,26 @@
1SUMMARY = "Abseil is a cpp library like STL" 1SUMMARY = "Abseil is a cpp library like STL"
2DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \ 2DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
3additional useful libraries like algorithm, container, debugging, hash, memory, \ 3additional useful libraries like algorithm, container, debugging, hash, memory, \
4meta, numeric, strings, synchronization, time, types and utility." 4meta, numeric, strings, synchronization, time, types and utility"
5HOMEPAGE = "https://abseil.io/" 5HOMEPAGE = "https://abseil.io/"
6SECTION = "libs" 6SECTION = "libs"
7LICENSE = "Apache-2.0" 7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
9 9
10SRCREV = "fb3621f4f897824c0dbe0615fa94543df6192f30" 10SRCREV = "2f9e432cce407ce0ae50676696666f33a77d42ac"
11BRANCH = "lts_2023_08_02" 11BRANCH = "lts_2024_01_16"
12SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \ 12SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
13 file://0001-absl-always-use-asm-sgidefs.h.patch \ 13 file://0001-absl-always-use-asm-sgidefs.h.patch \
14 file://0002-Remove-maes-option-from-cross-compilation.patch \ 14 file://0002-Remove-maes-option-from-cross-compilation.patch \
15 file://abseil-ppc-fixes.patch \ 15 file://abseil-ppc-fixes.patch \
16 file://0003-Remove-neon-option-from-cross-compilation.patch \ 16 file://0003-Remove-neon-option-from-cross-compilation.patch \
17 file://0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch \
18 " 17 "
19 18
20S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
21 20
21ASNEEDED:class-native = ""
22ASNEEDED:class-nativesdk = ""
23
22inherit cmake 24inherit cmake
23 25
24EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \ 26EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
@@ -26,29 +28,8 @@ EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
26 -DABSL_ENABLE_INSTALL=ON \ 28 -DABSL_ENABLE_INSTALL=ON \
27 " 29 "
28 30
29SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}" 31BBCLASSEXTEND = "native nativesdk"
30
31PACKAGES_DYNAMIC = "^libabsl-*"
32PACKAGES_DYNAMIC:class-native = ""
33
34PACKAGESPLITFUNCS =+ "split_dynamic_packages"
35
36python split_dynamic_packages() {
37 libdir = d.getVar('libdir')
38
39 libpackages = do_split_packages(
40 d,
41 root=libdir,
42 file_regex=r'^libabsl_(.*)\.so\..*$',
43 output_pattern='libabsl-%s',
44 description="abseil shared library %s",
45 prepend=True,
46 extra_depends='',
47 )
48 if libpackages:
49 d.appendVar('RDEPENDS:' + d.getVar('PN'), ' ' + ' '.join(libpackages))
50}
51 32
52ALLOW_EMPTY:${PN} = "1" 33SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
53 34
54BBCLASSEXTEND = "native nativesdk" 35FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"