summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-03 10:55:14 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-03 10:55:59 -0700
commit8105f98ad6e47d6b86017c347c4041442ede234f (patch)
tree4c1fb2d1c61091ee1e96fc152a92059daa9beacb /meta-oe/recipes-devtools
parentfec057d6d084e4cd147d1107b8616ff87d6c0a91 (diff)
downloadmeta-openembedded-8105f98ad6e47d6b86017c347c4041442ede234f.tar.gz
ctags: Switch to universal ctags
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/ctags/ctags_5.8.bb25
-rw-r--r--meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb25
2 files changed, 25 insertions, 25 deletions
diff --git a/meta-oe/recipes-devtools/ctags/ctags_5.8.bb b/meta-oe/recipes-devtools/ctags/ctags_5.8.bb
deleted file mode 100644
index d006d83aa5..0000000000
--- a/meta-oe/recipes-devtools/ctags/ctags_5.8.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Exuberant Ctags"
5DESCRIPTION = "Exuberant Ctags is a multilanguage reimplementation of the \
6 Unix ctags utility. Ctags generates an index of source code \
7 definitions which is used by numerous editors and utilities \
8 to instantly locate the definitions."
9
10HOMEPAGE = "http://ctags.sourceforge.net/"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
14
15inherit autotools-brokensep
16
17SRC_URI = "http://prdownloads.sourceforge.net/${BPN}/${BP}.tar.gz"
18
19SRC_URI[md5sum] = "c00f82ecdcc357434731913e5b48630d"
20SRC_URI[sha256sum] = "0e44b45dcabe969e0bbbb11e30c246f81abe5d32012db37395eb57d66e9e99c7"
21
22do_install() {
23 install -Dm 755 ${B}/ctags ${D}${bindir}/ctags
24 install -Dm 644 ${B}/ctags.1 ${D}${mandir}/man1/ctags.1
25}
diff --git a/meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb b/meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb
new file mode 100644
index 0000000000..aca0502db6
--- /dev/null
+++ b/meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb
@@ -0,0 +1,25 @@
1# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Ctags"
5DESCRIPTION = "Universal Ctags is a multilanguage reimplementation of the \
6 Unix ctags utility. Ctags generates an index of source code \
7 definitions which is used by numerous editors and utilities \
8 to instantly locate the definitions."
9
10HOMEPAGE = "https://ctags.io/"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
14
15inherit autotools-brokensep pkgconfig manpages
16
17DEPENDS += "libxml2 jansson libyaml python3-docutils-native"
18SRCREV = "6df08b82d4845d1b9420d9268f24d5db16ee4480"
19SRC_URI = "git://github.com/universal-ctags/ctags"
20
21S = "${WORKDIR}/git"
22
23#do_install() {
24# install -Dm 755 ${B}/ctags ${D}${bindir}/ctags
25#}