summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorDmitry Baryshkov <dmitry.baryshkov@linaro.org>2025-02-10 01:45:17 +0200
committerKhem Raj <raj.khem@gmail.com>2025-02-09 16:43:14 -0800
commit6b44831860baf6285afa75f80f5108f44a7e431a (patch)
tree02034b7a6879f311d2e1fd907c56100b8fbe3de3 /meta-oe/recipes-devtools
parentf0f690a64debe3f27fbb1ca9b087850d1bfb43c5 (diff)
downloadmeta-openembedded-6b44831860baf6285afa75f80f5108f44a7e431a.tar.gz
android-tools: drop useless USB_DEBUGGING_ENABLED handling
This reverts commits 4271cc28279b ("android-tools: Add flag to enable adbd service (#147)") and b85ae59968f4 ("android-tools 10: Add flag to enable adbd service"). These two commits added optional ROOTFS_POSTPROCESS_COMMAND touching the flag file, however this variable doesn't make any sense in the package recipe, it is only concerned in the image context. Drop useless code from the android-tools recipe. Fixes: 4271cc28279b ("android-tools: Add flag to enable adbd service (#147)") Fixes: b85ae59968f4 ("android-tools 10: Add flag to enable adbd service") Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb6
1 files changed, 0 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index a291fc39a2..7c27efb093 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -188,12 +188,6 @@ FILES:${PN}-fstools = "\
188 188
189BBCLASSEXTEND = "native" 189BBCLASSEXTEND = "native"
190 190
191android_tools_enable_devmode() {
192 touch ${IMAGE_ROOTFS}/etc/usb-debugging-enabled
193}
194
195ROOTFS_POSTPROCESS_COMMAND_${PN}-adbd += "${@bb.utils.contains("USB_DEBUGGING_ENABLED", "1", "android_tools_enable_devmode;", "", d)}"
196
197# http://errors.yoctoproject.org/Errors/Details/766881/ 191# http://errors.yoctoproject.org/Errors/Details/766881/
198# android-tools/5.1.1.r37/git/system/core/adb/adb_auth_host.c:86:23: error: passing argument 2 of 'RSA_get0_key' from incompatible pointer type [-Wincompatible-pointer-types] 192# android-tools/5.1.1.r37/git/system/core/adb/adb_auth_host.c:86:23: error: passing argument 2 of 'RSA_get0_key' from incompatible pointer type [-Wincompatible-pointer-types]
199# android-tools/5.1.1.r37/git/system/core/adb/adb_auth_host.c:86:27: error: passing argument 3 of 'RSA_get0_key' from incompatible pointer type [-Wincompatible-pointer-types] 193# android-tools/5.1.1.r37/git/system/core/adb/adb_auth_host.c:86:27: error: passing argument 3 of 'RSA_get0_key' from incompatible pointer type [-Wincompatible-pointer-types]