summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-06-13 17:00:19 +0800
committerKhem Raj <raj.khem@gmail.com>2022-06-30 13:39:27 -0400
commit58d18fcd47f55fe1afaff3dd79860ef44bbf6ec9 (patch)
treeda95ee274193ac52c497114eaabf0c2ca923f93a /meta-oe/recipes-devtools
parente16e743d4afeb29aa91935e51d2d81ba69967199 (diff)
downloadmeta-openembedded-58d18fcd47f55fe1afaff3dd79860ef44bbf6ec9.tar.gz
musl-nscd: upgrade 1.0.2 -> 1.1.0
License-Update: Copyright year updated to 2021. 0001-Fix-build-under-GCC-fno-common.patch 0001-configure-Check-for-flex-if-lex-is-not-found.patch removed since they're included in 1.1.0 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch43
-rw-r--r--meta-oe/recipes-devtools/musl/musl-nscd/0001-configure-Check-for-flex-if-lex-is-not-found.patch29
-rw-r--r--meta-oe/recipes-devtools/musl/musl-nscd_git.bb8
3 files changed, 3 insertions, 77 deletions
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch b/meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch
deleted file mode 100644
index 6fee0526d..000000000
--- a/meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 8c0e4b7907eb577b1e5214f9a7bc75d5c3263b0a Mon Sep 17 00:00:00 2001
2From: Ariadne Conill <ariadne@dereferenced.org>
3Date: Sat, 14 Nov 2020 22:55:30 -0700
4Subject: [PATCH] Fix build under GCC -fno-common.
5
6Upstream-Status: Submitted [https://github.com/pikhq/musl-nscd/pull/11]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 include/modules.h | 4 ++--
10 src/main.c | 3 +++
11 2 files changed, 5 insertions(+), 2 deletions(-)
12
13diff --git a/include/modules.h b/include/modules.h
14index 70c1960..e77ec58 100644
15--- a/include/modules.h
16+++ b/include/modules.h
17@@ -28,7 +28,7 @@ struct mod_passwd {
18 link_t link;
19 };
20
21-list_t passwd_mods;
22-list_t group_mods;
23+extern list_t passwd_mods;
24+extern list_t group_mods;
25
26 #endif
27diff --git a/src/main.c b/src/main.c
28index c1a78bb..808ef74 100644
29--- a/src/main.c
30+++ b/src/main.c
31@@ -18,6 +18,9 @@
32 #include "parse.h"
33 #include "util.h"
34
35+list_t passwd_mods;
36+list_t group_mods;
37+
38 static void *get_dll(const char *service)
39 {
40 char *path;
41--
422.29.2
43
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd/0001-configure-Check-for-flex-if-lex-is-not-found.patch b/meta-oe/recipes-devtools/musl/musl-nscd/0001-configure-Check-for-flex-if-lex-is-not-found.patch
deleted file mode 100644
index 691aa3d2a..000000000
--- a/meta-oe/recipes-devtools/musl/musl-nscd/0001-configure-Check-for-flex-if-lex-is-not-found.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 4d09032741475c4e9d3de62c8187597f3f72f934 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 22 Nov 2020 12:32:01 -0800
4Subject: [PATCH] configure: Check for flex if lex is not found
5
6lex is already checked by this time, therefore check should be to find
7flex
8Upstream-Status: Submitted [https://github.com/pikhq/musl-nscd/pull/12]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 configure | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/configure b/configure
15index 256824a..4c94568 100755
16--- a/configure
17+++ b/configure
18@@ -249,7 +249,7 @@ printf "checking for lex... "
19 trylex ${CROSS_COMPILE}lex
20 trylex lex
21 trylex ${CROSS_COMPILE}flex
22-trylex lex
23+trylex flex
24 printf "%s\n" "$LEX"
25 test -n "$LEX" || echo "$0: cannot find lex. Will try to use pre-provided source."
26
27--
282.29.2
29
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd_git.bb b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
index ac2b5a266..82e5c3bc5 100644
--- a/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
+++ b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
@@ -4,17 +4,15 @@
4DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules" 4DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules"
5HOMEPAGE = "https://github.com/pikhq/musl-nscd" 5HOMEPAGE = "https://github.com/pikhq/musl-nscd"
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee" 7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fff9baeb9a392879d7fb25ba3a2696e4"
8SECTION = "utils" 8SECTION = "utils"
9 9
10DEPENDS += "flex-native bison-native flex bison" 10DEPENDS += "flex-native bison-native flex bison"
11 11
12PV = "1.0.2" 12PV = "1.1.0"
13 13
14SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4" 14SRCREV = "cddd6be6c629ca96f2d2e74ee52daf12bbef1f83"
15SRC_URI = "git://github.com/pikhq/musl-nscd;branch=master;protocol=https \ 15SRC_URI = "git://github.com/pikhq/musl-nscd;branch=master;protocol=https \
16 file://0001-Fix-build-under-GCC-fno-common.patch \
17 file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \
18 file://0001-nsswitch.y-Replace-empty-bison-extension.patch \ 16 file://0001-nsswitch.y-Replace-empty-bison-extension.patch \
19 " 17 "
20 18