diff options
author | Pascal Bach <pascal.bach@siemens.com> | 2019-06-17 12:23:03 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-06-17 08:17:12 -0700 |
commit | 50440a488a620e766eedddbbdd66227fec537462 (patch) | |
tree | 9485e6b816b8d40958135fef02af81d64826d02e /meta-oe/recipes-devtools | |
parent | 52a326728a0682bd2a28a133b9f112e951acf372 (diff) | |
download | meta-openembedded-50440a488a620e766eedddbbdd66227fec537462.tar.gz |
protobuf: 3.6.1 -> 3.8.0
Simple update to latest release
The patch is needed to make python3-protobuf compile
as otherwise a file it expects is missing.
Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/protobuf/protobuf/0001-Added-stubs-map_util.h-to-list-of-installed-headers.patch | 52 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/protobuf/protobuf_3.8.0.bb (renamed from meta-oe/recipes-devtools/protobuf/protobuf_3.6.1.bb) | 7 |
2 files changed, 55 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf/0001-Added-stubs-map_util.h-to-list-of-installed-headers.patch b/meta-oe/recipes-devtools/protobuf/protobuf/0001-Added-stubs-map_util.h-to-list-of-installed-headers.patch new file mode 100644 index 000000000..a160e5e97 --- /dev/null +++ b/meta-oe/recipes-devtools/protobuf/protobuf/0001-Added-stubs-map_util.h-to-list-of-installed-headers.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From ea6e776e50971c89ad2293046b6ae2a6a9753c56 Mon Sep 17 00:00:00 2001 | ||
2 | From: Adam Cozzette <acozzette@google.com> | ||
3 | Date: Thu, 6 Jun 2019 10:29:58 -0700 | ||
4 | Subject: [PATCH] Added stubs/map_util.h to list of installed headers | ||
5 | |||
6 | This should fix issue #6186. I also had to remove a couple unnecessary | ||
7 | const keywords in map_util.h because the no_warning_test was showing | ||
8 | errors about those. | ||
9 | |||
10 | Upstream-Status: Submitted [https://github.com/protocolbuffers/protobuf/pull/6223] | ||
11 | --- | ||
12 | src/Makefile.am | 1 + | ||
13 | src/google/protobuf/stubs/map_util.h | 4 ++-- | ||
14 | 2 files changed, 3 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/src/Makefile.am b/src/Makefile.am | ||
17 | index be18ba76..1689e221 100644 | ||
18 | --- a/src/Makefile.am | ||
19 | +++ b/src/Makefile.am | ||
20 | @@ -72,6 +72,7 @@ nobase_include_HEADERS = \ | ||
21 | google/protobuf/stubs/hash.h \ | ||
22 | google/protobuf/stubs/logging.h \ | ||
23 | google/protobuf/stubs/macros.h \ | ||
24 | + google/protobuf/stubs/map_util.h \ | ||
25 | google/protobuf/stubs/mutex.h \ | ||
26 | google/protobuf/stubs/once.h \ | ||
27 | google/protobuf/stubs/platform_macros.h \ | ||
28 | diff --git a/src/google/protobuf/stubs/map_util.h b/src/google/protobuf/stubs/map_util.h | ||
29 | index 2313e1f5..b04d9d46 100644 | ||
30 | --- a/src/google/protobuf/stubs/map_util.h | ||
31 | +++ b/src/google/protobuf/stubs/map_util.h | ||
32 | @@ -620,7 +620,7 @@ bool UpdateReturnCopy(Collection* const collection, | ||
33 | // twice. Unlike UpdateReturnCopy this also does not come with the issue of an | ||
34 | // undefined previous* in case new data was inserted. | ||
35 | template <class Collection> | ||
36 | -typename Collection::value_type::second_type* const | ||
37 | +typename Collection::value_type::second_type* | ||
38 | InsertOrReturnExisting(Collection* const collection, | ||
39 | const typename Collection::value_type& vt) { | ||
40 | std::pair<typename Collection::iterator, bool> ret = collection->insert(vt); | ||
41 | @@ -633,7 +633,7 @@ InsertOrReturnExisting(Collection* const collection, | ||
42 | |||
43 | // Same as above, except for explicit key and data. | ||
44 | template <class Collection> | ||
45 | -typename Collection::value_type::second_type* const | ||
46 | +typename Collection::value_type::second_type* | ||
47 | InsertOrReturnExisting( | ||
48 | Collection* const collection, | ||
49 | const typename Collection::value_type::first_type& key, | ||
50 | -- | ||
51 | 2.11.0 | ||
52 | |||
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.6.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.8.0.bb index cf72d9ca7..476d1e309 100644 --- a/meta-oe/recipes-devtools/protobuf/protobuf_3.6.1.bb +++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.8.0.bb | |||
@@ -10,13 +10,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b" | |||
10 | DEPENDS = "zlib" | 10 | DEPENDS = "zlib" |
11 | DEPENDS_append_class-target = " protobuf-native" | 11 | DEPENDS_append_class-target = " protobuf-native" |
12 | 12 | ||
13 | PV .= "+git${SRCPV}" | 13 | SRCREV = "09745575a923640154bcf307fba8aedff47f240a" |
14 | 14 | ||
15 | SRCREV = "48cb18e5c419ddd23d9badcfe4e9df7bde1979b2" | 15 | SRC_URI = "git://github.com/google/protobuf.git;branch=3.8.x \ |
16 | |||
17 | SRC_URI = "git://github.com/google/protobuf.git;branch=3.6.x \ | ||
18 | file://run-ptest \ | 16 | file://run-ptest \ |
19 | file://0001-protobuf-fix-configure-error.patch \ | 17 | file://0001-protobuf-fix-configure-error.patch \ |
18 | file://0001-Added-stubs-map_util.h-to-list-of-installed-headers.patch \ | ||
20 | " | 19 | " |
21 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
22 | 21 | ||