diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2024-07-08 14:10:52 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-07-08 08:40:19 -0700 |
commit | 23e3b5e97191175036c53f0983dedbe3940c87e2 (patch) | |
tree | 7449bba8c879c694eda524ff882f46e584768302 /meta-oe/recipes-devtools | |
parent | cdd196388a3053fad5bed239e08e2c90fd67dc52 (diff) | |
download | meta-openembedded-23e3b5e97191175036c53f0983dedbe3940c87e2.tar.gz |
giflib: fix build with gold and avoid imagemagick-native dependency
* avoid imagemagick-native like upstream did in:
https://sourceforge.net/p/giflib/code/ci/d54b45b0240d455bbaedee4be5203d2703e59967/
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
3 files changed, 39 insertions, 45 deletions
diff --git a/meta-oe/recipes-devtools/giflib/files/add_suffix_to_convert_binary_used_in_Makefile.patch b/meta-oe/recipes-devtools/giflib/files/add_suffix_to_convert_binary_used_in_Makefile.patch deleted file mode 100644 index a01b28ac6..000000000 --- a/meta-oe/recipes-devtools/giflib/files/add_suffix_to_convert_binary_used_in_Makefile.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | Subject: Modify binary name "convert" to "convert.im7" | ||
2 | |||
3 | The change is needed to resolve the below compilation error | ||
4 | after giflib version upgrade. Log data follows: | ||
5 | | DEBUG: Executing shell function do_compile | ||
6 | | NOTE: make -j 8 | ||
7 | | make -C doc | ||
8 | | make[1]: Entering directory '../giflib/5.2.2/giflib-5.2.2/doc' | ||
9 | | convert ../pic/gifgrid.gif -resize 50x50 giflib-logo.gif | ||
10 | | make[1]: convert: No such file or directory | ||
11 | | make[1]: *** [Makefile:46: giflib-logo.gif] Error 127 | ||
12 | | make[1]: Leaving directory '../giflib/5.2.2/giflib-5.2.2/doc' | ||
13 | | make: *** [Makefile:93: all] Error 2 | ||
14 | | ERROR: oe_runmake failed | ||
15 | |||
16 | Added dependency on ImageMagick which includes "convert" utility, | ||
17 | to ensure availability of required tool during compilation process. | ||
18 | |||
19 | This patch updates the binary name used in Makefile from | ||
20 | "convert" to "convert.im7" for resizing the logo image used in HTML | ||
21 | documentation as Imagemagick installs binary in this format. | ||
22 | |||
23 | Below commits justify the cause of adding the suffix to binaries | ||
24 | provided by ImageMagic package: | ||
25 | https://git.openembedded.org/meta-openembedded/commit/meta-oe/recipes-support/imagemagick?id=dcbb49f707e7ad9bf755dd3275ffc442154b8144 | ||
26 | https://git.openembedded.org/meta-openembedded/commit/meta-oe/recipes-support/imagemagick?id=6e0c24e9b3f9d430dec57f61f8c12c74bca5375d | ||
27 | |||
28 | Signed-off-by: Bhabu Bindu <bhabubindu@kpit.com> | ||
29 | Upstream-Status: Inappropriate [OE specific] | ||
30 | |||
31 | =================================================================== | ||
32 | --- a/doc/Makefile | ||
33 | +++ b/doc/Makefile | ||
34 | @@ -43,7 +43,7 @@ | ||
35 | |||
36 | # Logo image file for HTML docs | ||
37 | giflib-logo.gif: ../pic/gifgrid.gif | ||
38 | - convert $^ -resize 50x50 $@ | ||
39 | + convert.im7 $^ -resize 50x50 $@ | ||
40 | |||
41 | # Philosophical choice: the website gets the internal manual pages | ||
42 | allhtml: $(XMLALL:.xml=.html) giflib-logo.gif | ||
diff --git a/meta-oe/recipes-devtools/giflib/giflib/0001-Makefile-fix-typo-in-soname-argument.patch b/meta-oe/recipes-devtools/giflib/giflib/0001-Makefile-fix-typo-in-soname-argument.patch new file mode 100644 index 000000000..dc87ed60b --- /dev/null +++ b/meta-oe/recipes-devtools/giflib/giflib/0001-Makefile-fix-typo-in-soname-argument.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 7f0cd4b6b56183b0afbefd01425e5ebd2b8733b4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <martin.jansa@gmail.com> | ||
3 | Date: Mon, 8 Jul 2024 13:18:11 +0200 | ||
4 | Subject: [PATCH] Makefile: fix typo in soname argument | ||
5 | |||
6 | * introduced in: | ||
7 | https://sourceforge.net/p/giflib/code/ci/b65c7ac2905c0842e7977a7b51d83af4486ca7b8/ | ||
8 | there is no LIBUTILMAJOR variable only LIBUTILSOMAJOR leading to: | ||
9 | |||
10 | ld: fatal error: -soname: must take a non-empty argument | ||
11 | collect2: error: ld returned 1 exit status | ||
12 | |||
13 | with some linkers like GOLD | ||
14 | |||
15 | Signed-off-by: Martin Jansa <martin.jansa@gmail.com> | ||
16 | --- | ||
17 | Upstream-Status: Submitted [https://sourceforge.net/p/giflib/code/merge-requests/17/] | ||
18 | |||
19 | Makefile | 2 +- | ||
20 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/Makefile b/Makefile | ||
23 | index 87966a9..41b149e 100644 | ||
24 | --- a/Makefile | ||
25 | +++ b/Makefile | ||
26 | @@ -109,7 +109,7 @@ $(LIBUTILSO): $(UOBJECTS) $(UHEADERS) | ||
27 | ifeq ($(UNAME), Darwin) | ||
28 | $(CC) $(CFLAGS) -dynamiclib -current_version $(LIBVER) $(OBJECTS) -o $(LIBUTILSO) | ||
29 | else | ||
30 | - $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname -Wl,$(LIBUTILMAJOR) -o $(LIBUTILSO) $(UOBJECTS) | ||
31 | + $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname -Wl,$(LIBUTILSOMAJOR) -o $(LIBUTILSO) $(UOBJECTS) | ||
32 | endif | ||
33 | |||
34 | libutil.a: $(UOBJECTS) $(UHEADERS) | ||
diff --git a/meta-oe/recipes-devtools/giflib/giflib_5.2.2.bb b/meta-oe/recipes-devtools/giflib/giflib_5.2.2.bb index 7d8a175fe..aa47f9309 100644 --- a/meta-oe/recipes-devtools/giflib/giflib_5.2.2.bb +++ b/meta-oe/recipes-devtools/giflib/giflib_5.2.2.bb | |||
@@ -5,14 +5,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ae11c61b04b2917be39b11f78d71519a" | |||
5 | 5 | ||
6 | CVE_PRODUCT = "giflib_project:giflib" | 6 | CVE_PRODUCT = "giflib_project:giflib" |
7 | 7 | ||
8 | DEPENDS = "xmlto-native imagemagick-native" | 8 | DEPENDS = "xmlto-native" |
9 | 9 | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/giflib/${BP}.tar.gz \ | 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/giflib/${BP}.tar.gz \ |
11 | file://add_suffix_to_convert_binary_used_in_Makefile.patch" | 11 | https://sourceforge.net/p/giflib/code/ci/d54b45b0240d455bbaedee4be5203d2703e59967/tree/doc/giflib-logo.gif?format=raw;subdir=${BP}/doc;name=logo;downloadfilename=giflib-logo.gif \ |
12 | file://0001-Makefile-fix-typo-in-soname-argument.patch \ | ||
13 | " | ||
12 | 14 | ||
15 | SRC_URI[logo.sha256sum] = "1a54383986adad1521d00e003b4c482c27e8bc60690be944a1f3319c75abc2c9" | ||
13 | SRC_URI[sha256sum] = "be7ffbd057cadebe2aa144542fd90c6838c6a083b5e8a9048b8ee3b66b29d5fb" | 16 | SRC_URI[sha256sum] = "be7ffbd057cadebe2aa144542fd90c6838c6a083b5e8a9048b8ee3b66b29d5fb" |
14 | 17 | ||
15 | |||
16 | do_install() { | 18 | do_install() { |
17 | # using autotools's default will end up in /usr/local | 19 | # using autotools's default will end up in /usr/local |
18 | oe_runmake DESTDIR=${D} PREFIX=${prefix} LIBDIR=${libdir} install | 20 | oe_runmake DESTDIR=${D} PREFIX=${prefix} LIBDIR=${libdir} install |