summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-04-03 17:50:14 +0800
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commit1816eb77793140a1e5940e3dbc005df48ada6384 (patch)
tree9008585c9cfc5d936b9caf78ccbeebcacab18a70 /meta-oe/recipes-devtools
parent2768c1deb3e3e8ad96c0f251fd44d76c5b044159 (diff)
downloadmeta-openembedded-1816eb77793140a1e5940e3dbc005df48ada6384.tar.gz
php5: upgrade to 5.6.35
For changes, see: http://php.net/ChangeLog-5.php#5.6.35 Split patches between php5 and php7 to ensure there are no fuzz warnings for both the versions. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/php/php.inc2
-rw-r--r--meta-oe/recipes-devtools/php/php/php5-change-AC_TRY_RUN-to-AC_TRY_LINK.patch63
-rw-r--r--meta-oe/recipes-devtools/php/php/php5-pear-makefile.patch26
-rw-r--r--meta-oe/recipes-devtools/php/php/php5-phar-makefile.patch46
-rw-r--r--meta-oe/recipes-devtools/php/php_5.6.35.bb (renamed from meta-oe/recipes-devtools/php/php_5.6.33.bb)12
-rw-r--r--meta-oe/recipes-devtools/php/php_7.2.4.bb4
6 files changed, 148 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc
index d2af4f619..fbc750df8 100644
--- a/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-oe/recipes-devtools/php/php.inc
@@ -18,8 +18,6 @@ SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \
18SRC_URI_append_class-target = " \ 18SRC_URI_append_class-target = " \
19 file://iconv.patch \ 19 file://iconv.patch \
20 file://imap-fix-autofoo.patch \ 20 file://imap-fix-autofoo.patch \
21 file://pear-makefile.patch \
22 file://phar-makefile.patch \
23 file://php_exec_native.patch \ 21 file://php_exec_native.patch \
24 file://php-fpm.conf \ 22 file://php-fpm.conf \
25 file://php-fpm-apache.conf \ 23 file://php-fpm-apache.conf \
diff --git a/meta-oe/recipes-devtools/php/php/php5-change-AC_TRY_RUN-to-AC_TRY_LINK.patch b/meta-oe/recipes-devtools/php/php/php5-change-AC_TRY_RUN-to-AC_TRY_LINK.patch
new file mode 100644
index 000000000..1d21f8c56
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php/php5-change-AC_TRY_RUN-to-AC_TRY_LINK.patch
@@ -0,0 +1,63 @@
1From 5f49987e88dfcbdb84be6e0c9025432fbd998709 Mon Sep 17 00:00:00 2001
2From: Roy Li <rongqing.li@windriver.com>
3Date: Thu, 20 Aug 2015 16:29:35 +0800
4Subject: [PATCH] config.m4: change AC_TRY_RUN to AC_TRY_LINK
5
6Upstream-Status: Pending
7
8AC_TRY_RUN is not suitable for cross-compile
9
10Signed-off-by: Roy Li <rongqing.li@windriver.com>
11
12%% original patch: change-AC_TRY_RUN-to-AC_TRY_LINK.patch
13
14%% original patch: php5-change-AC_TRY_RUN-to-AC_TRY_LINK.patch
15---
16 ext/fileinfo/config.m4 | 31 ++++++-------------------------
17 1 file changed, 6 insertions(+), 25 deletions(-)
18
19diff --git a/ext/fileinfo/config.m4 b/ext/fileinfo/config.m4
20index 7e98d62..8a8ea0e 100644
21--- a/ext/fileinfo/config.m4
22+++ b/ext/fileinfo/config.m4
23@@ -14,31 +14,12 @@ if test "$PHP_FILEINFO" != "no"; then
24 libmagic/readcdf.c libmagic/softmagic.c"
25
26 AC_MSG_CHECKING([for strcasestr])
27- AC_TRY_RUN([
28-#include <string.h>
29-#include <strings.h>
30-#include <stdlib.h>
31-
32-int main(void)
33-{
34- char *s0, *s1, *ret;
35-
36- s0 = (char *) malloc(42);
37- s1 = (char *) malloc(8);
38-
39- memset(s0, 'X', 42);
40- s0[24] = 'Y';
41- s0[26] = 'Z';
42- s0[41] = '\0';
43- memset(s1, 'x', 8);
44- s1[0] = 'y';
45- s1[2] = 'Z';
46- s1[7] = '\0';
47-
48- ret = strcasestr(s0, s1);
49-
50- return !(NULL != ret);
51-}
52+ AC_TRY_COMPILE([
53+ #include <string.h>
54+ #include <strings.h>
55+ #include <stdlib.h>
56+ ],[
57+ strcasestr(NULL, NULL);
58 ],[
59 dnl using the platform implementation
60 AC_MSG_RESULT(yes)
61--
622.7.4
63
diff --git a/meta-oe/recipes-devtools/php/php/php5-pear-makefile.patch b/meta-oe/recipes-devtools/php/php/php5-pear-makefile.patch
new file mode 100644
index 000000000..cff6426ab
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php/php5-pear-makefile.patch
@@ -0,0 +1,26 @@
1From 79725e82d5981fc94eb657f0f46a499dbfc1cc40 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 2 Nov 2011 16:54:57 +0100
4Subject: [PATCH] Upstream-status: Unknown
5
6%% original patch: php5-pear-makefile.patch
7---
8 pear/Makefile.frag | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/pear/Makefile.frag b/pear/Makefile.frag
12index 00bacae..739eeca 100644
13--- a/pear/Makefile.frag
14+++ b/pear/Makefile.frag
15@@ -11,7 +11,7 @@ PEAR_PREFIX = -dp a${program_prefix}
16 PEAR_SUFFIX = -ds a$(program_suffix)
17
18 install-pear-installer: $(SAPI_CLI_PATH)
19- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
20+ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
21
22 install-pear:
23 @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
24--
252.7.4
26
diff --git a/meta-oe/recipes-devtools/php/php/php5-phar-makefile.patch b/meta-oe/recipes-devtools/php/php/php5-phar-makefile.patch
new file mode 100644
index 000000000..4e1efd40c
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php/php5-phar-makefile.patch
@@ -0,0 +1,46 @@
1From 3ea626a8d081f56b01004b7992534d4e6b81a9cc Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 2 Nov 2011 16:54:57 +0100
4Subject: [PATCH] Fix phar packaging
5
6Inherited from OE-Classic, with some additions to fix host paths leaking
7into the target package.
8
9Upstream-Status: Inappropriate [config]
10
11%% original patch: php5-phar-makefile.patch
12---
13 ext/phar/Makefile.frag | 17 +++--------------
14 1 file changed, 3 insertions(+), 14 deletions(-)
15
16diff --git a/ext/phar/Makefile.frag b/ext/phar/Makefile.frag
17index b8b1b42..1005b2d 100644
18--- a/ext/phar/Makefile.frag
19+++ b/ext/phar/Makefile.frag
20@@ -5,20 +5,9 @@ pharcmd: $(builddir)/phar.php $(builddir)/phar.phar
21
22 PHP_PHARCMD_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 -d 'safe_mode=0'
23 PHP_PHARCMD_EXECUTABLE = ` \
24- if test -x "$(top_builddir)/$(SAPI_CLI_PATH)"; then \
25- $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
26- if test "x$(PHP_MODULES)" != "x"; then \
27- $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
28- for i in bz2 zlib phar; do \
29- if test -f "$(top_builddir)/modules/$$i.la"; then \
30- . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
31- fi; \
32- done; \
33- fi; \
34- else \
35- $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
36- fi;`
37-PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
38+ $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; `
39+
40+PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
41
42 $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
43 -@test -d $(builddir)/phar || mkdir $(builddir)/phar
44--
452.7.4
46
diff --git a/meta-oe/recipes-devtools/php/php_5.6.33.bb b/meta-oe/recipes-devtools/php/php_5.6.35.bb
index 9c78918df..5ccbfa1ad 100644
--- a/meta-oe/recipes-devtools/php/php_5.6.33.bb
+++ b/meta-oe/recipes-devtools/php/php_5.6.35.bb
@@ -2,14 +2,20 @@ require php.inc
2 2
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b602636d46a61c0ac0432bbf5c078fe4" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=b602636d46a61c0ac0432bbf5c078fe4"
4 4
5SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch \ 5SRC_URI += "file://php5-change-AC_TRY_RUN-to-AC_TRY_LINK.patch \
6 file://pthread-check-threads-m4.patch \ 6 file://pthread-check-threads-m4.patch \
7 file://0001-Add-lpthread-to-link.patch \ 7 file://0001-Add-lpthread-to-link.patch \
8 file://acinclude-xml2-config.patch \ 8 file://acinclude-xml2-config.patch \
9 file://0001-acinclude-use-pkgconfig-for-libxml2-config.patch \ 9 file://0001-acinclude-use-pkgconfig-for-libxml2-config.patch \
10 " 10 "
11SRC_URI[md5sum] = "1ba84d9881521065f6398e665786f9e2" 11
12SRC_URI[sha256sum] = "07f696a9761dcd839e2045c95c3a4d2ffb52c54417477cca9d30a14975b831cc" 12SRC_URI_append_class-target = " \
13 file://php5-pear-makefile.patch \
14 file://php5-phar-makefile.patch \
15 "
16
17SRC_URI[md5sum] = "905ae5f586351f3ca29d044c9484d475"
18SRC_URI[sha256sum] = "ee78a7e9ca21d8ea394d037c55effff477a49dbae31c7753c547036f5bd73b92"
13 19
14DEPENDS += "libmcrypt" 20DEPENDS += "libmcrypt"
15EXTRA_OECONF += "--with-mcrypt=${STAGING_DIR_TARGET}${exec_prefix} \ 21EXTRA_OECONF += "--with-mcrypt=${STAGING_DIR_TARGET}${exec_prefix} \
diff --git a/meta-oe/recipes-devtools/php/php_7.2.4.bb b/meta-oe/recipes-devtools/php/php_7.2.4.bb
index e00e1b567..1a9c8ffad 100644
--- a/meta-oe/recipes-devtools/php/php_7.2.4.bb
+++ b/meta-oe/recipes-devtools/php/php_7.2.4.bb
@@ -6,6 +6,10 @@ SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch \
6 file://0001-acinclude.m4-skip-binconfig-check-for-libxml.patch \ 6 file://0001-acinclude.m4-skip-binconfig-check-for-libxml.patch \
7 file://0001-main-php_ini.c-build-empty-php_load_zend_extension_c.patch \ 7 file://0001-main-php_ini.c-build-empty-php_load_zend_extension_c.patch \
8 " 8 "
9SRC_URI_append_class-target = " \
10 file://pear-makefile.patch \
11 file://phar-makefile.patch \
12 "
9 13
10SRC_URI[md5sum] = "864c64ffd2f1686b035ef8ce6a6d8478" 14SRC_URI[md5sum] = "864c64ffd2f1686b035ef8ce6a6d8478"
11SRC_URI[sha256sum] = "11658a0d764dc94023b9fb60d4b5eb75d438ad17981efe70abb0d0d09a447ef3" 15SRC_URI[sha256sum] = "11658a0d764dc94023b9fb60d4b5eb75d438ad17981efe70abb0d0d09a447ef3"