summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2018-10-04 16:15:37 -0700
committerKhem Raj <raj.khem@gmail.com>2018-10-04 20:00:52 -0700
commit126f046247079aed0fdc2acda21b0f6898b56bd6 (patch)
tree5886165bb3d97aa9045a5c2f6615c7b35ea1f11e /meta-oe/recipes-devtools
parent7d892a14ef4e03ef916e18ace4505073a36afb1d (diff)
downloadmeta-openembedded-126f046247079aed0fdc2acda21b0f6898b56bd6.tar.gz
nlohmann-json: Add recipe
nlohmann-json is a c++ header-only json library. Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
new file mode 100644
index 000000000..a89b659ae
--- /dev/null
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
6
7SRC_URI = "git://github.com/nlohmann/json.git"
8
9PV = "3.2.0+git${SRCPV}"
10
11SRCREV = "8c20571136f2d5351b379a06ad6591bd980880fe"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
18
19# nlohmann-json is a header only C++ library, so the main package will be empty.
20
21RDEPENDS_${PN}-dev = ""
22
23BBCLASSEXTEND = "native nativesdk"