diff options
author | Markus Volk <f_l_k@t-online.de> | 2022-06-21 16:52:11 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-06-30 13:39:29 -0400 |
commit | 0b32f0000ce6b93306db7f0d2d72c36b5270e2ab (patch) | |
tree | 5d35f1d94b6dbc985ae0270262766cb357cd888d /meta-oe/recipes-devtools | |
parent | 2117bbee2087d9a3ce9040c8e4ae89306b796145 (diff) | |
download | meta-openembedded-0b32f0000ce6b93306db7f0d2d72c36b5270e2ab.tar.gz |
flatbuffers: update to 2.0.6
- fix flatc not found issue
- build the python3 module as a separate package to allow proper install
- remove fpic CXXFLAG as it seems to be unneeded
- use python3-native
- remove -DCMAKE_BUILD_TYPE=Release option and its outdated comment.
After a long discussion the default behavior was changed:
https://github.com/google/flatbuffers/pull/5180
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.6.bb (renamed from meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.0.bb) | 24 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb | 15 |
2 files changed, 21 insertions, 18 deletions
diff --git a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.0.bb b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.6.bb index bf74f1229f..3ca4772100 100644 --- a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.0.bb +++ b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.6.bb | |||
@@ -3,41 +3,29 @@ HOMEPAGE = "https://github.com/google/flatbuffers" | |||
3 | SECTION = "console/tools" | 3 | SECTION = "console/tools" |
4 | LICENSE = "Apache-2.0" | 4 | LICENSE = "Apache-2.0" |
5 | 5 | ||
6 | inherit python3-dir | 6 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
7 | 7 | ||
8 | PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-${PYTHON_PN}" | 8 | DEPENDS = "flatbuffers-native" |
9 | 9 | ||
10 | RDEPENDS:${PN}-compiler = "${PN}" | 10 | RDEPENDS:${PN}-compiler = "${PN}" |
11 | RDEPENDS:${PN}-${PYTHON_PN} = "${PN}" | ||
12 | RDEPENDS:${PN}-dev += "${PN}-compiler" | 11 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
13 | 12 | ||
14 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" | 13 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
15 | 14 | ||
16 | SRCREV = "a9a295fecf3fbd5a4f571f53b01f63202a3e2113" | 15 | SRCREV = "615616cb5549a34bdf288c04bc1b94bd7a65c396" |
17 | SRC_URI = "git://github.com/google/flatbuffers.git;branch=master;protocol=https" | 16 | SRC_URI = "git://github.com/google/flatbuffers.git;branch=master;protocol=https" |
18 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
19 | 18 | ||
20 | CVE_CHECK_IGNORE += "CVE-2020-35864" | 19 | CVE_CHECK_IGNORE += "CVE-2020-35864" |
21 | 20 | ||
22 | CXXFLAGS += "-fPIC" | 21 | EXTRA_OECMAKE += " \ |
23 | BUILD_CXXFLAGS += "-fPIC" | ||
24 | |||
25 | # BUILD_TYPE=Release is required, otherwise flatc is not installed | ||
26 | EXTRA_OECMAKE += "\ | ||
27 | -DCMAKE_BUILD_TYPE=Release \ | ||
28 | -DFLATBUFFERS_BUILD_TESTS=OFF \ | 22 | -DFLATBUFFERS_BUILD_TESTS=OFF \ |
29 | -DFLATBUFFERS_BUILD_SHAREDLIB=ON \ | 23 | -DFLATBUFFERS_BUILD_SHAREDLIB=ON \ |
30 | " | 24 | " |
25 | EXTRA_OECMAKE:append:class-target = " -DFLATBUFFERS_FLATC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/flatc" | ||
31 | 26 | ||
32 | inherit cmake | 27 | inherit cmake python3native |
33 | |||
34 | do_install:append() { | ||
35 | install -d ${D}${PYTHON_SITEPACKAGES_DIR} | ||
36 | cp -rf ${S}/python/flatbuffers ${D}${PYTHON_SITEPACKAGES_DIR} | ||
37 | } | ||
38 | 28 | ||
39 | FILES:${PN}-compiler = "${bindir}" | 29 | FILES:${PN}-compiler = "${bindir}" |
40 | 30 | ||
41 | FILES:${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}" | ||
42 | |||
43 | BBCLASSEXTEND = "native nativesdk" | 31 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb b/meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb new file mode 100644 index 0000000000..cc453da357 --- /dev/null +++ b/meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "Memory Efficient Serialization Library - Python3 Modules" | ||
2 | HOMEPAGE = "https://github.com/google/flatbuffers" | ||
3 | SECTION = "console/tools" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://../LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
7 | |||
8 | SRCREV = "615616cb5549a34bdf288c04bc1b94bd7a65c396" | ||
9 | SRC_URI = "git://github.com/google/flatbuffers.git;branch=master;protocol=https" | ||
10 | S = "${WORKDIR}/git/python" | ||
11 | |||
12 | RDEPENDS:${PN} = "flatbuffers" | ||
13 | |||
14 | inherit setuptools3 | ||
15 | |||