summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2017-10-17 23:50:09 +1100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-27 16:39:33 +0000
commit09d5d09762be59ad374f0da9e4a37063e179a726 (patch)
treea3d482da8400c4a90e72a9a968052b33c8d412be /meta-oe/recipes-devtools
parent0d220e002e4f525469f0c24e0585318d2178e7a1 (diff)
downloadmeta-openembedded-09d5d09762be59ad374f0da9e4a37063e179a726.tar.gz
nodejs: Remove unreferenced patches
Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch29
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch59
2 files changed, 0 insertions, 88 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch b/meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
deleted file mode 100644
index 324a4683d..000000000
--- a/meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From c2aff16cc196a61f4ab1cdae4a91c7926123c239 Mon Sep 17 00:00:00 2001
2From: Zuzana Svetlikova <zsvetlik@redhat.com>
3Date: Thu, 27 Apr 2017 14:25:42 +0200
4Subject: [PATCH] Disable running gyp on shared deps
5
6---
7 Makefile | 7 +++----
8 1 file changed, 3 insertions(+), 4 deletions(-)
9
10diff --git a/Makefile b/Makefile
11index 0a217bd893..e1229ad07f 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -79,10 +79,9 @@ $(NODE_G_EXE): config.gypi out/Makefile
15 $(MAKE) -C out BUILDTYPE=Debug V=$(V)
16 if [ ! -r $@ -o ! -L $@ ]; then ln -fs out/Debug/$(NODE_EXE) $@; fi
17
18-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
19- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
20- deps/v8/gypfiles/features.gypi deps/v8/src/v8.gyp node.gyp \
21- config.gypi
22+out/Makefile: common.gypi deps/http_parser/http_parser.gyp \
23+ deps/v8/gypfiles/toolchain.gypi deps/v8/gypfiles/features.gypi \
24+ deps/v8/src/v8.gyp node.gyp config.gypi
25 $(PYTHON) tools/gyp_node.py -f make
26
27 config.gypi: configure
28--
292.12.2
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch b/meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch
deleted file mode 100644
index ed2473897..000000000
--- a/meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch
+++ /dev/null
@@ -1,59 +0,0 @@
1Bugfix for --no-registry in nodejs-v0.12.2
2
3diff -u -r node-v0.12.2_def/deps/npm/lib/cache/caching-client.js node-v0.12.2/deps/npm/lib/cache/caching-client.js
4--- node-v0.12.2_def/deps/npm/lib/cache/caching-client.js 2015-04-01 01:13:01.000000000 +0300
5+++ node-v0.12.2/deps/npm/lib/cache/caching-client.js 2015-05-18 00:47:10.738599686 +0300
6@@ -67,6 +67,22 @@
7 var cacheBase = cacheFile(npm.config.get("cache"))(uri)
8 var cachePath = path.join(cacheBase, ".cache.json")
9
10+ if (parsed.host === "noregistry") (function() {
11+ var stat = null
12+ var file = npm.config.get("cache") + parsed.pathname + "/.cache.json"
13+ try {
14+ stat = fs.statSync(cachePath)
15+ } catch (ex) {}
16+ if (!stat) try {
17+ stat = fs.statSync(file)
18+ cachePath = file
19+ } catch (ex) {
20+ stat = "Registry not defined and registry files not found: \"" +
21+ cachePath + "\", \"" + file + "\"."
22+ throw new Error(stat)
23+ }
24+ })()
25+
26 // If the GET is part of a write operation (PUT or DELETE), then
27 // skip past the cache entirely, but still save the results.
28 if (uri.match(/\?write=true$/)) {
29@@ -83,12 +99,17 @@
30 }
31 catch (ex) {
32 data = null
33+ if (parsed.host === "noregistry")
34+ throw new Error("File \"" + cachePath+"\"" + " corrupted.")
35 }
36
37 params.stat = stat
38 params.data = data
39
40- get_.call(client, uri, cachePath, params, cb)
41+ if (parsed.host === "noregistry")
42+ cb(null, data, JSON.stringify(data), { statusCode : 304 })
43+ else
44+ get_.call(client, uri, cachePath, params, cb)
45 })
46 }
47 else {
48diff -u -r node-v0.12.2_def/deps/npm/lib/utils/map-to-registry.js node-v0.12.2/deps/npm/lib/utils/map-to-registry.js
49--- node-v0.12.2_def/deps/npm/lib/utils/map-to-registry.js 2015-04-01 01:13:01.000000000 +0300
50+++ node-v0.12.2/deps/npm/lib/utils/map-to-registry.js 2015-05-18 01:15:10.030569613 +0300
51@@ -45,6 +45,8 @@
52
53 log.silly("mapToRegistry", "registry", registry)
54
55+ if (!registry) return cb(null, "http://noregistry/" + name, {})
56+
57 var auth = config.getCredentialsByURI(registry)
58
59 // normalize registry URL so resolution doesn't drop a piece of registry URL