summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/xerces-c
diff options
context:
space:
mode:
authorJagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>2015-08-20 21:58:07 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 20:02:23 +0200
commite956ce897bf179edfdfe40103cc6879d8f13dde9 (patch)
tree503ad650ced272032763b1d649defd5351d84f04 /meta-oe/recipes-devtools/xerces-c
parent3a92cd036ca878a736b7643e391c123b32e05f16 (diff)
downloadmeta-openembedded-e956ce897bf179edfdfe40103cc6879d8f13dde9.tar.gz
xerces-c : add new recipe
Xerces-C++ is a validating XML parser written in a portable subset of C++. Xerces-C++ makes it easy to give your application the ability to read and write XML data. A shared library is provided for parsing, generating, manipulating, and validating XML documents using the DOM, SAX, and SAX2 APIs Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/xerces-c')
-rw-r--r--meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.2.bb b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.2.bb
new file mode 100644
index 000000000..8699d6f00
--- /dev/null
+++ b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Xerces-c is a validating xml parser written in C++"
2DESCRIPTION = "Xerces-C++ makes it easy to give your application \
3 the ability to read and write XML data. \
4 A shared library is provided for parsing, generating, \
5 manipulating, and validating XML documents using \
6 the DOM, SAX, and SAX2 APIs."
7HOMEPAGE = "http://xerces.apache.org/xerces-c/"
8SECTION = "libs"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRC_URI = "http://apache.lauf-forum.at/xerces/c/3/sources/${BP}.tar.bz2"
13SRC_URI[md5sum] = "d987b8bb576aea456e92454781fe3615"
14SRC_URI[sha256sum] = "95d8655c4c50668ad60d555b59da9f31937b2c53638aa8d5768cb169f192d5e1"
15
16inherit autotools
17
18PACKAGECONFIG ??= "curl icu"
19PACKAGECONFIG[curl] = "--with-curl=${STAGING_DIR},--with-curl=no,curl"
20PACKAGECONFIG[icu] = "--with-icu=${STAGING_DIR},--with-icu=no,icu"
21PACKAGES = "libxerces-c \
22 libxerces-c-dbg \
23 libxerces-c-dev \
24 xerces-c-samples \
25 xerces-c-samples-dbg \
26 libxerces-c-staticdev \
27 "
28
29FILES_libxerces-c = "${libdir}/libxerces-c-3.1.so"
30FILES_libxerces-c-dbg = "${libdir}/.debug \
31 ${prefix}/src/debug "
32FILES_libxerces-c-dev = "${libdir}/lib*.la \
33 ${libdir}/libxerces-c.so \
34 ${libdir}/pkgconfig/xerces-c.pc \
35 ${includedir}/xercesc \
36 "
37FILES_xerces-c-samples = "${bindir}/*"
38FILES_xerces-c-samples-dbg = "${bindir}/.debug/"
39FILES_libxerces-c-staticdev = "${libdir}/lib*.a"