diff options
author | wangmy <wangmy@fujitsu.com> | 2022-07-23 13:40:46 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-07-26 20:49:05 -0400 |
commit | 5719b75341a4f72563af51549b3d3fcd2d266585 (patch) | |
tree | a7ef343d21213017f798d919d202e5e55bca392d /meta-oe/recipes-devtools/unattended-upgrades/unattended-upgrades_2.9.1.bb | |
parent | d2a6027876504fdf48e5a250a5b6de9b96e07f53 (diff) | |
download | meta-openembedded-5719b75341a4f72563af51549b3d3fcd2d266585.tar.gz |
unattended-upgrades: upgrade 2.6 -> 2.9.1
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/unattended-upgrades/unattended-upgrades_2.9.1.bb')
-rw-r--r-- | meta-oe/recipes-devtools/unattended-upgrades/unattended-upgrades_2.9.1.bb | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/unattended-upgrades/unattended-upgrades_2.9.1.bb b/meta-oe/recipes-devtools/unattended-upgrades/unattended-upgrades_2.9.1.bb new file mode 100644 index 0000000000..e37dbcd02f --- /dev/null +++ b/meta-oe/recipes-devtools/unattended-upgrades/unattended-upgrades_2.9.1.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "This script upgrades packages automatically and unattended." | ||
2 | DESCRIPTION = "The purpose of unattended-upgrades is to keep the computer current with the latest security (and other) updates automatically." | ||
3 | HOMEPAGE = "https://wiki.debian.org/UnattendedUpgrades" | ||
4 | LICENSE = "GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | ||
6 | file://debian/copyright;md5=62b5f2ac0ede901fb245eefbe54c181f" | ||
7 | |||
8 | SRC_URI = "git://github.com/mvo5/unattended-upgrades.git;protocol=https;branch=master \ | ||
9 | file://0001-unattended-upgrade-Remove-distro_info-usage-to-check.patch \ | ||
10 | file://0001-setup.py-Disable-autodection-of-modules.patch \ | ||
11 | " | ||
12 | |||
13 | SRCREV = "5aff8fa2b5b60b7c11bbfb39c884477e72d11d02" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit setuptools3_legacy | ||
18 | |||
19 | DEPENDS += "apt intltool-native python3-distutils-extra-native" | ||
20 | RDEPENDS:${PN} += "apt lsb-release python3-apt python3-core python3-datetime python3-email python3-fcntl python3-io python3-logging python3-stringold python3-syslog" | ||
21 | |||
22 | do_configure:prepend () { | ||
23 | install -Dm 0644 ${S}/data/50unattended-upgrades.Debian ${S}/data/50unattended-upgrades | ||
24 | } | ||
25 | |||
26 | do_install:append () { | ||
27 | # fix bad installation path's | ||
28 | mv -v ${D}/usr/usr/share/* ${D}/usr/share/ | ||
29 | rm -r ${D}/usr/usr | ||
30 | } | ||
31 | |||
32 | FILES:${PN} = "${bindir} ${exec_prefix}/etc ${libdir} ${datadir} ${nonarch_libdir}" | ||