diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-06-17 23:12:47 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-17 15:11:21 -0700 |
commit | 358b3982583c93fdc0a4cebdab31f923d77b7f8b (patch) | |
tree | cea587eb9d87c43e3bcd23c229e2584bc83f2a12 /meta-oe/recipes-devtools/sip/sip3_4.19.23.bb | |
parent | 2bc281393aa6c6b83218f2996c32b793ac79a42a (diff) | |
download | meta-openembedded-358b3982583c93fdc0a4cebdab31f923d77b7f8b.tar.gz |
sip3: Upgrade 4.19.19 -> 4.19.23
Upgrade to release 4.19.23:
- Added some missing quotes to configure.py
- Fixed a race condition when calling the PyQt5-specific meta-call
helper.
- Fixed the wrapping of methods that return a Py_Ssize_t.
- The code generator now distinguishes between the copy/assignment
helper and the array helper when determining which helpers can
be generated.
- Fixed the code generation when making a copy of C++ object on
the stack to the heap when the class has no suitable ctor.
- Check there is a public copy ctor when we can't using an
assigment operator as a workaround.
- Preserve any current exception in the implementation of the
wrapper dealloc functions.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/sip/sip3_4.19.23.bb')
-rw-r--r-- | meta-oe/recipes-devtools/sip/sip3_4.19.23.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb b/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb new file mode 100644 index 0000000000..320755b844 --- /dev/null +++ b/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | SUMMARY = "SIP is a C++/Python Wrapper Generator" | ||
2 | HOMEPAGE = "https://riverbankcomputing.com/software/sip/" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPLv2+" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303" | ||
6 | |||
7 | SRC_URI = "https://www.riverbankcomputing.com/static/Downloads/sip/${PV}/sip-${PV}.tar.gz \ | ||
8 | " | ||
9 | SRC_URI[md5sum] = "70adc0c9734e2d9dcd241d3f931dfc74" | ||
10 | SRC_URI[sha256sum] = "22ca9bcec5388114e40d4aafd7ccd0c4fe072297b628d0c5cdfa2f010c0bc7e7" | ||
11 | |||
12 | inherit python3-dir python3native | ||
13 | |||
14 | S = "${WORKDIR}/sip-${PV}" | ||
15 | |||
16 | DEPENDS = "python3" | ||
17 | |||
18 | PACKAGES += "python3-sip3" | ||
19 | |||
20 | BBCLASSEXTEND = "native" | ||
21 | |||
22 | do_configure_prepend_class-target() { | ||
23 | echo "py_platform = linux" > sip.cfg | ||
24 | echo "py_inc_dir = %(sysroot)/${includedir}/python%(py_major).%(py_minor)${PYTHON_ABI}" >> sip.cfg | ||
25 | echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg | ||
26 | echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg | ||
27 | echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg | ||
28 | echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg | ||
29 | ${PYTHON} configure.py --configuration sip.cfg --sip-module PyQt5.sip --sysroot ${STAGING_DIR_HOST} CC="${CC}" CXX="${CXX}" LINK="${CXX}" STRIP="" LINK_SHLIB="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LFLAGS="${LDFLAGS}" | ||
30 | } | ||
31 | |||
32 | do_configure_prepend_class-native() { | ||
33 | echo "py_platform = linux" > sip.cfg | ||
34 | echo "py_inc_dir = ${includedir}/python%(py_major).%(py_minor)${PYTHON_ABI}" >> sip.cfg | ||
35 | echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg | ||
36 | echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg | ||
37 | echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg | ||
38 | echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg | ||
39 | ${PYTHON} configure.py --configuration sip.cfg --sip-module PyQt5.sip --sysroot=${STAGING_DIR_NATIVE} | ||
40 | } | ||
41 | |||
42 | do_install() { | ||
43 | oe_runmake install | ||
44 | } | ||
45 | |||
46 | FILES_python3-sip3 = "${libdir}/${PYTHON_DIR}/site-packages/" | ||
47 | FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug" | ||