summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-25 16:48:31 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-28 08:32:19 -0800
commitff10588f479be5fdd5cf92c324e62f8dae518d66 (patch)
treeeeb40286b4cd6a2ff6a96d02e8998914279563bc /meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
parent63856541d42f035844ec0b0291c68fdd3ca7177a (diff)
downloadmeta-openembedded-ff10588f479be5fdd5cf92c324e62f8dae518d66.tar.gz
python3-distutils-extra; merge inc, fix wheel build
We have not supported Python2 for quite some time now, so there is no reason to maintain a separate inc file. This recipe does not inherit pypi and the PN does not match the built wheel. Set PIP_INSTALL_PACKAGE appropriately so the wheel can be found. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
new file mode 100644
index 000000000..8aca4ca3a
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
@@ -0,0 +1,17 @@
1SUMMARY = "python-distutils extension"
2DESCRIPTION = "python-distutils extension integrating gettext support, themed icons and scrollkeeper based documentation"
3HOMEPAGE = "https://launchpad.net/python-distutils-extra"
4SECTION = "devel/python"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4"
7
8SRC_URI = "https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/python-distutils-extra-${PV}.tar.gz"
9SRC_URI[sha256sum] = "723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae8063af"
10
11inherit setuptools3
12
13PIP_INSTALL_PACKAGE = "python_distutils_extra"
14
15S = "${WORKDIR}/python-distutils-extra-${PV}"
16
17BBCLASSEXTEND = "native"