diff options
author | Armin Kuster <akuster808@gmail.com> | 2015-04-04 19:54:16 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-05-11 10:30:21 +0200 |
commit | bf6aa3c1eb1224caf593994d859bbb2fbb735d6c (patch) | |
tree | d60337b5e2ee2d450f88de6d726988d74e466903 /meta-oe/recipes-devtools/protobuf | |
parent | 5dd01c5175f518658d8ee5627ede4f593111b872 (diff) | |
download | meta-openembedded-bf6aa3c1eb1224caf593994d859bbb2fbb735d6c.tar.gz |
protobuf: update update and build fix
googlecode is shutting down so had to move SRC_URI to github.
changed LIC_FILES_CHKSUM to LICENSE since COPY.TXT has been removed.
updated fixed the following build issue:
| tmp/work/ppc7400-poky-linux/protobuf/2.5.0-r0/protobuf-2.5.0/src/google/protobuf/extension_set.cc:81:3: error: 'GoogleOnceInit' is not a member of 'google::protobuf'
| ::google::protobuf::GoogleOnceInit(®istry_init_, &InitRegistry);
| ^
| tmp/work/ppc7400-poky-linux/protobuf/2.5.0-r0/protobuf-2.5.0/src/google/protobuf/extension_set.cc:81:39: error: 'registry_init_' was not declared in this scope
| ::google::protobuf::GoogleOnceInit(®istry_init_, &InitRegistry);
| ^
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf')
-rw-r--r-- | meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb (renamed from meta-oe/recipes-devtools/protobuf/protobuf_2.5.0.bb) | 13 |
1 files changed, 8 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_2.5.0.bb b/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb index a0db7bf95d..049f9d4e8f 100644 --- a/meta-oe/recipes-devtools/protobuf/protobuf_2.5.0.bb +++ b/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb | |||
@@ -2,21 +2,24 @@ SUMMARY = "Protocol Buffers - structured data serialisation mechanism" | |||
2 | DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an \ | 2 | DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an \ |
3 | efficient yet extensible format. Google uses Protocol Buffers for almost \ | 3 | efficient yet extensible format. Google uses Protocol Buffers for almost \ |
4 | all of its internal RPC protocols and file formats." | 4 | all of its internal RPC protocols and file formats." |
5 | HOMEPAGE = "http://code.google.com/p/protobuf/" | 5 | HOMEPAGE = "https://github.com/google/protobuf" |
6 | SECTION = "console/tools" | 6 | SECTION = "console/tools" |
7 | LICENSE = "BSD-3-Clause" | 7 | LICENSE = "BSD-3-Clause" |
8 | 8 | ||
9 | DEPENDS = "zlib" | 9 | DEPENDS = "zlib" |
10 | 10 | ||
11 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514" | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=af6809583bfde9a31595a58bb4a24514" |
12 | 12 | ||
13 | SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz" | 13 | SRCREV = "bba83652e1be610bdb7ee1566ad18346d98b843c" |
14 | 14 | ||
15 | SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8" | 15 | PV = "2.6.1+git${SRCPV}" |
16 | SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e" | 16 | |
17 | SRC_URI = "git://github.com/google/protobuf.git" | ||
17 | 18 | ||
18 | EXTRA_OECONF += " --with-protoc=echo" | 19 | EXTRA_OECONF += " --with-protoc=echo" |
19 | 20 | ||
20 | inherit autotools | 21 | inherit autotools |
21 | 22 | ||
23 | S = "${WORKDIR}/git" | ||
24 | |||
22 | BBCLASSEXTEND = "native nativesdk" | 25 | BBCLASSEXTEND = "native nativesdk" |