summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/protobuf
diff options
context:
space:
mode:
authorVyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>2022-08-27 11:53:28 +0200
committerKhem Raj <raj.khem@gmail.com>2022-08-27 07:39:10 -0700
commit8c6ae75bef0504e850f8674340d5cfb3ca21e78b (patch)
treeb6ba46a2e34672d7850ae26c9373759029790478 /meta-oe/recipes-devtools/protobuf
parentd2fef0d7126091e66a0b58e43888f1ad34f60302 (diff)
downloadmeta-openembedded-8c6ae75bef0504e850f8674340d5cfb3ca21e78b.tar.gz
protobuf: disable protoc binary for target
When applications want to use protoc during the build, the target binary has to be disabled in order to avoid following error: | The imported target "protobuf::protoc" references the file | | "<application build dir>/recipe-sysroot/usr/bin/protoc-<protobuf version>" | | but this file does not exist. Possible reasons include: | | * The file was deleted, renamed, or moved to another location. | | * An install or uninstall procedure did not complete successfully. | | * The installation package was faulty and contained | | "<application build dir>/recipe-sysroot/usr/lib/cmake/protobuf/protobuf-targets.cmake" | | but not all the files it references. Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.21.5.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.21.5.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.21.5.bb
index 88bef2c06d..0bc9cbedc0 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_3.21.5.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.21.5.bb
@@ -25,7 +25,9 @@ S = "${WORKDIR}/git"
25inherit cmake pkgconfig ptest 25inherit cmake pkgconfig ptest
26 26
27PACKAGECONFIG ??= "" 27PACKAGECONFIG ??= ""
28PACKAGECONFIG:class-native ?= "compiler"
28PACKAGECONFIG[python] = ",," 29PACKAGECONFIG[python] = ",,"
30PACKAGECONFIG[compiler] = "-Dprotobuf_BUILD_PROTOC_BINARIES=ON,-Dprotobuf_BUILD_PROTOC_BINARIES=OFF"
29 31
30EXTRA_OECMAKE += "\ 32EXTRA_OECMAKE += "\
31 -Dprotobuf_BUILD_SHARED_LIBS=ON \ 33 -Dprotobuf_BUILD_SHARED_LIBS=ON \