summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/protobuf/protobuf-c
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2019-09-29 17:29:56 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit489d3b4b932ee8016d792341f8ea5836a9522cd4 (patch)
tree31c0de67f383a1c720ee97ad39a5a240b31be685 /meta-oe/recipes-devtools/protobuf/protobuf-c
parent7e5be41e9e916e8a76c8d62b606d7716175923f7 (diff)
downloadmeta-openembedded-489d3b4b932ee8016d792341f8ea5836a9522cd4.tar.gz
protobuf-c: fix race condition
Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf/protobuf-c')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch b/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch
new file mode 100644
index 000000000..4fc7703d8
--- /dev/null
+++ b/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch
@@ -0,0 +1,36 @@
1From 216e31260b618ec73862f9f5336597f391444dac Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com>
3Date: Sun, 29 Sep 2019 17:20:42 +0800
4Subject: [PATCH] avoid race condition
5
6It's possible that the cxx-generate-packed-data.cc is compiled
7while the t/test-full.pb.h is being generated. This will result
8the following error.
9
10 DEBUG: ./t/test-full.pb.h:4:0: error: unterminated #ifndef
11 ./t/test-full.pb.h:4:0: error: unterminated #ifndef
12
13Add a dependency to avoid such problem.
14
15Upstream-Status: Pending
16
17Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
18---
19 Makefile.am | 1 +
20 1 file changed, 1 insertion(+)
21
22diff --git a/Makefile.am b/Makefile.am
23index b0cb065..1608ae0 100644
24--- a/Makefile.am
25+++ b/Makefile.am
26@@ -156,6 +156,7 @@ noinst_PROGRAMS += \
27 t_generated_code2_cxx_generate_packed_data_SOURCES = \
28 t/generated-code2/cxx-generate-packed-data.cc \
29 t/test-full.pb.cc
30+t/generated-code2/cxx-generate-packed-data.cc: t/test-full.pb.h
31 $(t_generated_code2_cxx_generate_packed_data_OBJECTS): t/test-full.pb.h
32 t_generated_code2_cxx_generate_packed_data_CXXFLAGS = \
33 $(AM_CXXFLAGS) \
34--
352.17.1
36