summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/pmtools
diff options
context:
space:
mode:
authorJagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>2015-08-19 15:52:56 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:43:44 +0200
commit14c8b506cab9e5c741d01cf6ea3c07f3fdb6c1aa (patch)
tree9ae35f9bbc56df14a6c293727f16ab28ff2f9755 /meta-oe/recipes-devtools/pmtools
parent227aa6c63b4acd65a5b924aa41ceccac0989b6b3 (diff)
downloadmeta-openembedded-14c8b506cab9e5c741d01cf6ea3c07f3fdb6c1aa.tar.gz
pmtools: add new recipe
pmtools contains small collection of power management test and investigation tools, acpidump - dump a system’s ACPI tables to an ASCII file acpixtract - convert ASCII acpidump output to raw binary table madt - parser for ACPI table Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/pmtools')
-rw-r--r--meta-oe/recipes-devtools/pmtools/pmtools_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pmtools/pmtools_git.bb b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
new file mode 100644
index 000000000..602da5e20
--- /dev/null
+++ b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "This is a small collection of power management \
2 test and investigation tools"
3HOMEPAGE = "http://lesswatts.org/projects/acpi"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
6
7PV = "20130209+git${SRCPV}"
8
9SRC_URI = "git://github.com/anyc/pmtools.git;protocol=https"
10SRCREV = "3ebe0e54c54061b4c627236cbe35d820de2e1168"
11
12COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
13
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17do_compile() {
18 oe_runmake
19}
20
21do_install() {
22 install -d ${D}${bindir} ${D}${docdir}
23 install -m 755 ${S}/acpidump/acpidump ${D}${bindir}
24 install -m 755 ${S}/acpixtract/acpixtract ${D}${bindir}
25 install -m 755 ${S}/madt/madt ${D}${bindir}
26 install -m 644 ${S}/README ${D}${docdir}
27}