summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-01 23:01:41 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-08 12:04:27 +0100
commit831e145bd695839860641a32b2cdcd6ad4a0921a (patch)
tree6f04730a247b9a0fe5171bc1d49b3c422589e986 /meta-oe/recipes-devtools/php
parentceb1a79a8f23f843c0f92eb379ce0ded2a7c4202 (diff)
downloadmeta-openembedded-831e145bd695839860641a32b2cdcd6ad4a0921a.tar.gz
php: add PACKAGECONFIG for imap
Allow imap support to be easily disabled; default it to enabled based on previous configuration. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r--meta-oe/recipes-devtools/php/php_5.5.20.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/php/php_5.5.20.bb b/meta-oe/recipes-devtools/php/php_5.5.20.bb
index 645de04db..1c0557fa8 100644
--- a/meta-oe/recipes-devtools/php/php_5.5.20.bb
+++ b/meta-oe/recipes-devtools/php/php_5.5.20.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=52dd90569008fee5bcdbb22d945b1108"
7 7
8BBCLASSEXTEND = "native" 8BBCLASSEXTEND = "native"
9DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native \ 9DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native \
10 uw-imap openssl libmcrypt" 10 openssl libmcrypt"
11DEPENDS_class-native = "zlib-native libxml2-native" 11DEPENDS_class-native = "zlib-native libxml2-native"
12 12
13SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \ 13SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \
@@ -56,9 +56,7 @@ EXTRA_OECONF = "--enable-mbstring \
56 --enable-wddx \ 56 --enable-wddx \
57 --enable-fpm \ 57 --enable-fpm \
58 --enable-zip \ 58 --enable-zip \
59 --with-imap=${STAGING_DIR_HOST} \
60 --with-gettext=${STAGING_LIBDIR}/.. \ 59 --with-gettext=${STAGING_LIBDIR}/.. \
61 --with-imap-ssl=${STAGING_DIR_HOST} \
62 --with-zlib=${STAGING_LIBDIR}/.. \ 60 --with-zlib=${STAGING_LIBDIR}/.. \
63 --with-iconv=${STAGING_LIBDIR}/.. \ 61 --with-iconv=${STAGING_LIBDIR}/.. \
64 --with-mcrypt=${STAGING_DIR_TARGET}${exec_prefix} \ 62 --with-mcrypt=${STAGING_DIR_TARGET}${exec_prefix} \
@@ -74,7 +72,7 @@ EXTRA_OECONF_class-native = " \
74 ${COMMON_EXTRA_OECONF} \ 72 ${COMMON_EXTRA_OECONF} \
75" 73"
76 74
77PACKAGECONFIG ??= "mysql sqlite3 \ 75PACKAGECONFIG ??= "mysql sqlite3 imap \
78 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" 76 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
79PACKAGECONFIG_class-native = "" 77PACKAGECONFIG_class-native = ""
80 78
@@ -92,6 +90,10 @@ PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--witho
92PACKAGECONFIG[soap] = "--enable-libxml --enable-soap, --disable-soap, libxml2" 90PACKAGECONFIG[soap] = "--enable-libxml --enable-soap, --disable-soap, libxml2"
93PACKAGECONFIG[apache2] = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs,,apache2-native apache2" 91PACKAGECONFIG[apache2] = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs,,apache2-native apache2"
94PACKAGECONFIG[pam] = ",,libpam" 92PACKAGECONFIG[pam] = ",,libpam"
93PACKAGECONFIG[imap] = "--with-imap=${STAGING_DIR_HOST} \
94 --with-imap-ssl=${STAGING_DIR_HOST} \
95 ,--without-imap --without-imap-ssl \
96 ,uw-imap"
95 97
96 98
97export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}" 99export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"