summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-10-29 20:31:19 +0200
committerKhem Raj <raj.khem@gmail.com>2019-11-01 17:22:52 -0700
commit5826b0f1dde0f02fc0dbeff04ca257251425dbad (patch)
tree4d1699117cf4362389ef1c4f5bab54467bb385a7 /meta-oe/recipes-devtools/php
parenta0361dad8b372d20198effb2d12584be7847e65f (diff)
downloadmeta-openembedded-5826b0f1dde0f02fc0dbeff04ca257251425dbad.tar.gz
php: Upgrade 7.3.9 -> 7.3.11
Patch for issue fixed upstream removed. Also merge the inc into the recipe. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r--meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch161
-rw-r--r--meta-oe/recipes-devtools/php/php_7.3.11.bb (renamed from meta-oe/recipes-devtools/php/php.inc)12
-rw-r--r--meta-oe/recipes-devtools/php/php_7.3.9.bb20
3 files changed, 12 insertions, 181 deletions
diff --git a/meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch b/meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch
deleted file mode 100644
index 2258c4c7f..000000000
--- a/meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch
+++ /dev/null
@@ -1,161 +0,0 @@
1From 03fecab78f9fa747ad8ab3484e7ca00c0148321d Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Sun, 28 Apr 2019 16:45:02 +0800
4Subject: [PATCH] From: Hugh McMaster <hugh.mcmaster@outlook.com> Date: Wed, 5
5 Dec 2018 23:27:30 +1100 Subject: ext/intl: Use pkg-config to detect icu
6
7The developers of icu recommend using pkg-config to detect icu,
8because icu-config is deprecated.
9
10Upstream-Status: Pending
11
12update to version 7.3.4
13Signed-off-by: Changqing Li <changqing.li@windriver.com>
14---
15 acinclude.m4 | 95 ++++++------------------------------------------------
16 ext/intl/config.m4 | 16 ++++-----
17 2 files changed, 15 insertions(+), 96 deletions(-)
18
19diff --git a/acinclude.m4 b/acinclude.m4
20index 7d77c33..86b0ecc 100644
21--- a/acinclude.m4
22+++ b/acinclude.m4
23@@ -2158,92 +2158,15 @@ dnl
24 dnl Common setup macro for ICU
25 dnl
26 AC_DEFUN([PHP_SETUP_ICU],[
27- PHP_ARG_WITH(icu-dir,,
28- [ --with-icu-dir=DIR Specify where ICU libraries and headers can be found], DEFAULT, no)
29-
30- if test "$PHP_ICU_DIR" = "no"; then
31- PHP_ICU_DIR=DEFAULT
32- fi
33-
34- AC_MSG_CHECKING([for location of ICU headers and libraries])
35- found_icu=no
36-
37- dnl First try to find pkg-config
38- if test -z "$PKG_CONFIG"; then
39- AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
40- fi
41-
42- dnl If pkg-config is found try using it
43- if test "$PHP_ICU_DIR" = "DEFAULT" && test -x "$PKG_CONFIG" && $PKG_CONFIG --exists icu-uc icu-io icu-i18n; then
44- if $PKG_CONFIG --atleast-version=40 icu-uc; then
45- found_icu=yes
46- icu_version_full=`$PKG_CONFIG --modversion icu-uc`
47- ac_IFS=$IFS
48- IFS="."
49- set $icu_version_full
50- IFS=$ac_IFS
51- icu_version=`expr [$]1 \* 1000 + [$]2`
52- AC_MSG_RESULT([found $icu_version_full])
53-
54- ICU_LIBS=`$PKG_CONFIG --libs icu-uc icu-io icu-i18n`
55- ICU_INCS=`$PKG_CONFIG --cflags-only-I icu-uc icu-io icu-i18n`
56- ICU_CXXFLAGS="-DU_USING_ICU_NAMESPACE=1"
57-
58- AC_MSG_RESULT([found $ICU_VERSION])
59-
60- PHP_EVAL_LIBLINE($ICU_LIBS, $1)
61- PHP_EVAL_INCLINE($ICU_INCS)
62- else
63- AC_MSG_ERROR([ICU version 4.0 or later required.])
64- fi
65- fi
66-
67- dnl If pkg-config fails for some reason, revert to the old method
68- if test "$found_icu" = "no"; then
69- if test "$PHP_ICU_DIR" = "DEFAULT"; then
70- dnl Try to find icu-config
71- AC_PATH_PROG(ICU_CONFIG, icu-config, no, [$PATH:/usr/local/bin])
72- else
73- ICU_CONFIG="$PHP_ICU_DIR/bin/icu-config"
74- fi
75-
76- dnl Trust icu-config to know better what the install prefix is..
77- icu_install_prefix=`$ICU_CONFIG --prefix 2> /dev/null`
78- if test "$?" != "0" || test -z "$icu_install_prefix"; then
79- AC_MSG_RESULT([not found])
80- AC_MSG_ERROR([Unable to detect ICU prefix or $ICU_CONFIG failed. Please verify ICU install prefix and make sure icu-config works.])
81- else
82- AC_MSG_RESULT([$icu_install_prefix])
83-
84- dnl Check ICU version
85- AC_MSG_CHECKING([for ICU 4.0 or greater])
86- icu_version_full=`$ICU_CONFIG --version`
87- ac_IFS=$IFS
88- IFS="."
89- set $icu_version_full
90- IFS=$ac_IFS
91- icu_version=`expr [$]1 \* 1000 + [$]2`
92- AC_MSG_RESULT([found $icu_version_full])
93-
94- if test "$icu_version" -lt "4000"; then
95- AC_MSG_ERROR([ICU version 4.0 or later is required])
96- fi
97-
98- ICU_VERSION=$icu_version
99- ICU_INCS=`$ICU_CONFIG --cppflags-searchpath`
100- ICU_LIBS=`$ICU_CONFIG --ldflags --ldflags-icuio`
101- PHP_EVAL_INCLINE($ICU_INCS)
102- PHP_EVAL_LIBLINE($ICU_LIBS, $1)
103-
104- ICU_CXXFLAGS=`$ICU_CONFIG --cxxflags`
105- if test "$icu_version" -ge "49000"; then
106- ICU_CXXFLAGS="$ICU_CXXFLAGS -DUNISTR_FROM_CHAR_EXPLICIT=explicit -DUNISTR_FROM_STRING_EXPLICIT=explicit"
107- ICU_CFLAGS="-DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1"
108- fi
109- if test "$icu_version" -ge "60000"; then
110- ICU_CFLAGS="$ICU_CFLAGS -DU_HIDE_OBSOLETE_UTF_OLD_H=1"
111- fi
112- fi
113+ PKG_CHECK_MODULES([ICU], [icu-io >= 50.1])
114+ PHP_EVAL_INCLINE($ICU_CFLAGS)
115+ PHP_EVAL_LIBLINE($ICU_LIBS, $1)
116+
117+ ICU_CFLAGS="$ICU_CFLAGS -DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1"
118+ ICU_CXXFLAGS="$ICU_CXXFLAGS -DUNISTR_FROM_CHAR_EXPLICIT=explicit -DUNISTR_FROM_STRING_EXPLICIT=explicit"
119+
120+ if $PKG_CONFIG icu-io --atleast-version=60; then
121+ ICU_CFLAGS="$ICU_CFLAGS -DU_HIDE_OBSOLETE_UTF_OLD_H=1"
122 fi
123 ])
124
125diff --git a/ext/intl/config.m4 b/ext/intl/config.m4
126index 4b9f469..fdae88a 100644
127--- a/ext/intl/config.m4
128+++ b/ext/intl/config.m4
129@@ -9,15 +9,7 @@ if test "$PHP_INTL" != "no"; then
130 PHP_SETUP_ICU(INTL_SHARED_LIBADD)
131 PHP_SUBST(INTL_SHARED_LIBADD)
132 PHP_REQUIRE_CXX()
133- INTL_COMMON_FLAGS="$ICU_INCS $ICU_CFLAGS -Wno-write-strings -D__STDC_LIMIT_MACROS -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1"
134- if test "$icu_version" -ge "4002"; then
135- icu_spoof_src=" spoofchecker/spoofchecker_class.c \
136- spoofchecker/spoofchecker.c\
137- spoofchecker/spoofchecker_create.c\
138- spoofchecker/spoofchecker_main.c"
139- else
140- icu_spoof_src=""
141- fi
142+ INTL_COMMON_FLAGS="$ICU_CFLAGS -Wno-write-strings -D__STDC_LIMIT_MACROS -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1"
143 PHP_NEW_EXTENSION(intl, php_intl.c \
144 intl_error.c \
145 intl_convert.c \
146@@ -68,7 +60,11 @@ if test "$PHP_INTL" != "no"; then
147 transliterator/transliterator_methods.c \
148 uchar/uchar.c \
149 idn/idn.c \
150- $icu_spoof_src, $ext_shared,,$INTL_COMMON_FLAGS,cxx)
151+ spoofchecker/spoofchecker_class.c \
152+ spoofchecker/spoofchecker.c\
153+ spoofchecker/spoofchecker_create.c\
154+ spoofchecker/spoofchecker_main.c \
155+ , $ext_shared,,$INTL_COMMON_FLAGS,cxx)
156
157 PHP_INTL_CXX_SOURCES="intl_convertcpp.cpp \
158 common/common_enum.cpp \
159--
1602.7.4
161
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php_7.3.11.bb
index 3d537e5b6..e7fb847fa 100644
--- a/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-oe/recipes-devtools/php/php_7.3.11.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://www.php.net"
3SECTION = "console/network" 3SECTION = "console/network"
4 4
5LICENSE = "PHP-3.0" 5LICENSE = "PHP-3.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fb07bfc51f6d5e0c30b65d9701233b2e"
6 7
7BBCLASSEXTEND = "native" 8BBCLASSEXTEND = "native"
8DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native" 9DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native"
@@ -12,6 +13,11 @@ PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}"
12 13
13SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \ 14SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \
14 file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch \ 15 file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch \
16 file://0001-acinclude.m4-don-t-unset-cache-variables.patch \
17 file://0048-Use-pkg-config-for-FreeType2-detection.patch \
18 file://0001-Use-pkg-config-for-libxml2-detection.patch \
19 file://debian-php-fixheader.patch \
20 file://CVE-2019-6978.patch \
15 " 21 "
16 22
17SRC_URI_append_class-target = " \ 23SRC_URI_append_class-target = " \
@@ -22,8 +28,14 @@ SRC_URI_append_class-target = " \
22 file://php-fpm-apache.conf \ 28 file://php-fpm-apache.conf \
23 file://70_mod_php${PHP_MAJOR_VERSION}.conf \ 29 file://70_mod_php${PHP_MAJOR_VERSION}.conf \
24 file://php-fpm.service \ 30 file://php-fpm.service \
31 file://pear-makefile.patch \
32 file://phar-makefile.patch \
33 file://0001-opcache-config.m4-enable-opcache.patch \
34 file://xfail_two_bug_tests.patch \
25 " 35 "
26S = "${WORKDIR}/php-${PV}" 36S = "${WORKDIR}/php-${PV}"
37SRC_URI[md5sum] = "21b710b4126d4d54714de9693a6c7b0d"
38SRC_URI[sha256sum] = "92d1ff4b13c7093635f1ec338a5e6891ca99b10e65fbcadd527e5bb84d11b5e7"
27 39
28inherit autotools pkgconfig pythonnative gettext 40inherit autotools pkgconfig pythonnative gettext
29 41
diff --git a/meta-oe/recipes-devtools/php/php_7.3.9.bb b/meta-oe/recipes-devtools/php/php_7.3.9.bb
deleted file mode 100644
index a5c7b9b6b..000000000
--- a/meta-oe/recipes-devtools/php/php_7.3.9.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1require php.inc
2
3LIC_FILES_CHKSUM = "file://LICENSE;md5=fb07bfc51f6d5e0c30b65d9701233b2e"
4
5SRC_URI += "file://0001-acinclude.m4-don-t-unset-cache-variables.patch \
6 file://0048-Use-pkg-config-for-FreeType2-detection.patch \
7 file://0049-ext-intl-Use-pkg-config-to-detect-icu.patch \
8 file://0001-Use-pkg-config-for-libxml2-detection.patch \
9 file://debian-php-fixheader.patch \
10 file://CVE-2019-6978.patch \
11 "
12SRC_URI_append_class-target = " \
13 file://pear-makefile.patch \
14 file://phar-makefile.patch \
15 file://0001-opcache-config.m4-enable-opcache.patch \
16 file://xfail_two_bug_tests.patch \
17 "
18
19SRC_URI[md5sum] = "bcc37749815009c9201e4c126e1ab8ee"
20SRC_URI[sha256sum] = "a39c9709a8c9eb7ea8ac4933ef7a78b92f7e5735a405c8b8e42ee39541d963c4"