summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php/php-5.6.33
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-02-13 14:57:22 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-23 20:28:55 -0800
commit5abacb2751225739f51c9b55ecc8b516b5ea76f8 (patch)
tree6bdffc8a11bbf270aa7c19a8e75c0857785c3287 /meta-oe/recipes-devtools/php/php-5.6.33
parentb955bbbba493360f6ea30717b349468fc959a1b5 (diff)
downloadmeta-openembedded-5abacb2751225739f51c9b55ecc8b516b5ea76f8.tar.gz
php: update stable version 5.6.31 -> 5.6.33
04 Jan 2017, PHP 5.6.33 - GD: . Fixed bug #75571 (Potential infinite loop in gdImageCreateFromGifCtx). (cmb) - Phar: . Fixed bug #74782 (Reflected XSS in .phar 404 page). (Stas) 26 Sep 2017, PHP 5.6.32 - Date: . Fixed bug #75055 (Out-Of-Bounds Read in timelib_meridian()). (Derick) - mcrypt: . Fixed bug #72535 (arcfour encryption stream filter crashes php). (Leigh) - PCRE: . Fixed bug #75207 (applied upstream patch for CVE-2016-1283). (Anatol) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php/php-5.6.33')
-rw-r--r--meta-oe/recipes-devtools/php/php-5.6.33/0001-Add-lpthread-to-link.patch38
-rw-r--r--meta-oe/recipes-devtools/php/php-5.6.33/change-AC_TRY_RUN-to-AC_TRY_LINK.patch56
2 files changed, 94 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php-5.6.33/0001-Add-lpthread-to-link.patch b/meta-oe/recipes-devtools/php/php-5.6.33/0001-Add-lpthread-to-link.patch
new file mode 100644
index 000000000..f70e550ff
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php-5.6.33/0001-Add-lpthread-to-link.patch
@@ -0,0 +1,38 @@
1From ed0a954983d50267c2fc0bc13aba929ea0cad971 Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Tue, 2 May 2017 06:34:40 +0000
4Subject: [PATCH] Add -lpthread to link
5
6When building the php-5.6.26, the following errors occured:
7
8 ld: TSRM/.libs/TSRM.o: undefined reference to symbol
9 'pthread_sigmask@@GLIBC_2.2.5'
10
11 error adding symbols: DSO missing from command line
12
13This is because no pthread to link, so we should add it.
14
15Upstream-Status: Pending
16
17Signed-off-by: Dengke Du <dengke.du@windriver.com>
18---
19 configure.in | 3 ++-
20 1 file changed, 2 insertions(+), 1 deletion(-)
21
22diff --git a/configure.in b/configure.in
23index a467dff1..9afef652 100644
24--- a/configure.in
25+++ b/configure.in
26@@ -1058,7 +1058,8 @@ case $php_sapi_module in
27 ;;
28 esac
29
30-EXTRA_LIBS="$EXTRA_LIBS $DLIBS $LIBS"
31+PTHREAD_LIBS="-lpthread"
32+EXTRA_LIBS="$EXTRA_LIBS $DLIBS $LIBS $PTHREAD_LIBS"
33
34 dnl this has to be here to prevent the openssl crypt() from
35 dnl overriding the system provided crypt().
36--
372.11.0
38
diff --git a/meta-oe/recipes-devtools/php/php-5.6.33/change-AC_TRY_RUN-to-AC_TRY_LINK.patch b/meta-oe/recipes-devtools/php/php-5.6.33/change-AC_TRY_RUN-to-AC_TRY_LINK.patch
new file mode 100644
index 000000000..39c334f39
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php-5.6.33/change-AC_TRY_RUN-to-AC_TRY_LINK.patch
@@ -0,0 +1,56 @@
1[PATCH] config.m4: change AC_TRY_RUN to AC_TRY_LINK
2
3Upstream-Status: Pending
4
5AC_TRY_RUN is not suitable for cross-compile
6
7Signed-off-by: Roy Li <rongqing.li@windriver.com>
8---
9 ext/fileinfo/config.m4 | 31 ++++++-------------------------
10 1 file changed, 6 insertions(+), 25 deletions(-)
11
12diff --git a/ext/fileinfo/config.m4 b/ext/fileinfo/config.m4
13index 7e98d62..8a8ea0e 100644
14--- a/ext/fileinfo/config.m4
15+++ b/ext/fileinfo/config.m4
16@@ -14,31 +14,12 @@ if test "$PHP_FILEINFO" != "no"; then
17 libmagic/readcdf.c libmagic/softmagic.c"
18
19 AC_MSG_CHECKING([for strcasestr])
20- AC_TRY_RUN([
21-#include <string.h>
22-#include <strings.h>
23-#include <stdlib.h>
24-
25-int main(void)
26-{
27- char *s0, *s1, *ret;
28-
29- s0 = (char *) malloc(42);
30- s1 = (char *) malloc(8);
31-
32- memset(s0, 'X', 42);
33- s0[24] = 'Y';
34- s0[26] = 'Z';
35- s0[41] = '\0';
36- memset(s1, 'x', 8);
37- s1[0] = 'y';
38- s1[2] = 'Z';
39- s1[7] = '\0';
40-
41- ret = strcasestr(s0, s1);
42-
43- return !(NULL != ret);
44-}
45+ AC_TRY_COMPILE([
46+ #include <string.h>
47+ #include <strings.h>
48+ #include <stdlib.h>
49+ ],[
50+ strcasestr(NULL, NULL);
51 ],[
52 dnl using the platform implementation
53 AC_MSG_RESULT(yes)
54--
551.9.1
56