diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-29 18:37:58 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-01 09:11:46 -0800 |
commit | df4f8a675f75ad7781f630b68c284276169932ae (patch) | |
tree | 1e1edb814484df103c2ad66d25fad47ed714c0fe /meta-oe/recipes-devtools/nodejs | |
parent | 7f456b1f00261d05d5cef90e91a0299713e70744 (diff) | |
download | meta-openembedded-df4f8a675f75ad7781f630b68c284276169932ae.tar.gz |
nodejs: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs/gcc13.patch | 70 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb | 1 |
2 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/gcc13.patch b/meta-oe/recipes-devtools/nodejs/nodejs/gcc13.patch new file mode 100644 index 000000000..be82c3369 --- /dev/null +++ b/meta-oe/recipes-devtools/nodejs/nodejs/gcc13.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | From 0be1c5728173ea9ac42843058e26b6268568acf0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jiawen Geng <technicalcute@gmail.com> | ||
3 | Date: Fri, 14 Oct 2022 09:54:33 +0800 | ||
4 | Subject: [PATCH] deps: V8: cherry-pick c2792e58035f | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Original commit message: | ||
10 | |||
11 | [base] Fix build with gcc-13 | ||
12 | |||
13 | See https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes. | ||
14 | |||
15 | Also see Gentoo Linux bug report: https://bugs.gentoo.org/865981 | ||
16 | |||
17 | Change-Id: I421f396b02ba37e12ee70048ee33e034f8113566 | ||
18 | Reviewed-on: https://chromium-review.googlesource.com/c/v8/v8/+/3934140 | ||
19 | Reviewed-by: Clemens Backes <clemensb@chromium.org> | ||
20 | Reviewed-by: Simon Zünd <szuend@chromium.org> | ||
21 | Commit-Queue: Clemens Backes <clemensb@chromium.org> | ||
22 | Cr-Commit-Position: refs/heads/main@{#83587} | ||
23 | |||
24 | Refs: https://github.com/v8/v8/commit/c2792e58035fcbaa16d0cb70998852fbeb5df4cc | ||
25 | PR-URL: https://github.com/nodejs/node/pull/44961 | ||
26 | Fixes: https://github.com/nodejs/node/issues/43642 | ||
27 | Reviewed-By: Michaël Zasso <targos@protonmail.com> | ||
28 | Reviewed-By: Richard Lau <rlau@redhat.com> | ||
29 | Reviewed-By: Luigi Pinca <luigipinca@gmail.com> | ||
30 | Reviewed-By: Colin Ihrig <cjihrig@gmail.com> | ||
31 | |||
32 | Upstream-Status: Backport [https://github.com/nodejs/node/commit/0be1c5728173ea9ac42843058e26b6268568acf0] | ||
33 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
34 | --- | ||
35 | common.gypi | 2 +- | ||
36 | deps/v8/AUTHORS | 1 + | ||
37 | deps/v8/src/base/logging.h | 1 + | ||
38 | deps/v8/src/inspector/v8-string-conversions.h | 1 + | ||
39 | 4 files changed, 4 insertions(+), 1 deletion(-) | ||
40 | |||
41 | --- a/deps/v8/AUTHORS | ||
42 | +++ b/deps/v8/AUTHORS | ||
43 | @@ -247,6 +247,7 @@ Vlad Burlik <vladbph@gmail.com> | ||
44 | Vladimir Krivosheev <develar@gmail.com> | ||
45 | Vladimir Shutoff <vovan@shutoff.ru> | ||
46 | Wael Almattar <waelsy123@gmail.com> | ||
47 | +WANG Xuerui <git@xen0n.name> | ||
48 | Wei Wu <lazyparser@gmail.com> | ||
49 | Wenlu Wang <kingwenlu@gmail.com> | ||
50 | Wenming Yang <yangwenming@bytedance.com> | ||
51 | --- a/deps/v8/src/base/logging.h | ||
52 | +++ b/deps/v8/src/base/logging.h | ||
53 | @@ -5,6 +5,7 @@ | ||
54 | #ifndef V8_BASE_LOGGING_H_ | ||
55 | #define V8_BASE_LOGGING_H_ | ||
56 | |||
57 | +#include <cstdint> | ||
58 | #include <cstring> | ||
59 | #include <sstream> | ||
60 | #include <string> | ||
61 | --- a/deps/v8/src/inspector/v8-string-conversions.h | ||
62 | +++ b/deps/v8/src/inspector/v8-string-conversions.h | ||
63 | @@ -5,6 +5,7 @@ | ||
64 | #ifndef V8_INSPECTOR_V8_STRING_CONVERSIONS_H_ | ||
65 | #define V8_INSPECTOR_V8_STRING_CONVERSIONS_H_ | ||
66 | |||
67 | +#include <cstdint> | ||
68 | #include <string> | ||
69 | |||
70 | // Conversion routines between UT8 and UTF16, used by string-16.{h,cc}. You may | ||
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb index e96913e56..e96412fec 100644 --- a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb +++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb | |||
@@ -25,6 +25,7 @@ SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \ | |||
25 | file://system-c-ares.patch \ | 25 | file://system-c-ares.patch \ |
26 | file://0001-liftoff-Correct-function-signatures.patch \ | 26 | file://0001-liftoff-Correct-function-signatures.patch \ |
27 | file://0001-mips-Use-32bit-cast-for-operand-on-mips32.patch \ | 27 | file://0001-mips-Use-32bit-cast-for-operand-on-mips32.patch \ |
28 | file://gcc13.patch \ | ||
28 | " | 29 | " |
29 | 30 | ||
30 | SRC_URI:append:class-target = " \ | 31 | SRC_URI:append:class-target = " \ |