summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs/nodejs_4.7.0.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <oleksandr.kravchuk@pelagicore.com>2017-01-03 09:57:21 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-10 13:12:56 +0100
commit4fe4318c566a2444a43dea704e1cd952c3a83a01 (patch)
tree59f2533b90d73b905a3cc91c3b0e78ff40d27f2e /meta-oe/recipes-devtools/nodejs/nodejs_4.7.0.bb
parentcabf72ebbfbed41db228e978400e63ae8f0cc7b1 (diff)
downloadmeta-openembedded-4fe4318c566a2444a43dea704e1cd952c3a83a01.tar.gz
nodejs: upgrade to 4.7.0
Section with information regarding few third-party components has been removed from the LICENSE file: https://github.com/nodejs/node/commit/f7c4e9489f0d72533. Signed-off-by: Oleksandr Kravchuk <oleksandr.kravchuk@pelagicore.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/nodejs_4.7.0.bb')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_4.7.0.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_4.7.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_4.7.0.bb
new file mode 100644
index 000000000..54d6829a1
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_4.7.0.bb
@@ -0,0 +1,88 @@
1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & BSD & Artistic-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f45e9ffb97e64da46d14f462d34a039f"
5
6DEPENDS = "openssl zlib"
7
8COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
9COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"
10COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*"
11
12SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
13 file://no-registry.patch \
14"
15SRC_URI[md5sum] = "f4a7ca6912d0688b37712bb09b65d2d4"
16SRC_URI[sha256sum] = "b03c777ba8817a8478d57f00797db86dc7e7953d2066c34edbceeba8ad056142"
17
18S = "${WORKDIR}/node-v${PV}"
19
20# v8 errors out if you have set CCACHE
21CCACHE = ""
22
23def map_nodejs_arch(a, d):
24 import re
25
26 if re.match('i.86$', a): return 'ia32'
27 elif re.match('x86_64$', a): return 'x64'
28 elif re.match('aarch64$', a): return 'arm64'
29 elif re.match('powerpc64$', a): return 'ppc64'
30 elif re.match('powerpc$', a): return 'ppc'
31 return a
32
33ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)} \
34 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-arm-fpu=neon', \
35 bb.utils.contains('TUNE_FEATURES', 'vfpv3d16', '--with-arm-fpu=vfpv3-d16', \
36 bb.utils.contains('TUNE_FEATURES', 'vfpv3', '--with-arm-fpu=vfpv3', \
37 '--with-arm-fpu=vfp', d), d), d)}"
38GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' "
39ARCHFLAGS ?= ""
40
41# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
42do_configure () {
43 export LD="${CXX}"
44 GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
45 # $TARGET_ARCH settings don't match --dest-cpu settings
46 ./configure --prefix=${prefix} --without-snapshot --shared-openssl --shared-zlib \
47 --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \
48 --dest-os=linux \
49 ${ARCHFLAGS}
50}
51
52do_compile () {
53 export LD="${CXX}"
54 oe_runmake BUILDTYPE=Release
55}
56
57do_install () {
58 oe_runmake install DESTDIR=${D}
59}
60
61do_install_append_class-native() {
62 # use node from PATH instead of absolute path to sysroot
63 # node-v0.10.25/tools/install.py is using:
64 # shebang = os.path.join(node_prefix, 'bin/node')
65 # update_shebang(link_path, shebang)
66 # and node_prefix can be very long path to bindir in native sysroot and
67 # when it exceeds 128 character shebang limit it's stripped to incorrect path
68 # and npm fails to execute like in this case with 133 characters show in log.do_install:
69 # updating shebang of /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/work/x86_64-linux/nodejs-native/0.10.15-r0/image/home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/npm to /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/node
70 # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js
71 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and
72 # npm-cli.js continues to use old shebang
73 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
74}
75
76do_install_append_class-target() {
77 sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
78}
79
80PACKAGES =+ "${PN}-npm"
81FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm"
82RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils"
83
84PACKAGES =+ "${PN}-systemtap"
85FILES_${PN}-systemtap = "${datadir}/systemtap"
86
87
88BBCLASSEXTEND = "native"