summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/mercurial
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-devtools/mercurial
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-devtools/mercurial')
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial-native_3.0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_3.0.1.bb b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.0.1.bb
new file mode 100644
index 000000000..9a5eebe32
--- /dev/null
+++ b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.0.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "The Mercurial distributed SCM"
2HOMEPAGE = "http://mercurial.selenic.com/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6DEPENDS = "python-native"
7
8SRC_URI = "http://mercurial.selenic.com/release/mercurial-${PV}.tar.gz"
9SRC_URI[md5sum] = "15de301a673b77f839325dba10ed4fc0"
10SRC_URI[sha256sum] = "36e48b59a84ef5a222d06596971e955ac8217e56b076dfb94c8ce5a0c29fd705"
11
12S = "${WORKDIR}/mercurial-${PV}"
13
14inherit native
15
16EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
17 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} PREFIX=${prefix}"
18
19do_configure_append () {
20 sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
21}
22
23do_install () {
24 oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
25}
26