summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/luajit
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-devtools/luajit
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-devtools/luajit')
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch33
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.3.bb56
2 files changed, 89 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch b/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch
new file mode 100644
index 000000000..f123b3f55
--- /dev/null
+++ b/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch
@@ -0,0 +1,33 @@
1From 528009f5ca0685c95ef27f6c8957160499c0576a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 10 May 2013 10:42:45 -0700
4Subject: [PATCH] Do not strip automatically, this leaves the stripping
5 busines to OE
6
7Upstream-Status: Inappropriate [OE-Specific]
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 src/Makefile | 2 --
12 1 file changed, 2 deletions(-)
13
14diff --git a/src/Makefile b/src/Makefile
15index 278324a..5ecd6d5 100644
16--- a/src/Makefile
17+++ b/src/Makefile
18@@ -665,12 +665,10 @@ $(LUAJIT_A): $(LJVMCORE_O)
19 $(LUAJIT_SO): $(LJVMCORE_O)
20 $(E) "DYNLINK $@"
21 $(Q)$(TARGET_LD) $(TARGET_ASHLDFLAGS) -o $@ $(LJVMCORE_DYNO) $(TARGET_ALIBS)
22- $(Q)$(TARGET_STRIP) $@
23
24 $(LUAJIT_T): $(TARGET_O) $(LUAJIT_O) $(TARGET_DEP)
25 $(E) "LINK $@"
26 $(Q)$(TARGET_LD) $(TARGET_ALDFLAGS) -o $@ $(LUAJIT_O) $(TARGET_O) $(TARGET_ALIBS)
27- $(Q)$(TARGET_STRIP) $@
28 $(E) "OK Successfully built LuaJIT"
29
30 ##############################################################################
31--
321.7.9.5
33
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.3.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.3.bb
new file mode 100644
index 000000000..48137e385
--- /dev/null
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.3.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Just-In-Time Compiler for Lua"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=97b6446bbf9d55616838f821585c5978"
4HOMEPAGE = "http://luajit.org"
5
6SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \
7 file://0001-Do-not-strip-automatically-this-leaves-the-stripping.patch \
8"
9SRC_URI[md5sum] = "f14e9104be513913810cd59c8c658dc0"
10SRC_URI[sha256sum] = "55be6cb2d101ed38acca32c5b1f99ae345904b365b642203194c585d27bebd79"
11
12S = "${WORKDIR}/LuaJIT-${PV}"
13
14inherit pkgconfig binconfig
15
16BBCLASSEXTEND = "native"
17
18do_configure_prepend() {
19 sed -i -e s:/usr/local:${prefix}:g ${S}/Makefile
20 sed -i -e s:/lib$:${base_libdir}:g ${S}/Makefile
21}
22
23EXTRA_OEMAKE = 'CROSS=${HOST_PREFIX} \
24 TARGET_CFLAGS="${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}" \
25 TARGET_LDFLAGS="${TOOLCHAIN_OPTIONS}" \
26 TARGET_SHLDFLAGS="${TOOLCHAIN_OPTIONS}"'
27EXTRA_OEMAKE_append_powerpc = ' HOST_CC="${BUILD_CC} -m32"'
28EXTRA_OEMAKE_append_x86-64 = ' HOST_CC="${BUILD_CC}"'
29EXTRA_OEMAKE_append_i586 = ' HOST_CC="${BUILD_CC} -m32"'
30EXTRA_OEMAKE_append_powerpc64 = ' HOST_CC="${BUILD_CC}"'
31EXTRA_OEMAKE_append_arm = ' HOST_CC="${BUILD_CC} -m32"'
32EXTRA_OEMAKE_append_mips64 = ' HOST_CC="${BUILD_CC} -m32"'
33
34do_compile () {
35 oe_runmake
36}
37
38do_install () {
39 oe_runmake 'DESTDIR=${D}' install
40 rmdir ${D}${datadir}/lua/5.* \
41 ${D}${datadir}/lua \
42 ${D}${libdir}/lua/5.* \
43 ${D}${libdir}/lua
44}
45
46PACKAGES += 'luajit-common'
47
48FILES_${PN} += "${libdir}/libluajit-5.1.so.2 \
49 ${libdir}/libluajit-5.1.so.${PV} \
50"
51FILES_${PN}-dev += "${libdir}/libluajit-5.1.a \
52 ${libdir}/libluajit-5.1.so \
53 ${libdir}/pkgconfig/luajit.pc \
54"
55FILES_luajit-common = "${datadir}/${BPN}-${PV}"
56