summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/lua/lua_5.3.4.bb
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2019-04-10 23:13:42 -0700
committerKhem Raj <raj.khem@gmail.com>2019-04-11 11:30:35 -0700
commitbe6481ca9f144708c8d6f741396be6e597eb8f18 (patch)
tree8db05f7264630beaf87b404b02c22b1ddcb631f1 /meta-oe/recipes-devtools/lua/lua_5.3.4.bb
parentfc144a1428cdff292d2dc9d1a7440acd1e712aa0 (diff)
downloadmeta-openembedded-be6481ca9f144708c8d6f741396be6e597eb8f18.tar.gz
lua: upgrade from v5.3.4 to v5.3.5
The v5.3.5 release covers CVE-2019-6706 which is vulnerable. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/lua/lua_5.3.4.bb')
-rw-r--r--meta-oe/recipes-devtools/lua/lua_5.3.4.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta-oe/recipes-devtools/lua/lua_5.3.4.bb b/meta-oe/recipes-devtools/lua/lua_5.3.4.bb
deleted file mode 100644
index 8f4e8fe68..000000000
--- a/meta-oe/recipes-devtools/lua/lua_5.3.4.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1DESCRIPTION = "Lua is a powerful light-weight programming language designed \
2for extending applications."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=318;endline=352;md5=60aa5cfdbd40086501778d9b6ebf29ee"
5HOMEPAGE = "http://www.lua.org/"
6
7DEPENDS = "readline"
8SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \
9 file://lua.pc.in \
10 "
11SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', \
12 'http://www.lua.org/tests/lua-${PV}-tests.tar.gz;name=tarballtest \
13 file://run-ptest \
14 ', '', d)}"
15
16SRC_URI[tarballsrc.md5sum] = "53a9c68bcc0eda58bdc2095ad5cdfc63"
17SRC_URI[tarballsrc.sha256sum] = "f681aa518233bc407e23acf0f5887c884f17436f000d453b2491a9f11a52400c"
18SRC_URI[tarballtest.md5sum] = "b14fe3748c1cb2d74e3acd1943629ba3"
19SRC_URI[tarballtest.sha256sum] = "b80771238271c72565e5a1183292ef31bd7166414cd0d43a8eb79845fa7f599f"
20
21inherit pkgconfig binconfig ptest
22
23UCLIBC_PATCHES += "file://uclibc-pthread.patch"
24SRC_URI_append_libc-uclibc = "${UCLIBC_PATCHES}"
25
26TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
27EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLDFLAGS='${LDFLAGS}'"
28
29do_configure_prepend() {
30 sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
31}
32
33do_compile () {
34 oe_runmake linux
35}
36
37do_install () {
38 oe_runmake \
39 'INSTALL_TOP=${D}${prefix}' \
40 'INSTALL_BIN=${D}${bindir}' \
41 'INSTALL_INC=${D}${includedir}/' \
42 'INSTALL_MAN=${D}${mandir}/man1' \
43 'INSTALL_SHARE=${D}${datadir}/lua' \
44 'INSTALL_LIB=${D}${libdir}' \
45 'INSTALL_CMOD=${D}${libdir}/lua/5.3' \
46 install
47 install -d ${D}${libdir}/pkgconfig
48
49 sed -e s/@VERSION@/${PV}/ ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc
50 install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/
51 rmdir ${D}${datadir}/lua/5.3
52 rmdir ${D}${datadir}/lua
53}
54
55do_install_ptest () {
56 cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV}-tests ${D}${PTEST_PATH}/test
57}
58
59BBCLASSEXTEND = "native nativesdk"