diff options
author | Li xin <lixin.fnst@cn.fujitsu.com> | 2016-04-15 04:06:49 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-06 12:38:31 +0200 |
commit | a61cb514258cbd0758ca575c0786ad6f651462ac (patch) | |
tree | 49ce73aa4d5301758b8c3afaa4e87f0c0b1da9e6 /meta-oe/recipes-devtools/ltrace | |
parent | 53adf32f49ce7ef82d9addbbfb9124f714c26494 (diff) | |
download | meta-openembedded-a61cb514258cbd0758ca575c0786ad6f651462ac.tar.gz |
ltrace: Error Fix for ARM
1) The error is as following:
root # ltrace ls
__libc_start_main(0xb6fbc018, 1, 0xbed8fdc4, 0xb6fd0b88PTRACE_SINGLESTEP: Input/output error
2747 couldn't continue when handling __libc_start_main (0xb6fbbde0) at 0xb6fbbde0
The master branch fix it.
2) remove unused patch:
--0001-ltrace-fix-gcc-5-logical-not-parentheses.patch
--ltrace-0.7.2-unused-typedef.patch
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/ltrace')
3 files changed, 2 insertions, 91 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace/0001-ltrace-fix-gcc-5-logical-not-parentheses.patch b/meta-oe/recipes-devtools/ltrace/ltrace/0001-ltrace-fix-gcc-5-logical-not-parentheses.patch deleted file mode 100644 index 681c43da0d..0000000000 --- a/meta-oe/recipes-devtools/ltrace/ltrace/0001-ltrace-fix-gcc-5-logical-not-parentheses.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From 876fe5680d77800426f8c4c5680a235732d722e6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Kai Kang <kai.kang@windriver.com> | ||
3 | Date: Mon, 24 Aug 2015 17:37:54 +0800 | ||
4 | Subject: [PATCH] ltrace: fix gcc 5 logical not parentheses | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Build ltrace with gcc 5.2, it fails with: | ||
9 | |||
10 | error: logical not is only applied to the left hand side of comparison | ||
11 | [-Werror=logical-not-parentheses] | ||
12 | if (!need_data(data, offset, SIZE / 8) < 0) \ | ||
13 | ^ | ||
14 | |||
15 | Function need_data just return 0 on success and -1 if fail. So it is ok | ||
16 | to just test if (need_data(data, offset, SIZE / 8) < 0). | ||
17 | |||
18 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
19 | --- | ||
20 | ltrace-elf.c | 2 +- | ||
21 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/ltrace-elf.c b/ltrace-elf.c | ||
24 | index c571d2a..7fe830f 100644 | ||
25 | --- a/ltrace-elf.c | ||
26 | +++ b/ltrace-elf.c | ||
27 | @@ -218,7 +218,7 @@ need_data(Elf_Data *data, GElf_Xword offset, GElf_Xword size) | ||
28 | int \ | ||
29 | NAME(Elf_Data *data, GElf_Xword offset, uint##SIZE##_t *retp) \ | ||
30 | { \ | ||
31 | - if (!need_data(data, offset, SIZE / 8) < 0) \ | ||
32 | + if (need_data(data, offset, SIZE / 8) < 0) \ | ||
33 | return -1; \ | ||
34 | \ | ||
35 | if (data->d_buf == NULL) /* NODATA section */ { \ | ||
36 | -- | ||
37 | 1.9.1 | ||
38 | |||
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace/ltrace-0.7.2-unused-typedef.patch b/meta-oe/recipes-devtools/ltrace/ltrace/ltrace-0.7.2-unused-typedef.patch deleted file mode 100644 index 8f3c0ecea1..0000000000 --- a/meta-oe/recipes-devtools/ltrace/ltrace/ltrace-0.7.2-unused-typedef.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | diff --git a/value.c b/value.c | ||
2 | index d18db17..b98298e 100644 | ||
3 | --- a/value.c | ||
4 | +++ b/value.c | ||
5 | @@ -1,6 +1,6 @@ | ||
6 | /* | ||
7 | * This file is part of ltrace. | ||
8 | - * Copyright (C) 2011,2012 Petr Machata, Red Hat Inc. | ||
9 | + * Copyright (C) 2011,2012,2013 Petr Machata, Red Hat Inc. | ||
10 | * | ||
11 | * This program is free software; you can redistribute it and/or | ||
12 | * modify it under the terms of the GNU General Public License as | ||
13 | @@ -282,9 +282,9 @@ value_init_deref(struct value *ret_val, struct value *valp) | ||
14 | if (value_extract_word(valp, &l, NULL) < 0) | ||
15 | return -1; | ||
16 | |||
17 | - /* We need "long" to be long enough to hold platform | ||
18 | + /* We need "long" to be long enough to hold target | ||
19 | * pointers. */ | ||
20 | - typedef char assert__long_enough_long[-(sizeof(l) < sizeof(void *))]; | ||
21 | + assert(sizeof(l) >= sizeof(arch_addr_t)); | ||
22 | |||
23 | value_common_init(ret_val, valp->inferior, valp, | ||
24 | valp->type->u.ptr_info.info, 0); | ||
25 | diff --git a/lens_default.c b/lens_default.c | ||
26 | index ed3d0e1..5d00814 100644 | ||
27 | --- a/lens_default.c | ||
28 | +++ b/lens_default.c | ||
29 | @@ -1,6 +1,6 @@ | ||
30 | /* | ||
31 | * This file is part of ltrace. | ||
32 | - * Copyright (C) 2011,2012 Petr Machata, Red Hat Inc. | ||
33 | + * Copyright (C) 2011,2012,2013 Petr Machata, Red Hat Inc. | ||
34 | * Copyright (C) 1998,2004,2007,2008,2009 Juan Cespedes | ||
35 | * Copyright (C) 2006 Ian Wienand | ||
36 | * Copyright (C) 2006 Steve Fink | ||
37 | @@ -342,9 +342,9 @@ format_array(FILE *stream, struct value *value, struct value_dict *arguments, | ||
38 | struct expr_node *length, size_t maxlen, int before, | ||
39 | const char *open, const char *close, const char *delim) | ||
40 | { | ||
41 | - /* We need "long" to be long enough to cover the whole address | ||
42 | - * space. */ | ||
43 | - typedef char assert__long_enough_long[-(sizeof(long) < sizeof(void *))]; | ||
44 | + /* We need "long" to be long enough to cover the whole target | ||
45 | + * address space. */ | ||
46 | + assert(sizeof(long) >= sizeof(arch_addr_t)); | ||
47 | long l; | ||
48 | if (expr_eval_word(length, value, arguments, &l) < 0) | ||
49 | return -1; | ||
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb index bc4e27166d..19899f9bd5 100644 --- a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb +++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb | |||
@@ -11,14 +11,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" | |||
11 | 11 | ||
12 | PE = "1" | 12 | PE = "1" |
13 | PV = "7.3+git${SRCPV}" | 13 | PV = "7.3+git${SRCPV}" |
14 | SRCREV = "37ecc41b58be3dbdd79592a76e331b5b371e4f81" | 14 | SRCREV = "01b10e191e99d8cb147e5a2b7da8196e0ec6fb94" |
15 | 15 | ||
16 | DEPENDS = "elfutils" | 16 | DEPENDS = "elfutils" |
17 | RDEPENDS_${PN} = "elfutils" | 17 | RDEPENDS_${PN} = "elfutils" |
18 | SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=ltrace-0.7 \ | 18 | SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=master \ |
19 | file://ltrace-0.7.2-unused-typedef.patch \ | ||
20 | file://configure-allow-to-disable-selinux-support.patch \ | 19 | file://configure-allow-to-disable-selinux-support.patch \ |
21 | file://0001-ltrace-fix-gcc-5-logical-not-parentheses.patch \ | ||
22 | " | 20 | " |
23 | S = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/git" |
24 | 22 | ||