summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/lshw/lshw_02.18.bb
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2018-06-06 20:33:24 +0200
committerKhem Raj <raj.khem@gmail.com>2018-06-08 00:57:29 -0700
commitfaa20de8833a31e725d28bc13c17af523c745fc9 (patch)
treefefb85c6e2f711dbb6b75c815558669534c8ec6a /meta-oe/recipes-devtools/lshw/lshw_02.18.bb
parent2ac1799a19f3fbbd01468892539ad2d989aace1e (diff)
downloadmeta-openembedded-faa20de8833a31e725d28bc13c17af523c745fc9.tar.gz
lshw: Add new recipe with B.02.18 version
Add new recipe for lshw B.02.18 version - a small tool to provide detailed information on the hardware configuration of the machine. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/lshw/lshw_02.18.bb')
-rw-r--r--meta-oe/recipes-devtools/lshw/lshw_02.18.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/lshw/lshw_02.18.bb b/meta-oe/recipes-devtools/lshw/lshw_02.18.bb
new file mode 100644
index 000000000..b344fbf32
--- /dev/null
+++ b/meta-oe/recipes-devtools/lshw/lshw_02.18.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "A small tool to provide detailed information on the hardware \
2configuration of the machine. It can report exact memory configuration, \
3firmware version, mainboard configuration, CPU version and speed, cache \
4configuration, bus speed, etc. on DMI-capable or EFI systems."
5SUMMARY = "Hardware lister"
6HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
7SECTION = "console/tools"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
13
14SRC_URI = " \
15 http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
16 file://0001-Makefile-Fix-cross-compilation.patch \
17 file://0002-Makefile-Use-supplied-LDFLAGS-to-silence-OE-GNU_HASH.patch \
18 file://0003-sysfs-Fix-basename-build-with-musl.patch \
19"
20SRC_URI[md5sum] = "8671c6d94d6324a744b7f21f1bfecfd2"
21SRC_URI[sha256sum] = "ae22ef11c934364be4fd2a0a1a7aadf4495a0251ec6979da280d342a89ca3c2f"
22
23S = "${WORKDIR}/lshw-B.${PV}"
24
25do_compile() {
26 # build core only - don't ship gui
27 oe_runmake -C src core
28}
29
30do_install() {
31 oe_runmake install DESTDIR=${D}
32}