summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/libsombok3
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-07-11 18:44:31 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:33 +0200
commit0112916134631681c66d6f9b92edfa0c2ad2f37f (patch)
treeb74d0def899265abe81cb79cc7e3a6a0c81357cf /meta-oe/recipes-devtools/libsombok3
parenta52f2cb2e93ead8f747cecfa2df12a9a6e144499 (diff)
downloadmeta-openembedded-0112916134631681c66d6f9b92edfa0c2ad2f37f.tar.gz
libsombok3: add recipe
Sombok - Unicode Text Segmentation Package. It's being depended by libunicode-linebreak-perl. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/libsombok3')
-rw-r--r--meta-oe/recipes-devtools/libsombok3/libsombok3/0001-configure.ac-fix-cross-compiling-issue.patch31
-rw-r--r--meta-oe/recipes-devtools/libsombok3/libsombok3_2.4.0.bb25
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/libsombok3/libsombok3/0001-configure.ac-fix-cross-compiling-issue.patch b/meta-oe/recipes-devtools/libsombok3/libsombok3/0001-configure.ac-fix-cross-compiling-issue.patch
new file mode 100644
index 000000000..1a6928707
--- /dev/null
+++ b/meta-oe/recipes-devtools/libsombok3/libsombok3/0001-configure.ac-fix-cross-compiling-issue.patch
@@ -0,0 +1,31 @@
1From 9c2ffe825e28d63e2a771135f297e8ffac0dbe81 Mon Sep 17 00:00:00 2001
2From: Ming Liu <liu.ming50@gmail.com>
3Date: Tue, 11 Jul 2017 14:35:30 +0200
4Subject: [PATCH] configure.ac: fix cross-compiling issue
5
6Avoid checking for file existence when cross compiling.
7
8Upstream-Status: Inappropriate [embedded specific]
9
10Signed-off-by: Ming Liu <liu.ming50@gmail.com>
11---
12 configure.ac | 3 ---
13 1 file changed, 3 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 9978852..06b16e3 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -120,9 +120,6 @@ AC_ARG_WITH(unicode-version,
20 AC_HELP_STRING(--with-unicode-version=VERSION,
21 [version of Unicode Standard @<:@default=current version@:>@]),
22 UNICODE_VERSION=$withval,UNICODE_VERSION=$DEFAULT_UNICODE_VERSION)
23-AC_CHECK_FILE([lib/$UNICODE_VERSION.c],
24- AC_MSG_RESULT($UNICODE_VERSION),
25- AC_MSG_ERROR(Unknown Unicode version $UNICODE_VERSION.))
26 AC_SUBST(UNICODE_VERSION)
27
28 # check if code to debug memory allocation is enabled.
29--
302.7.4
31
diff --git a/meta-oe/recipes-devtools/libsombok3/libsombok3_2.4.0.bb b/meta-oe/recipes-devtools/libsombok3/libsombok3_2.4.0.bb
new file mode 100644
index 000000000..b83e86a48
--- /dev/null
+++ b/meta-oe/recipes-devtools/libsombok3/libsombok3_2.4.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Sombok - Unicode Text Segmentation Package."
2DESCRIPTION = "Sombok library package performs Line Breaking Algorithm described in \
3Unicode Standard Annex #14 (UAX #14). East_Asian_Width informative \
4properties defined by Annex #11 (UAX #11) may be concerned to determin \
5breaking positions. This package also implements "default" Grapheme \
6Cluster segmentation described in Annex #29 (UAX #29)."
7LICENSE = "Artistic-1.0 | GPLv1+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5b122a36d0f6dc55279a0ebc69f3c60b"
9
10SRC_URI = "git://github.com/hatukanezumi/sombok.git;protocol=https \
11 file://0001-configure.ac-fix-cross-compiling-issue.patch \
12 "
13
14inherit autotools pkgconfig
15
16# sombok-2.4.0
17SRCREV = "0098d85a037ef5c99a648a3669a077781a45e8cc"
18
19S = "${WORKDIR}/git"
20B = "${S}"
21
22# Disable libthai support
23EXTRA_OECONF = "--disable-libthai"
24
25BBCLASSEXTEND = "native"